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Chapter 1 

Fundamental Skills  

Microsoft® Excel® is a tool that can be used in virtually all careers and is valuable in both 

professional and personal settings. Whether you need to keep track of medications in 

inventory for a hospital or create a financial plan for your retirement, Excel enables you to 

do these activities efficiently and accurately. This chapter introduces the fundamental skills 

necessary to get you started in using Excel. You will find that just a few skills can make you 

very productive in a short period of time.  

1.1 An Overview of Microsoft® Excel®  
LEARNING OBJECTIVES 

1. Examine the value of using Excel to make decisions  

2. Learn how to start Excel  

3. Become familiar with the Excel workbook  

4. Understand how to navigate worksheets  

5. Examine the Excel Ribbon  

6. Become familiar with the Quick Access Toolbar  

7. Examine the right-click menu options  

8. Become familiar with the commands in the File tab  

9. Learn how to save workbooks  

10. Examine the Status Bar  

11. Become familiar with the features in the Excel Help window 

 

Microsoft® Office contains a variety of tools that help people accomplish many personal 

and professional objectives. Microsoft Excel is perhaps the most versatile and widely used 

of all the Office applications. No matter which career path you choose, you will likely need 

to use Excel to accomplish your professional objectives, some of which may occur daily.  

This chapter provides an overview of the Excel application along with an orientation for 

accessing the commands and features of an Excel workbook.  
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Making Decisions with Excel  

Follow-along file: Not needed for this skill  

Taking a very simple view, Excel is a tool that allows you to enter quantitative data into an 

electronic spreadsheet to apply one or many mathematical computations. These 

computations ultimately convert that quantitative data into information. The information 

produced in Excel can be used to make decisions in both professional and personal 

contexts. For example, employees can use Excel to determine how much inventory to buy 

for a clothing retailer, how much medication to administer to a patient, or how much 

money to spend to stay within a budget. With respect to personal decisions, you can use 

Excel to determine how much money you can spend on a house, how much you can spend 

on car lease payments, or how much you need to save to reach your retirement goals. We 

will demonstrate how you can use Excel to make these decisions and many more 

throughout this text.  

Figure 1.1 "Example of an Excel Worksheet with Embedded Chart" shows a completed Excel 

worksheet that will be constructed in this chapter. The information shown in this 

worksheet is top-line sales data for a hypothetical merchandise retail company. The 

worksheet data can help this retailer determine the number of salespeople needed for each 

month, how much inventory is needed to satisfy sales, and what types of products should 

be purchased. Notice that the embedded chart makes it very easy to see which months have 

the highest unit sales.  

Figure 1.1 Example of an Excel Worksheet with Embedded Chart 
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Starting Excel  

Follow-along file: Not needed for this skill  

The following steps will guide you in starting the Excel application. Note that these steps 

along with Figure 1.2 "Start Menu" relate to the Windows 10 operating system.  

1. Click the Windows button on the lower left corner of your computer screen. 

2. Start typing Excel. You will see Excel pop up as an option.  

3. Click the Microsoft Excel 2016 option. This will start the Excel application. 

Figure 1.2 Start Menu  

 

The Excel Workbook  

Once Excel is started, a blank workbook will open on your screen. A workbook is an Excel  
file that contains one or more worksheets (sometimes referred to as spreadsheets). Excel 

will assign a file name to the workbook, such as Book1, Book2, Book3, and so on, depending 

on how many new workbooks are opened.  
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Navigating Worksheets  

Follow-along file: Not needed for this skill  

Data are entered and managed in an Excel worksheet. The worksheet contains several 

rectangles called cells for entering numeric and nonnumeric data. Each cell in an Excel 

worksheet contains an address, which is defined by a column letter followed by a row   

number. For example, the cell that is currently activated in Worksheet" is A1. This 

would be referred to as cell location A1 or cell reference A1. The following steps explain 

how you can navigate in an Excel worksheet:  

1. Place your mouse pointer over cell D5 and left click. Check to make sure column letter D  

and row number 5 are highlighted in gray, as shown in Figure 1.5 "Activating a Cell  

Location".  

2. Move the mouse pointer to cell A1.  

3. Click and hold the left mouse button and drag the mouse pointer back to cell D5.  

4. Release the left mouse button. You should see several cells highlighted, as shown in 

Figure 1.6 "Highlighting a Range of Cells". This is referred to as a cell range and is 

documented as follows: A1:D5. Any two cell locations separated by a colon are known 

as a cell range. The first cell reference is the top left corner of the range, and the second 

cell reference is the lower right corner of the range  
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. 

5. Click the + in the circle to create a new worksheet. Excel 2016 comes with only 1 

worksheet in a new workbook.   

6. Click the Sheet2 worksheet tab at the bottom of the worksheet. This is how you open a 

worksheet within a workbook.  

7. Click the Sheet1 worksheet tab at the bottom of the worksheet to return to the 

worksheet shown   

 
 

The Excel Ribbon  

Excel’s features and commands are found in the Ribbon, which is the upper area of the 

Excel screen that contains several tabs running across the top. Each tab provides access to 

a different set of Excel commands. Figure 1.7 "Ribbon for Excel" shows the commands 

available in the Home tab of the Ribbon. Table 1.1 "Command Overview for Each Tab of the 

Ribbon" provides an overview of the commands that are found in each tab of the Ribbon.  
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Figure 1.7 Ribbon for Excel 

 
  

Table 1.1 Command Overview for Each Tab of the Ribbon  

Tab Name  Description of Commands 

File Also known as the Backstage view of the Excel workbook. Contains all 

commands for opening, closing, saving, and creating new Excel 

workbooks.  Includes print commands, document properties, e-mailing 

options, and help features. The default settings and options are also found 

in this tab. 

Home Contains the most frequently used Excel commands. Formatting commands 

are found in this tab along with commands for cutting, copying, pasting, and 

for inserting and deleting rows and columns. 

Insert  Used to insert objects such as charts, pictures, shapes, PivotTables, 

Internet links, symbols, or text boxes. 

Page 
Layout  

Contains commands used to prepare a worksheet for printing. Also 

includes commands used to show and print the gridlines on a worksheet. 

Formulas  Includes commands for adding mathematical functions to a worksheet. 

Also contains tools for auditing mathematical formulas. 

Data Used when working with external data sources such as Microsoft® 

Access®, text files, or the Internet. Also contains sorting commands and 

access to scenario tools. 

Review  Includes Spelling and Track Changes features. Also contains protection 

features to password protect worksheets or workbooks. 

View  Used to adjust the visual appearance of a workbook. Common 

commands include the Zoom and Page Layout view. 

The Ribbon shown in Figure 1.7 "Ribbon for Excel" is full or maximized. The benefit of 
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having a full Ribbon is that the commands are always visible while you are developing a 

worksheet. However, depending on the screen dimensions of your computer, you may find 

that the Ribbon takes up too much vertical space on your worksheet. If this is the case, you 

can minimize the Ribbon by clicking the button shown in Figure 1.7 "Ribbon for Excel". 

When minimized, the Ribbon will show only the tabs and not the command buttons. When 

you click on a tab, the command buttons will appear until you select a command or click 

anywhere on your worksheet. 

 

Keyboard Shortcuts - Minimizing or Maximizing the Ribbon 

1. Hold down the CTRL key and press the F1 key  

2. Hold down the CTRL key and press the F1 key again to maximize the Ribbon 

 

Quick Access Toolbar and Right-Click Menu  

The Quick Access Toolbar is found at the upper left side of the Excel screen above the 

Ribbon. This area provides access to the most frequently used commands, such as Save and 

Undo. You also can customize the Quick Access Toolbar by adding commands that you use 

on a regular basis. By placing these commands in the Quick Access Toolbar, you do not have 

to navigate through the Ribbon to find them. To customize the Quick Access Toolbar, click 

the down arrow as shown in Figure 1.8 "Customizing the Quick Access Toolbar". This will 

open a menu of commands that you can add to the Quick Access Toolbar. If you do not see 

the command, you are looking for on the list, select the More Commands option.  

Figure 1.8 Customizing the Quick Access Toolbar 
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In addition to the Ribbon and Quick Access Toolbar, you can also access commands by right 

clicking anywhere on the worksheet. Figure 1.9 "Right-Click Menu" shows an example of 

the commands available in the right-click menu.  

Figure 1.9 Right-Click Menu  

 

The File Tab  

If you have used Office 2007, you may have noticed that the Office button has disappeared 

in the 2016 version. It has been replaced with the File tab on the far-left side of the Ribbon.  

The File tab is also known as the Backstage view of the workbook. It contains a variety of 

features and commands related to the workbook that is currently open, new workbooks, or 

workbooks stored in other locations on your computer or network. Figure 1.10 "File Tab 

or Backstage View of a Workbook" shows the options available in the File tab or Backstage 

view. To leave the Backstage view and return to the worksheet, click any tab on the Ribbon 
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or click the image of the worksheet on the right side of the window. You must click the Info 

button (highlighted in green in Figure 1.10 "File Tab or Backstage View of a Workbook") to 

see the image of your worksheet on the right side of the window.  

Figure 1.10 File Tab or Backstage View of a Workbook  

 
Included in the File tab are the default settings for the Excel application that can be 

accessed and modified by clicking the Options button. Figure 1.11 "Excel Options Window” 

shows the Excel Options window, which gives you access to settings such as the default font 

style, font size, and the number of worksheets that appear in new workbooks. 
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Figure 1.11 Excel Options Window  

 

Saving Workbooks (Save As)  

Once you create a new workbook, you will need to change the file name and choose a 

location on your computer or network to save it. The following steps explain how to save a 

new workbook and assign it a file name. It is important to remember where you save this 

workbook on your computer or network as you will be using this file in the Section 1.2 

“Entering, Editing, and Managing Data" to construct the workbook shown in Figure 1.1  

"Example of an Excel Worksheet with Embedded Chart".  

1. If you have not done so already, start Excel. A blank workbook should appear on your 

screen.  

2. Check to make sure the workbook is maximized (see Figure 1.4 "Restored Worksheet"). 

3. Click the File tab. 

4. Click the Save As button in the upper left side of the Backstage view window, as shown 

in Figure 1.10 "File Tab or Backstage View of a Workbook". This will open the Save As 

dialogbox.  

5. Click in the File Name box at the bottom of the Save As dialog box.  
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6. Use the BACKSPACE key to remove the current file name of the workbook. 

7. Type the file name: Excel Objective 1.0.  

8. Click the Desktop button on the left side of the Save As dialog box if you wish to save this 

file on your desktop. If you want to save this workbook in a different location on your 

computer or network, double click the Computer option, as shown in Figure 1.12 "Save  

As Dialog Box", and select your preferred location.  

9. Click the Save button on the lower right side of the Save As dialog box.  

Figure 1.12 Save As Dialog Box- 
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The Status Bar  

The Status Bar is located below the worksheet tabs on the Excel screen (see Figure 1.15 

“Customizing the Status Bar"). It displays a variety of information, such as the status of 

certain keys on your keyboard (e.g., CAPS LOCK), the available views for a workbook, the 

magnification of the screen, and mathematical functions that can be performed when data  

are highlighted on a worksheet. You can customize the Status Bar as follows:  

1. Place the mouse pointer over any area of the Status Bar and right click (see Figure 1.15 

“Customizing the Status Bar").  

2. Select the Caps Lock option from the menu (see Figure 1.15 "Customizing the Status 

Bar").  

3. Press the CAPS LOCK key on your keyboard. You will see the Caps Lock indicator on the 

lower right side of the Status Bar.  

4. Press the CAPS LOCK key again. The indicator on the Status Bar goes away.  

  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                13 

  

Figure 1.15 Customizing the Status Bar 

 

 
. 

Excel Help  

Follow-along file: Continue with a blank workbook or open a new one.  

The Help feature provides extensive information about the Excel application. Although 

some of this information may be stored on your computer, the Help window will 

automatically connect to the Internet, if you have a live connection, to provide you with 

resources that can answer most of your questions. You can open the Excel Help window by 

clicking the question mark in the upper right corner of the screen. Here you can search for 

specific topics or type a  question in the upper- left side of the window, as shown in Figure 

1.16 "Excel Help  Window".  
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Figure 1.16 Excel Help Window 
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1.2 Entering, Editing, and Managing Data  

 
 

In this section, we will begin the development of the workbook shown in Figure 1.1 "Example 

of an Excel Worksheet with Embedded Chart". The skills covered in this section are typically 

used in the early stages of developing one or more worksheets in a workbook. A theme we 

will continue to pursue in this book is making your spreadsheets tell a story all by itself.  

Meaning, a person can look at the spreadsheet and know exactly what information the 

spreadsheet is conveying.  

Entering Data  

Follow-along file: Excel Objective 1.0 (This is a blank workbook that was named in the previous 

section. If you skipped the previous section, open a new workbook and save it with the file name 

“Excel Objective 1.0.”)  

The XYZ Corporation has sales data they would like to have put into a worksheet. They 

want it professionally formatted and include an embedded chart. The sales data they are 

giving you is for the year 2017.  

We will begin building the workbook shown in Figure 1.1 "Example of an Excel Worksheet 

with Embedded Chart" by manually entering data into the worksheet. There are other ways 

in which you can bring data into an Excel worksheet, such as importing data from a website 

or a Microsoft Access database. However, we will demonstrate these other methods later.  

The following steps explain how the column headings in Row 2 are typed into the  

worksheet:  
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1. Activate cell location A2 on the worksheet.  

2. Type the word Month. Press the RIGHT ARROW key. This will enter the word into cell A2 

and activate the next cell to the right.  

3. Type Unit Sales and press the RIGHT ARROW key.  

4. Repeat step 4 for the words Average Price and SalesDollars.  

Figure 1.17 "Entering Column Headings into a Worksheet" shows how your worksheet 

should appear after you have typed the column headings into Row 2. Notice that the word 

Price in cell location C2 is not visible. This is because the column is too narrow to fit the 

entry you typed. We will examine formatting techniques to correct this problem in the next 

section.  

Figure 1.17 Entering Column Headings into a Worksheet 

 
. 
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5. Activate cell location B3. Type the number 2670 and press the ENTER key. After you 

press the ENTER key, cell B4 will be activated. Using the ENTER key is an efficient 

way to enter data vertically down a column.  

6. Repeat step 5 by entering the following numbers in cells B4 through B14:2160, 515,  

590, 1030, 2875, 2700, 900, 775, 1180, 1800,and 3560.  

7. Activate cell location C3.  

8. Type the number 9.99 and press the ENTER key.  

9. Repeat step 8 by entering the following numbers in cells C4 through C14:12.49, 14.99,  

17.49, 14.99, 12.49, 9.99, 19.99, 19.99, 19.99, 17.49, and14.99.  

10. Activate cell location D3.  

11. Type the number 26685 and press the ENTER key.  

12. Repeat step 12 by entering the following numbers in cells D4through D14:26937,  

7701, 10269, 15405, 35916, 26937, 17958, 15708, 23562,31416, and 53370. 

 

 
 

 
 

 

Figure 1.18 "Completed Data Entry for Columns B, C, and D" shows how your worksheet 

should appear after entering the data. Check your numbers carefully to make sure they are 

accurately entered into the worksheet.  
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Figure 1.18 Completed Data Entry for Columns B, C, and D 

 
. 

Editing Data  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.01 if you are starting with 

this skill.)  

Data that has been entered in a cell can be changed by:  

• double clicking the cell location  

• clicking in the Formula Bar  

• clicking the F2 function key while the cell is active.  

You may have noticed that as you were typing data into a cell location, the data you typed 

appeared in the Formula Bar. The Formula Bar can be used for entering data into cells as well 

as for editing data that already exists in a cell.   

The following steps provide an example of entering and then editing data that has been 

entered into a cell location:  
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1. Activate cell A15 in the Sheet1 worksheet.  

2. Type the abbreviation Tot and press the ENTER key.  

3. Click cell A15.  

4. Move the mouse pointer up to the Formula Bar. You will see the pointer turn into a 

cursor. Move the cursor to the end of the abbreviation Tot and left click.  

5. Type the letters al to complete the word Total.  

6. Click the checkmark to the left of the Formula Bar (see Figure 1.19 "Using the Formula 

Bar to Edit and Enter Data"). This will enter the change into the cell.  

7. Double click cell A15.  

8. Add a space after the word Total and type the word Sales.  

9. Press the ENTER key. 
. 

Figure 1.19 Using the Formula Bar to Edit and Enter Data  
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Auto Fill  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.02 if you are starting with this 

skill.)  

The Auto Fill feature is a valuable tool when manually entering data into a worksheet. This 

feature has many uses, but it is most beneficial when you are entering data in a defined 

sequence, such as the numbers 2, 4, 6, 8, and so on, or nonnumeric data such as the days of  

the week or months of the year. The following steps demonstrate how Auto Fill can be used 

to enter the months of the year in Column A:  

1. Activate cell A3 in the Sheet1worksheet.  

2. Type the word January and press the ENTER key. 
. 

3. Activate cell A3 again.  

4. Move the mouse pointer to the lower right corner of cell A3. You will see a small square 

in this corner of the cell; this is called the Fill Handle (see Figure 1.20 "Fill Handle").  

When the mouse pointer gets close to the Fill Handle, the white block plus sign will turn 

into a black plus sign.  

5. Left click and drag the Fill Handle to cell A14. Notice that the Auto Fill tip box indicates 

what month will be placed into each cell (see Figure 1.21 "Using Auto Fill to Enter the 

Months of the Year"). Release the left mouse button when the tip box reads “December.”  

Figure 1.20 Fill Handle 
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Figure 1.21 Using Auto Fill to Enter the Months of the Year  

 
 
Once you release the left mouse button, all twelve months of the year should appear in the 

cell range A3:A14, as shown in Figure 1.22 "Auto Fill Options Button". You will also see the 

Auto Fill Options button. By clicking this button, you have several options for inserting data 

into a group of cells.  

6. Left click the Auto Fill Options button.  

7. Left click the Copy Cells option. This will change the months in the range A4:A14 to 

January.  

8. Left click the Auto Fill Options button again.  

9. Left click the Fill Months option to return the months of the year to the cell range 

A4:A14. The Fill Series option will provide the same result. 
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. 

 
Figure 1.22 Auto Fill Options Button  

 
 

Deleting Data and the Undo Command  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.03 if starting with this skill.)  

There are several methods for removing data from a worksheet, a few of which are 

demonstrated here. With each method, you use the Undo command. This is a helpful 

command in the event you mistakenly remove data from your worksheet.  
. 

The following steps demonstrate how you can delete data from a cell or range of cells:  

1. Activate cell C2 by placing the mouse pointer over the cell and clicking the left mouse 

button.  
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2. Press the DELETE key on your keyboard. This removes the contents of the cell.  

3. Highlight the range C3:C14 by placing the mouse pointer over cell C3. Then left click and 

drag the mouse pointer down to cell C14.  

4. Place the mouse pointer over the Fill Handle. You will see the white block plus sign 

change to a black plus sign.  

5. Left click and drag the mouse pointer up to cell C3 (see Figure 1.23 "Using Auto Fill to 

Delete Contents of Cell"). Release the mouse button. The contents in the range C3:C14 

will be removed.  

Figure 1.23 Using Auto Fill to Delete Contents of Cell  

 
6. Click the Undo button in the Quick Access Toolbar. This should replace the data in the 

range C3:C14.  

7. Click the Undo button again. This should replace the data in cellC2. 
. 

8. Highlight the range C2:C14 by placing the mouse pointer over cell C2. Then left click and 

drag the mouse pointer down to cell C14.  

9. Click the Clear button in the Home tab of the Ribbon, which is next to the Cells group of 

commands (see Figure 1.24 "Clear Command Drop-Down Menu"). This opens a drop 

down menu that contains several options for removing or clearing data from a cell.  

Notice that you also have options for clearing just the formats in a cell or the 
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hyperlinks in a cell.  

10. Click the Clear All option. This removes the data in the cell range.  

11. Click the Undo button. This replaces the data in the range C2:C14.  

Figure 1.24 Clear Command Drop-Down Menu 

 

 

 
 

. 

Adjusting Columns and Rows  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.03 if starting with this skill.)  

In Figure 1.22 "Auto Fill Options Button", there are a few entries that appear cut off. For 

example, the last letter of the word September cannot be seen in cell A11. This is because 

the column is too narrow for this word. The columns and rows on an Excel worksheet can 

be adjusted to accommodate the data that is being entered into a cell. The following steps 

explain how to adjust the column widths and row heights in a worksheet:  

1. Bring the mouse pointer between Column A and Column B in the Sheet1 worksheet, as 

shown in Figure 1.25 "Adjusting Column Widths". You will see the white block plus sign 

turn into double arrows.  

2. Left click and drag the column to the right so the entire word September in cell A11 can 
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be seen. As you drag the column, you will see the column width tip box. This box 

displays the number of characters that will fit into the column using the Calibri 11-point 

font.  

3. Release the left mouse button.  

Figure 1.25 Adjusting Column Widths 

 
. 

You may find that using the click-and-drag method is inefficient if you need to set a specific 

character width for one or more columns. Steps 4 through 7 illustrate a second method for 

adjusting column widths when using a specific number of characters:  

4. Activate any cell location in Column A by moving the mouse pointer over a cell location 

and clicking the left mouse button. You can highlight cell locations in multiple columns 

if you are setting the same character width for more than one column.  

5. In the Home tab of the Ribbon, left click the Format button in the Cells group (see Figure 

1.26 "Cells Group in the Home Tab").  

6. Click the Column Width option from the drop-down menu (see Figure 1.27 "Format 

Drop-Down Menu"). This will open the Column Width dialog box.  

7. Type the number 13 and click the OK button on the Column Width dialog box. This will 

set Column A to this character width (see Figure 1.28 "Column Width Dialog Box").  

  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                26 

  

Figure 1.26 Cells Group in the Home Tab 

 
. 

Figure 1.27 Format Drop-Down Menu  
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Figure 1.28 Column Width Dialog Box 

 
  

 
 

The following steps demonstrate how to adjust row height, which is similar to adjusting 

column width:  

1. Activate cell A15 by placing the mouse pointer over the cell and clicking the left mouse 

button.  

2. In the Home tab of the Ribbon, left click the Format button in the Cells group (see Figure 

1.26 "Cells Group in the Home Tab").  

3. Click the Row Height option from the drop-down menu (see Figure 1.27 "Format Drop 

Down Menu"). This will open the Row Height dialog box.  

4. Type the number 24 and click the OK button on the Row Height dialog box. This will set 

Row 15 to a height of 24 points. A point is equivalent to approximately 1/72 of an inch.  

This adjustment in row height was made to create space between the totals for this 

worksheet and the rest of the data.  

Figure 1.29 "Excel Objective 1.0 with Column A and Row 15 Adjusted" shows the 

appearance of the worksheet after Column A and Row 15 are adjusted.  
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Figure 1.29 Excel Objective 1.0 with Column A and Row 15 Adjusted 

 
. 

 
 

Hiding Columns and Rows  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.04 if starting with this skill.)  

In addition to adjusting the columns and rows on a worksheet, you can also hide columns 

and rows. This is a useful technique for enhancing the visual appearance of a worksheet 

that contains data that is not necessary to display. These features will be demonstrated 

using the Excel Objective 1.0 workbook. However, there is no need to have hidden columns 

or rows for this worksheet. The use of these skills here will be for demonstration purposes 

only.  
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1. Activate cell C1 in the Sheet1 worksheet by placing the mouse pointer over the cell 

location and clicking the left mouse button.  

2. Click the Format button in the Home tab of the Ribbon.  

3. Place the mouse pointer over the Hide & Unhide option in the drop-down menu (see 

Figure 1.27 "Format Drop-Down Menu"). This will open a submenu of options.  

4. Click the Hide Columns option in the submenu of options (see Figure 1.30 "Hide & 

Unhide Submenu"). This will hide Column C. 

Figure 1.30 Hide & Unhide Submenu  

 

  

Figure 1.31 "Hidden Column" shows the workbook with Column C hidden in the Sheet1 

worksheet. You can tell a column is hidden by the missing letter C.  

Figure 1.31 Hidden Column  
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To unhide a column, follow these steps:  

1. Highlight the range B1:D1 by activating cell B1 and clicking and dragging over to cell D1. 
. 

2. Click the Format button in the Home tab of the Ribbon.  

3. Place the mouse pointer over the Hide & Unhide option in the drop-down menu (see 

Figure 1.27 "Format Drop-Down Menu").  

4. Click the Unhide Columns option in the submenu of options (see Figure 1.30 "Hide & 

Unhide Submenu"). Column C will now be visible on the worksheet.  

 
 

The following steps demonstrate how to hide rows, which is similar to hiding columns:  

1. Activate cell A3 in the Sheet1 worksheet by placing the mouse pointer over the cell 

location and clicking the left mouse button.  

2. Click the Format button in the Home tab of the Ribbon.  

3. Place the mouse pointer over the Hide & Unhide option in the drop-down menu (see 

Figure 1.27 "Format Drop-Down Menu"). This will open a submenu of options.  

4. Click the Hide Rows option in the submenu of options (see Figure 1.30 "Hide & Unhide 

Submenu"). This will hide Row 3.  

 
 

To unhide a row, follow these steps:  

1. Highlight the range A2:A4 by activating cell A2 and clicking and dragging over to cell A4. 

2. Click the Format button in the Home tab of the Ribbon.  

3. Place the mouse pointer over the Hide & Unhide option in the drop-down menu (see 

Figure 1.27 "Format Drop-Down Menu").  

4. Click the Unhide Rows option in the submenu of options (see Figure 1.30 "Hide & 

Unhide Submenu"). Row 3 will now be visible on the worksheet. 
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Inserting Columns and Rows  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.04 if starting with this skill.)  

Using Excel workbooks that have been created by others is a very efficient way to work 

because it eliminates the need to create data worksheets from scratch. However, you may 

find that to accomplish your goals, you need to add additional columns or rows of data. In 

this case, you can insert blank columns or rows into a worksheet. The following steps 

demonstrate how to do this:  

1. Activate cell C1 in the Sheet1 worksheet by placing the mouse pointer over the cell 

location and clicking the left mouse button.  

2. Click the down arrow on the Insert button in the Home tab of the Ribbon (see Figure 

1.32 "Insert Button (Down Arrow)").  

3. Click the Insert Sheet Columns option from the drop-down menu (see Figure 1.33 “Insert 

Drop- Down Menu"). A blank column will be inserted to the left of Column C. The 

contents that were previously in Column C now appear in Column D. Note that columns 

are always inserted to the left of the activated cell. 

4. Activate cell A3 in the Sheet1 worksheet by placing the mouse pointer over the cell 

location and clicking the left mouse button.  

5. Click the down arrow on the Insert button in the Home tab of the Ribbon (see Figure 

1.32 "Insert Button (Down Arrow)"). 

 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                32 

  

 
. 

Figure 1.32 Insert Button (Down Arrow)  

 

 
 

Figure 1.33 Insert Drop-Down Menu  

 
. 

6. Click the Insert Sheet Rows option from the drop-down menu (see Figure 1.33 "Insert 

Drop-Down Menu"). A blank row will be inserted above Row 3. The contents that were 

previously in Row 3 now appear in Row 4. Note that rows are always inserted above 

the activated cell.  
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Moving Data  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.05 if you skipped the previous 

skill and are starting with this skill.)  

Once data are entered into a worksheet, you can move it to different locations. The 

following steps demonstrate how to move data to different locations on a 

worksheet:  

1. Highlight the range D2:D15 by activating cell D2 and clicking and dragging down to cell 

D15.  

2. Bring the mouse pointer to the left edge of cell D2. You will see the white block plus sign 

change to cross arrows (see Figure 1.34 "Moving Data"). This indicates that you can left 

click and drag the data to a new location.  

3. Left click and drag the mouse pointer to cellC2.  

4. Release the left mouse button. The data now appears in Column C.  

5. Click the Undo button in the Quick Access Toolbar. This moves the data back to Column D. 
. 
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Figure 1.34 Moving Data  

 

  
 

Deleting Columns and Rows  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.05 if starting with this skill.)  

You may need to delete entire columns or rows of data from a worksheet. This need may 

arise if you need to remove either blank columns or rows from a worksheet or columns and 

rows that contain data. The methods for removing cell contents were covered earlier and 

can be used to delete unwanted data.  

However, if you do not want a blank row or column in your workbook, you can delete it 

using the following steps:  

1. Activate cell A3 by placing the mouse pointer over the cell location and clicking the left 

mouse button.  

2. Click the down arrow on the Delete button in the Cells group in the Home tab of the 

Ribbon.  

3. Click the Delete Sheet Rows option from the drop-down menu (see Figure 1.35 "Delete Drop- 
Down Menu"). This removes Row 3 and shifts all the data (below Row 2) in the worksheet up one 
row.  
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Figure 1.35 Delete Drop-Down Menu  

 
4. Activate cell C1 by placing the mouse pointer over the cell location and clicking the left 

mouse button.  

5. Click the down arrow on the Delete button in the Cells group in the Home tab of the 

Ribbon.  

6. Click the Delete Sheet Columns option from the drop-down menu (see Figure 1.35 

“Delete Drop- Down Menu"). This removes Column C and shifts all the data in the 

worksheet (to the right of Column B) over one column to the left. 
. 
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. 
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1.3 Formatting and Data Analysis  
 

  
 

This section addresses formatting commands that can be used to enhance the visual 

appearance of a worksheet. It also introduces mathematical calculations and charts. The 

skills introduced in this section will give you powerful tools for analyzing the data that we  

have been working with in this workbook and will highlight how Excel is used to make key  

decisions in virtually any career.  

Formatting Data and Cells  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.04 if starting with this skill.)  

Enhancing the visual appearance of a worksheet is a critical step in creating a valuable tool 

for you or your coworkers when making key decisions. The following steps demonstrate 

several fundamental formatting skills that will be applied to the workbook that we are 

developing for this chapter. Several of these formatting skills are identical to ones that you 

may have already used in other Microsoft applications such as Microsoft® Word® or 

Microsoft® PowerPoint®.  

1. Highlight the range A2:D2 in the Sheet1 worksheet by placing the mouse pointer over 

cell A2 and left clicking and dragging to cell D2.  

2. Click the Bold button in the Font group of commands in the Home tab of the Ribbon (see 

Figure 1.36 "Font Group of Commands"). 
. 
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Figure 1.36 Font Group of Commands  

 
3. Highlight the range B15:D15 by placing the mouse pointer over cell A15 and left clicking 

and dragging to cell D15.  

4. Click the Bold button in the Font group of commands in the Home tab of the Ribbon. 

5. Click the Italics button in the Font group of commands in the Home tab of the Ribbon.  

6. Highlight the range B15:D15. Click the drop-down arrow next to the Borders button in 

the Font group of commands in the Home tab of the Ribbon. From the drop-down, select 

the Top and Double Bottom border style. This is a standard business/accounting 

presentation of totals in a worksheet and denotes the end of a set of data.  

Figure 1.36b Border Icon  

 

7. Highlight the range B3:B14 by placing the mouse pointer over cell B3 and left clicking 

and dragging down to cell B14. 
. 

8. Click the Comma Style button in the Number group of commands in the Home tab of the 

Ribbon (see Figure 1.37 "Number Group of Commands").  
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Figure 1.37 Number Group of Commands  

 
9. Click the Decrease Decimal button in the Number group of commands in the Home tab 

of the Ribbon (see Figure 1.37 "Number Group of Commands").  

10. The numbers will also be reduced to zero decimal places.  

11. Highlight the range C3:D3 by placing the mouse pointer over cell C3 and left clicking 

and dragging across to cell D3.  

12. Click the Accounting Number Format button in the Number group of commands in the 

Home tab of the Ribbon (see Figure 1.37 "Number Group of Commands"). This will add 

the US currency symbol and two decimal places to the values. This format is common 

when working with pricing data. 

 
 

. 
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13. Highlight the range C4:D14 by placing the mouse pointer over cell D3 and left 

clicking and dragging down to cell D14.  

14. Click the Comma symbol to the values as well as two decimal places.  

15. Highlight D3:D14 and click the Decrease Decimal button twice in the Number group 

of commands in the Home tab of the Ribbon. You are decreasing the decimals to none 

because the Sales Dollars do not have any cents displayed. Decimal places when only 

zeroes are displayed adds clutter to your worksheet.  

16. This will add the comma style to the values and reduce the decimal places to zero. 

The comma style aligns the numbers in the cells with the Accounting style where $ 

are displayed.  

17. Highlight the range A1:D1 by placing the mouse pointer over cell A1 and left 

clicking and dragging over to cell D1.  

18. Click the down arrow next to the Fill Color button in the Font group of commands in 

the Home tab of the Ribbon (see Figure 1.38 "Fill Color Palette"). 
. 

19. Click the Aqua, Accent 5, Darker 25% color from the palette (see Figure 1.38 "Fill Color 

Palette").  

Notice that as you move the mouse pointer over the color palette, you will see a preview 

of how the color will appear in the highlighted cells.  

 
  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                41 

  

Figure 1.38 Fill Color Palette  

 

20. Click the down arrow next to the Font Color button in the Font group of commands 

in the Home tab of the Ribbon (see Figure 1.36 "Font Group of Commands"), and 

select White for the font color. This change will be visible once text is typed into the 

highlighted cells.  

21. Click the Increase Font Size button in the Font group of commands in the Home tab of 

the Ribbon (see Figure 1.38 "Fill Color Palette"). Each click will increase the font size 1 

point.  

22. Highlight the range A1:D15 by placing the mouse pointer over cell A1 and left 

clicking and dragging down to cell D15.  

23. Click the drop-down arrow on the right side of the Font button in the Home tab of 

the Ribbon (see Figure 1.36 "Font Group of Commands").  

24. Notice that as you move the mouse pointer over the font style options, you can see 

the font change in the highlighted cells. 
. 

25. Expand the row width of Column D to 10 characters.  

Figure 1.39 "Formatting Techniques Applied" shows how the Sheet1 worksheet should 

appear after the formatting techniques are applied.  

  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                42 

  

Figure 1.39 Formatting Techniques Applied 

 

 
. 
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1.4 Data Alignment  

Data Alignment (Wrap Text, Merge Cells, and Center)  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.06 if starting with this skill.)  

The skills presented in this segment show how data are aligned within cell locations. For 

example, text and numbers can be centered in a cell location, left justified, right justified, 

and so on. In some cases, you may want to stack multiword text entries vertically in a cell.   

instead of expanding the width of a column. This is referred to as wrapping text. These 

skills are demonstrated in the following steps:  

1. Highlight the range B2:D2 by placing the mouse pointer over cell B2 and left clicking and 

dragging over to cell D2.  

2. Click the Center button in the Alignment group of commands in the Home tab of the 

Ribbon (see Figure 1.40 "Alignment Group in Home Tab"). This will center the column 

headings in each cell location.  

Figure 1.40 Alignment Group in Home Tab 

 
. 

3. Click the Wrap Text button in the Alignment group (see Figure 1.40 "Alignment Group in 

Home Tab"). The height of Row 2 automatically expands, and the words that were cut 

off because the columns were too narrow are now stacked vertically (see Figure 1.42  

"Sheet1 with Data Alignment Features Added").  
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4. Highlight the range A1:D1 by placing the mouse pointer over cell A1 and left clicking 

and dragging over to cell D1.  

5. Click the down arrow on the right side of the Merge & Center button in the Alignment 

group of commands in the Home tab of the Ribbon.  

6. Left click the Merge & Center option (see Figure 1.41 "Merge Cell Drop-Down Menu"). 

This will create one large cell location running across the top of the dataset with 

centered text. 

 
Figure 1.41 Merge Cell Drop-Down Menu  
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Figure 1.42 "Sheet1 with Data Alignment Features Added" shows the Sheet1 worksheet 

with the data alignment commands applied. The reason for merging the cells in the range 

A1:D1 will become apparent in the next segment. 

 
Figure 1.42 Sheet1 with Data Alignment Features Added 

 
. 
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Creating Multi-Line Worksheet Titles  

Your worksheets need to tell their story without a person there to explain them. They need 
to be clearly labeled and formatted for ease of understanding. However, one important part 
of the story that often gets left out is the title of the story. All worksheets should include an   
informative title that describes the contents of the worksheet and the date, or range of 
dates, the data pertains to. We will include a title.  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.07 if starting with this skill.)  

In the Sheet1 worksheet, the cells in the range A1:D1 were merged for the purposes of 

adding a title to the worksheet. This title will require that three lines of text be entered into 

a cell. The following steps explain how you can enter text into a cell and determine where 

you want the second line of text to begin:  

1. Activate cell A1 in the Sheet1 worksheet by placing the mouse pointer over cell A1 and 

clicking the left mouse button. Since the cells were merged, clicking cell A1 will 

automatically activate the range A1:D1.  

2. Type the text General Merchandise World.  

3. Hold down the ALT key and press the ENTER key. This will start a new line of text in 

this cell location.  
 

4. Type the text 2017 Retail Sales (in millions) and press the ENTER key.  

5. Select cell A1. Then click the Italics button in the Font group of commands in the Home 

tab of the Ribbon.  

6. Increase the height of Row 1 to 30 points. Once the row height is increased, all the text 

typed into the cell will be visible (see Figure 1.43 "Title Added to the Sheet1 Worksheet").  
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Figure 1.43 Title Added to the Sheet1 Worksheet  

 
 

 

Borders (Adding Lines to a Worksheet)  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.08 if starting with this skill.)  

In Excel, adding custom lines to a worksheet is known as adding borders. Borders are 

different from the grid lines that appear on a worksheet and that define the perimeter of 

the cell locations. The Borders command lets you add a variety of line styles to a 

worksheet that can make reading the worksheet much easier.   

The following steps illustrate methods for adding preset borders and custom borders to a 

worksheet:  

1. Highlight cells A2:D2.  
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2. Click the down arrow to the right of the Borders button in the Font group of commands 

in the Home page of the Ribbon (see Figure 1.44 "Borders Drop-Down Menu").  

Figure 1.44 Borders Drop-Down Menu 

 
.

3. Left click the All Borders option from the Borders drop-down menu (see Figure 1.44 

“Borders Drop- Down Menu"). This will add vertical and horizontal lines to the range 

A2:D2.  

4. Highlight the range A2:D2 by placing the mouse pointer over cell A2 and left clicking and 

dragging over to cell D2.  

5. Click the down arrow to the right of the Borders button.  

6. Left click the Thick Bottom Border option from the Borders drop-down menu. 

7. Highlight the range A1:D15.  
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8. Click the down arrow to the right of the Borders button.  

9. This will open the Format Cells dialog box (see Figure 1.45 "Borders Tab of the Format 

Cells Dialog Box"). You can access all formatting commands in Excel through this dialog 

box.  

10. In the Style section of the Borders tab, left click the thickest line style (see Figure 

1.45 “Borders Tab of the Format Cells Dialog Box").  

11. Left click the Outline button in the Presets section (see Figure 1.45 "Borders Tab of the 

Format Cells Dialog Box").  

12. Click the OK button at the bottom of the dialog box (see Figure 1.45 "Borders Tab of 

the Format Cells Dialog Box").  

Figure 1.45 Borders Tab of the Format Cells Dialog Box 

 
. 
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Figure 1.46 Borders Added to the Sheet1 Worksheet  

 

 

  
 

 
. 
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AutoSum  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.09 if starting with this skill.)  

You will see at the bottom of Figure 1.46 "Borders Added to the Sheet1 Worksheet" that 

Row 15 is intended to show the totals for the data in this worksheet. Applying 

mathematical computations to a range of cells is accomplished through functions in Excel.  

Chapter 2 "Mathematical Computations" will review mathematical formulas and functions 

in detail. However, the following steps will demonstrate how you can quickly sum the 

values in a column of data using the AutoSum command:  

1. Activate cell B15 in the Sheet1worksheet.  

2. From the right side of the Home Ribbon, or the left side of the Formula ribbon, click the 

down arrow next to the AutoSum button. You will see that the AutoSum can sum, 

average, count numbers, and create Max and Min functions. 

 
Figure 1.47 AutoSum Drop-Down List 
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3. The default command for AutoSum is Sum. Select Sum from the drop-down list. (see 

Figure 1.47 "AutoSum Drop-Down List"). Note that the AutoSum button can also be 

found in the Editing group of commands in the Home tab of the Ribbon.  

4. Excel will provide a total for the values in the Unit Sales column.  

5. Click in cell D15 and click the AutoSum button. You will see that with this sum the 

Accounting format ($) has been applied to your total row. Excel will copy the formatting 

from your top row as the default number format for your total row. (Note: you should 

not add the Average Price column because it is only a list of prices.)  

Figure 1.48 Totals Added to the Sheet1 Worksheet 

 
. 

 

1.5 Simple Chart  

Inserting a Column Chart  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.10 if starting with this skill.)  

As mentioned at the beginning of this chapter, Excel serves as a critical tool for making 

decisions in both personal and professional contexts. Charts are a powerful tool in Excel 

that allow you to graphically display the data in a worksheet. Graphical displays allow the 
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reader to immediately identify key trends and behaviors in the data that is being analyzed.  

For the workbook that we are using for this chapter, understanding the trends in monthly 

sales data is critical for making decisions such as how many staff members to assign to the  

store for each month as well as supplying the store with enough inventory to accommodate  

expected sales. To assist the reader in analyzing this data, a column chart will be created to 

graphically display the data. It is important for you to plan which type of chart will best 

display the data so your readers can quickly see key trends. More details on creating charts 

and on chart types will be presented in a later chapter. The following steps are an 

introduction to creating the column chart required for this chapter’s objective:  

1. Highlight the range A2:B14.  

2. Click the Insert tab of the Ribbon.  

3. Click the Column button (see Figure 1.49 "Column Chart Drop-Down Menu"). This will 

open the column chart drop-down menu of options.  

4. Select the Clustered Column option from the list of column chart options (see Figure 1.49 

“Column Chart Drop-Down Menu"). This will create an embedded chart in the Sheet1 

worksheet (see Figure 1.50 "Embedded Column Chart in Sheet1"). Embedded means that 

the chart is on the worksheet that contains the original chart data. The chart is floating 

on the top of the worksheet and can be moved and sized on the face of the worksheet. 

 

Figure 1.49 Column Chart Drop-Down Menu  
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Figure 1.50 "Embedded Column Chart in Sheet1" shows the column chart that is created 

once a selection is made from the column chart drop-down menu. Notice that there are two 

new tabs added to the Ribbon. These tabs contain features for enhancing the appearance 

and construction of Excel charts. These commands will be covered in more detail in a later 

chapter. For now, you will see that Excel places the chart over the data in the worksheet.  

The following steps explain how to move and resize the chart:. 
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Figure 1.50 Embedded Column Chart in Sheet1  

 
 
5. While the chart is selected (buttons are visible around the outside of the chart), left 

click anywhere it the chart and drag the chart so the upper left corner is placed in the 

middle of cell F1.   

6. Place the mouse pointer over the top center sizing handle (see Figure 1.50 "Embedded 

Column Chart in Sheet1"). You will see the mouse pointer change from a white block 

plus sign to a vertical double arrow. Make sure the mouse pointer is not in the cross-

arrow mode as this will move the chart instead of resizing it.  

7. While holding down the ALT key on your keyboard, left click and drag the mouse 

pointer slightly up. The chart will automatically adjust up to the top of Row 1.  

8. Place the mouse pointer over the left center sizing handle.  

9. While holding down the ALT key on your keyboard, left click and drag the mouse slightly 

toward the left. The chart will automatically adjust to the left side of Column F.  

10. Place the mouse pointer over the lower center sizing handle.  

11. While holding down the ALT key on your keyboard, left click and drag the mouse 

slightly down. The chart will automatically adjust to the bottom of Row14. 

12. Place the mouse pointer over the right center sizing handle.  
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13. While holding down the ALT key on your keyboard, left click and drag the mouse 

slightly to the right. The chart will automatically adjust to the right side of Column M.  

 

 
 

Figure 1.52 "Embedded Chart Moved and Resized" shows the column chart moved and 

resized. Notice that the sizing handles are not visible around the perimeter of the chart.  

This is because the chart is not activated. Once you click anywhere on the worksheet 

outside the chart area, the chart is automatically deactivated.  

Figure 1.52 Embedded Chart Moved and Resized 

 

 
. 
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As shown in Figure 1.50 "Embedded Column Chart in Sheet1", when a chart is created, two 

tabs are added to the Ribbon. The following steps explain how to use a few of the 

formatting and design features in these tabs:  

1. Check to make sure the column chart in Sheet1 is activated. To activate the chart, left 

click anywhere on the chart.  

2. Click the Design tab under the Chart Tools set of tabs on the Ribbon.  

3. Click the down arrow on the right side of the Chart Styles section (see Figure 1.53 "Chart 

Styles in the Design Tab").  

Figure 1.53 Chart Styles in the Design Tab  

 
 

4. Click Style 9 in the Chart Styles section. This style has a black background with blue 

columns (see Figure 1.53 "Chart Styles in the Design Tab").  

5. Click the Format tab under the Chart Tools set of tabs on the Ribbon.  

6. Click the down arrow on the right side of the WordArt Styles section (see Figure in).  

Figure 1.54 WordArt Styles in the Format Tab 

 
. 
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7. Click the Blue, Accent 1, Inner Shadow option Notice that as you move the mouse 

pointer over the WordArt Styles options, the format of the chart title as well as the X 

and Y axis titles changes.  

Figure 1.55 "Formatting Features Applied to the Column Chart" shows the embedded 

column chart with the formatting features applied. This chart is very effective in displaying 

the Unit Sales trends for this company. You can see very quickly that the tallest bar in the 

chart is the month of December, followed by the months of June, July, January, and 

February.  

Figure 1.55 Formatting Features Applied to the Column Chart 

 
 

 
. 

Cut, Copy, and Paste  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.11 if starting with this skill.)  

The Cut, Copy, and Paste commands are perhaps the most widely used commands in 

Microsoft Office. With regard to Excel, the Copy and Paste commands are often used to 

make copies of worksheets for developing different scenarios or versions for the data being 
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analyzed. The following steps demonstrate how these commands are used for the objective 

in this chapter:  

1. Click the Select All button in the upper left corner of the Sheet1 worksheet (see Figure 

1.56 "Clipboard Group of Commands").  

Figure 1.56 Clipboard Group of Commands  

 
 
2. Click the Copy button in the Clipboard group of commands in the Home tab of the 

Ribbon (see Figure 1.56 "Clipboard Group of Commands").  

 
 

 
 

3. Create a new worksheet by clicking on the + button to the   

right of the Sheet1 tab.  

4. Activate cell location A1. 
. 

5. Click the Paste button in the Clipboard group of commands in the Home tab of the 

Ribbon.  Be sure to click the upper area of the Paste button and not the down arrow at 

the bottom of the button. A copy of Sheet1 will now appear in Sheet2.  
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6. Click anywhere on the chart in the Sheet2worksheet.  

7. Click the Cut button in the Clipboard group on the Home tab of the Ribbon. This will 

remove the chart from the Sheet2worksheet.  

 
 

8. Open the Sheet3 worksheet by left clicking on the Sheet3 worksheet tab at the bottom of 

the workbook.  

9. Activate cell location A1.  

10. Click the Paste button in the Home tab of the Ribbon. This will paste the chart from 

the Sheet2 worksheet into the Sheet3worksheet.  

Sorting Data (One Level)  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.12 if starting with this skill.)  

As mentioned earlier in this section, a chart is a tool that enables worksheet readers to 

analyze data quickly to spot key trends or patterns. Another powerful tool that provides 

similar benefits is the Sort command. This feature ranks the rows of data in a worksheet 

based on designated criteria. The following steps demonstrate how the Sort command is 

used to rank the data in the Sheet2 worksheet:  

1. In the Sheet2 worksheet, highlight the range A2:D14  

2. Click the Data tab of the Ribbon.  

3. Click the Sort button in the Sort & Filter group of commands. This will open the Sort 

dialog box (see Figure 1.57 "Sort & Filter Group of Commands"). 
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Figure 1.57 Sort & Filter Group of Commands  

 
 
4. Click the down arrow next to the “Sort by” drop-down box in the Sort dialog box (see 

Figure 1.58 "Sort Dialog Box"). Make sure the box “My data has headers” is checked.  

Figure 1.58 Sort Dialog Box  

 
5. Click the Unit Sales option from the drop-downlist.  

6. Click the down arrow next to the Order drop-downbox.  

7. Click Largest to Smallest from the drop-downlist.  

8. Click the OK button at the bottom of the Sort dialog box. The data in the range A2:D14 

will now be sorted in descending order based on the values in the Unit Sales column.  

(Note that when you perform the sort, your chart will automatically change to match the 

new sorted data.)  
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Figure 1.59 "Data Sorted Based on Unit Sales" shows the data in the Sheet2 worksheet 

sorted based on the values in the Unit Sales column. Similar to the chart, the Sort command 

makes it easy to identify the months of the year with the highest unit sales.  

Figure 1.59 Data Sorted Based on Unit Sales 

  
. 
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Moving, Renaming, Inserting, and Deleting Worksheets  

Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.13 if starting with this skill.)  

The default names for the worksheet tabs at the bottom of workbook are Sheet1, Sheet2, 

and so on. However, you can change the worksheet tab names to identify the data you are 

using in a workbook. Additionally, you can change the order in which the worksheet tabs.   

appear in the workbook. The following steps explain how to rename and move the 

worksheets in a workbook:  

1. With the left mouse button, double click the Sheet1 worksheet tab at the bottom of the 
workbook (see Figure 1.60 "Renaming a Worksheet Tab"). NOTE: This screenshot is an 

older version of Excel. In the 2016 version, the add worksheet icon is   

2. Type the name Sales by Month.  

3. Press the ENTER key on your keyboard.  

4. With the left mouse button, double click the Sheet2 worksheet tab at the bottom of the 

workbook.  

5. Type the name Unit Sales Rank.  

6. Press the ENTER key on your keyboard. 
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1. Left click and drag the Unit Sales Rank worksheet tab to the left of the Sales by Month 

worksheet tab. 

2. Right click the Sheet3 worksheet tab. Click Delete to delete the worksheet. Alternatively, 

you can: 

a. Click the Home tab of the Ribbon. 

b. Click the down arrow on the Delete button in the Cells group of commands. 

c. Click the Delete Sheet option from the drop-down list . 

d. Click the Delete button on the Delete warning box. 

3. Click the Insert Worksheet tab at the bottom of the workbook (see Figure 1.60 

"Renaming a Worksheet Tab"). 
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Figure 1.61 "Final Appearance of the Excel Objective 1.0 Workbook" shows the final appearance of the  

Excel Objective 1.0 workbook after the worksheet tabs have been renamed and moved. 
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Once you have completed a workbook, it is good practice to select the appropriate settings. 

for printing. These settings are in the Page Layout tab of the Ribbon and discussed in this 

section of the chapter. 

 

Page Setup 
Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.14 if starting with this skill.) 

 

Before you can properly print the worksheets in a workbook, you must establish appropriate settings.  

The following steps explain several of the commands in the Page Layout tab of the Ribbon used to  

prepare a worksheet for printing: 

 

1. Open the Unit Sales Rank worksheet by left clicking on the worksheet tab. 

2. Click the Page Layout tab of the Ribbon. 

3. Click the Margins button in the Page Setup group of commands. This will open a dropdown list of  

options for setting the margins of your printed document. 

4. Click the Wide option from the Margins drop-downlist. 

5. Open the Sales by Month worksheet by left clicking on the worksheet tab. 

6. Click the Page Layout tab of the Ribbon (see Figure 1.62 "Page Layout Commands for 

Printing"). 

7. Click the Margins button in the Page Setup group of commands. 

8. Click the Narrow option from the Margins drop-downlist. 

9. Click the Orientation button in the Page Setup group of commands. 

10. Click the Landscape option. 

11. Click the down arrow to the right of the Width button in the Scale to Fit group of commands. 

12. Click the 1 Page option from the drop-downlist.  

13. Click the down arrow to the right of the Height button in the Scale to Fit group of commands.  
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14. Click the 1 Page option from the drop-down list. This step along with step 12 will 

automatically reduce the worksheet so that it fits on one piece of paper. It is very common 

for professionals to create worksheets that fit within the width of the paper being used. 

However, for long data sets, you may need to set the height to more than one page. Table 

1.2 "Printing Resources: Purpose and Use for Page Setup Commands" provides a list of 

commands found in the Page Layout tab of the Ribbon. 
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Headers and Footers 
Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.15 if you are starting with this 

skill.) 

 

When printing worksheets from Excel, it is common to add headers and footers to the 

printed document. Information in the header or footer could include the date, page 

number, file name, company name, and so on. The following steps explain how to add 

headers and footers to the Excel Objective 1.0 workbook: 

1. Open the Unit Sales Rank worksheet by left clicking on the worksheet tab. 

2. Click the Insert tab of the Ribbon. (Make sure your Excel window is maximized) 

3. Click the Header & Footer button in the Text group of commands. You will see the 

Design tab added to the Ribbon; this is used for creating the headers and footers for 

the printed worksheet. Also, this will convert the view of the worksheet from Normal 

to Page Layout (see Figure 1.63 "Design Tab for Creating Headers and Footers"). 
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4. Type your name in the center section of the Header.  

5. Place the mouse pointer over the left section of the Header and left click (see Figure 

1.63 "Design Tab for Creating Headers and Footers").  

6. Click the Current Date button in the Header & Footer Elements group of commands in 

the Design tab of the Ribbon.  

7. Click the Go to Footer button in the Navigation group of commands in the Design tab of 

the Ribbon.  

8. Place the mouse pointer over the far-right section of the footer and left click.  

9. Click the Page Number button in the Header & Footer Elements group of commands in 

the Design tab of the Ribbon.  

10. Click any cell location outside the header or footer area. The Design tab for creating 

headers and footers will disappear.  

11. Click the Normal view button in the lower right side of the Status Bar (see Figure 1.64 

"Worksheet in Page Layout View"). 

12. Open the Sales by Month worksheet by left clicking the worksheet tab.  

13. Repeat steps 2 through 11 to create the same header and footer for this worksheet.  
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Printing Worksheets and Workbooks  
Follow-along file: Excel Objective 1.0 (Use file Excel Objective 1.16 if starting with this skill.)  

 

Once you have established the print settings for the worksheets in a workbook and have 

added headers and footers, you are ready to print your worksheets. The following steps 

explain how to print the worksheets in the Excel Objective 1.0 workbook:  

 

1. Open the Unit Sales Rank worksheet by left clicking on the worksheet tab.  

2. Click the File tab on the Ribbon. 

3. Click the Print option on the left side of the Backstage view (see Figure 1.65 "Print 

Preview"). On the right side of the Backstage view, you will be able to see a preview of your 

printed worksheet. 

4. Click the Print Active Sheets button in the Print section of the Backstage view (see Figure 

1.65 "Print Preview").  
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5. Click the Print Entire Workbook option from the drop-down list. This will print all 

worksheets in a workbook when the Print button is clicked.  

6. Click the Next Page arrow at the bottom of the preview window.  

7. Click the Print button.  

8. Click the Home tab of the Ribbon.  

9. Save and close the Excel Objective 1.0 workbook. 
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Chap 1 Sample Exercise 
 

Creating and maintaining budgets are common practices in many careers. Budgets play a 

critical role in helping a business or household control expenditures. In this exercise, you 

will create a budget for a hypothetical medical office.  

 

Begin the exercise by opening the file named Chapter 1 CiP Exercise 1. 

 

1. Activate all the cell locations in the Sheet1 worksheet by left clicking the Select All 

button in the upper left corner of the worksheet. 

2. In the Home tab of the Ribbon, set the font style to Arial and the font size to 12 points. 

3. Increase the width of Column A so all the entries in the range A3:A8 are visible. Place 

the mouse pointer between the letter A and letter B of Column A and Column B. When 

the mouse pointer changes to a double arrow, left click and drag it to the right until the 

character width is 18.00. 

4. Enter Quarter 1 in cell B2. 

5. Use Auto fill to complete the headings in the range C2:E2. Activate cell B2 and place the 

mouse pointer over the Fill Handle. When the mouse pointer changes to a black plus 

sign, left click and drag it to cell E2. 

6. Increase the width of Columns B, C, D, and E to 10.14 characters. Highlight the range 

B2:E2 and click the Format button in the Home tab of the Ribbon. Click the Column 

Width option, type 10.14 in the Column Width dialog box, and then click the OK button 

in the Column Width dialog box. 

7. Make the following format adjustment to the range A2:E2: bold; and change the cell fill 

color to orange. 

8. Set the alignment in cell B2 to Wrap Text. Activate the cell location and click the Wrap 

Text button in the Home tab of the Ribbon. 

9. Copy cell B3 and paste the contents into the range C3:E3. 

10. Copy the contents in the range B6:B8 by highlighting the range and clicking the Copy 

button in the Home tab of the Ribbon. Then, highlight the range C6:E8 and click the 

Paste button in the Home tab of the Ribbon. 

11. Insert a blank column between Columns A and B. Activate any cell location in Column B. 

Then, click the drop-down arrow of the Insert button in the Home tab of the Ribbon. 

Click the Insert Sheet Columns option. (Alternatively, you can right click and insert 

column.) 

12. Adjust the width of Column B to 13.29 characters. 

13. Enter the words Budget Cost in cell B2. 
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14. Calculate the total budget for all four quarters for the salaries. Activate cell B3 and click 

the down arrow on the AutoSum button in the Formulas tab of the Ribbon. Click the 

Sum option from the drop- down list. Then, highlight the range C3:F3 and press the 

ENTER key on your keyboard. 

15. Copy the contents of cell B3 and paste them into the range B4:B8. 

16. Enter the words Medical Office Budget in cell A1.  

17. Merge the cells in the range A1:F1. Highlight the range and click the Merge & Center 

button in the Home tab of the Ribbon. 

18. Make the following format adjustments to the range A1:F1: bold; italics; change the font 

size to 14 points; change the cell fill color to Blue, Accent 1, Darker 50%; and change the 

font color to white. 

19. Increase the height of Row 1 to fit the title. 

20. Sort the data in the range A2:F8 based on the values in the Quarter 4 column in 

ascending order. Have an active cell anywhere in the range A2:F8 and click the Sort 

button in the Data tab of the Ribbon. Select Quarter 4 in the “Sort by” drop-down box 

and select Smallest to Largest in the Order drop-down box. Click the OK button. 

(Because you have inserted a merged cell title you will need to select the data you want 

to sort.) 

21. Format the range B3:F8 with a US dollar sign and zero decimal places.  

22. Add vertical and horizontal lines to the range A1:F8. Highlight the range and click the 

down arrow next to the Borders button in the Home tab of the Ribbon. Select the All 

Borders option from the drop-down list. 

23. Change the name of the Sheet1 worksheet tab to “Budget.” Double click the worksheet 

tab, type the word Budget, and press the ENTER key. 

24. Insert a pie chart using the data in the range A2:B8. Highlight the range and click the Pie 

button in the Insert tab of the Ribbon. Click the first option on the list (the Pie option). 

25. Click and drag the chart so the upper left corner is in the center of cell H2. 

26. Add labels to the chart by clicking the Layout 1 option from the Chart Layouts list in the 

Design tab of the Ribbon. Make sure the chart is activated by clicking it once before you 

look for the Layout 1 Chart Layout option. 

27. Change the orientation of the Budget worksheet so it prints landscape instead of 

portrait. 

28. Adjust the appropriate settings so the Budget worksheet prints on one piece of paper. 

29. Add a header to the Budget worksheet that shows the date in the upper left corner and 

your name in the center. 

30. Add a footer to the Budget worksheet that shows the page number in the lower right 

corner. 
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31. Use the Save As command in the File tab of the Ribbon to save the workbook by adding 

your name in front of the current workbook name (i.e., “your name Chapter 1 CiP 

Exercise 1”). 

32. Close the workbook and Excel. Compare your results with the figure below. 

 

Figure 1 - Completed Medical Budget Exercise 
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Chapter 2 
 

Mathematical Computations 
 

Perhaps the most valuable feature of Excel is its ability to produce mathematical outputs 

using the data in a workbook. This chapter reviews several mathematical outputs that you 

can produce in Excel through the construction of formulas and functions. The chapter 

begins with the construction of formulas for basic and complex mathematical 

computations. The second section reviews statistical functions, such as SUM, AVERAGE, 

MIN, and MAX, which can be applied to a range of cells. The last section of the chapter 

addresses functions used to calculate mortgage and lease payments as well as the valuation 

of investments. This chapter also shows how you can use data from multiple worksheets to 

construct formulas and functions. These skills will be demonstrated in the context of a 

personal cash budget, which is a vital tool for managing your money for long-term financial 

security. The personal budget objective will also provide you with several opportunities to 

demonstrate Excel’s what-if scenario capabilities, which highlight how formulas and 

functions automatically produce new outputs when one or more inputs are changed.  

 

2.1 Formulas 

 

This section reviews the fundamental skills for entering formulas into an Excel worksheet. 

The objective used for this chapter is the construction of a personal cash budget. Most 

financial advisors recommend that all households construct and maintain a personal 

budget to achieve and maintain strong financial health. Organizing and maintaining a 

personal budget is a skill you can practice at any point in your life. Whether you are 
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managing your expenses during college or maintaining the finances of a family of four, a 

personal budget can be a vital tool when making financial decisions. Excel can make 

managing your money a fun and rewarding exercise.  

 

Figure 2.1 "Completed Personal Cash Budget Workbook" shows the completed workbook 

that will be demonstrated in this chapter. Notice that this workbook contains four  

worksheets. The first worksheet, Budget Summary, contains formulas that utilize or 

reference the data in the other three worksheets. As a result, the Budget Summary 

worksheet serves as an overview of the data that was entered and calculated in the other 

three worksheets of the workbook. 

 

Creating a Basic Formula 

Follow-along file: Excel Objective 2.00 

Formulas are used to calculate a variety of mathematical outputs in Excel and can be used 

to create virtually any custom calculation required for your objective. Furthermore, when 
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constructing a formula in Excel, you use cell locations that, when added to a formula, 

become cell references. This means that Excel uses, or references, the number entered into 

the cell location when calculating a mathematical output. As a result, when the numbers in 

the cell references are changed, Excel automatically produces a new output. This is what 

gives Excel the ability to create a variety of what-if scenarios, which will be explained later 

in the chapter. 

To demonstrate the construction of a basic formula, we will begin working on the Budget 

Detail worksheet in the Personal Budget workbook, which is shown in Figure 2.2 "Budget 

Detail Worksheet". To complete this worksheet, we will add several formulas and 

functions. Table 2.1 "Spend Category Definitions" provides definitions for each of the spend 

categories listed in the range A3:A11. When you develop a personal budget, these 

categories are defined based on how you spend your money. It is likely that every person 

could have different categories or define the same categories differently. Therefore, it is 

important to review the definitions in Table 2.1 "Spend Category Definitions" to 

understand how we are defining these categories before proceeding. 
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The first formula that we will add to the Budget Detail worksheet will calculate the 

Monthly Spend values. The formula will be constructed so that it takes the values in the 

Annual Spend column and divides them by 12. This will show how much money will be 

spent per month for each of the categories listed in Column A. The following explains how 

this formula is created:  

1. Click the Budget Detail worksheet tab to open the worksheet.  

2. Click cell C3.  

3. Type an equal sign (=). When the first character entered into a cell location is an equal 

sign, it signals Excel to perform a calculation or produce a logical output.  

4. Click on cell D3. This adds D3 to the formula, which is now a cell reference. Excel will use 

whatever value is entered into cell D3 to produce an output.  

5. Type the slash symbol (/). This is the symbol for division in Excel. As shown in Table 2.2 

"Excel Mathematical Operators", the mathematical operators in Excel are slightly different 

from those found on a typical calculator.  
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6. Type the number 12. This divides the value in cell D3 by 12. In this formula, a number, or 

constant, is used instead of a cell reference because it will not change. In other words, there 

will always be 12 months in a year.  

7. Press the ENTER key.  

Table 2.2 Excel Mathematical Operators 

 

Figure 2.3 "Adding a Formula to a Worksheet" shows how the formula appears in cell C3 

before you press the ENTER key. Figure 2.4 "Formula Output for Monthly Spend" shows the 

output of the formula after you press the ENTER key. The monthly spend for Household 

Utilities is $250 because the formula is taking the Annual Spend in cell D3 and dividing it by 

12. If the value in cell D3 is changed, the formula automatically produces a new output. We 

are calculating the spend per month for each category because people often get paid and 

are billed for these items monthly. This formula allows you to compare your monthly 

income to your monthly bills to determine whether you have enough income to pay these 

expenses. 
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Relative References (Copying and Pasting Formulas)  

Follow-along file: Continue with Excel Objective 2.00 or Excel Objective 2.01 if starting here.  

Once a formula is typed into a worksheet, it can be copied and pasted to other cell 

locations. For example, Figure 2.4 "Formula Output for Monthly Spend" shows the output of 

the formula that was entered into cell C3. However, this calculation needs to be performed 

for the rest of the cell locations in Column C. Since we used the D3 cell reference in the 

formula, Excel automatically adjusts that cell reference when the formula is copied and 

pasted into the rest of the cell locations in the column. This is called relative referencing 

and is demonstrated as follows:  

1. Click cell C3.  

2. Click the Copy button in the Home tab of the Ribbon.  

3. Highlight the range C4:C11.  

4. Click the Paste button in the Home tab of the Ribbon. (or hit Enter)  

5. While the cells are still highlighted, format cells C4:C11 for comma with no decimals.  

6. Double click cell C6. Notice that the cell reference in the formula automatically changed 

to D6 when copied.  

7. Press the ENTER key.  

 

Figure 2.5 "Relative Reference Example" shows the outputs added to the rest of the cell 

locations in the Monthly Spend column. For each row, the formula takes the value in the 

Annual Spend column and divides it by 12. You will also see that cell D6 has been double 

clicked to show the formula. Notice that Excel automatically changed the original cell 

reference of D3 to D6. This is the result of relative referencing, which means Excel 

automatically adjusts a cell reference relative to its original location when it is pasted into 

new cell locations. In this example, the formula was pasted into eight cell locations below 

the original cell location. As a result, Excel increased the row number of the original cell 

reference by a value of one for each row it was pasted into. 
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Creating Complex Formulas (Controlling the Order of Operations)  
Follow-along file: Continue with Excel Objective 2.00 or file Excel Objective 2.02 if starting here.  
 
The next formula to be added to the Personal Budget workbook is the percent change in 

spending this year over last year. This formula determines the difference between the 

values in the LY (Last Year) Spend column and shows the difference in terms of a 

percentage. This requires that the order of mathematical operations be controlled to get an 

accurate result. Table 2.3 "Standard Order of Mathematical Operations" shows the standard 

order of operations for a typical formula. 
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To change the order of operations shown in the table, we use parentheses to process 

certain mathematical calculations first. This formula is added to the worksheet as follows:  

1. Click cell F3 in the Budget Detail worksheet.  

2. Type an equal sign (=).  

3. Type an open parenthesis (().  

4. Click cell D3. This will add a cell reference to cell D3 to the formula. When building 

formulas, you can click cell locations instead of typing them.  

5. Type a minus sign (−).  

6. Click cell E3 to add this cell reference to the formula.  

7. Type a closing parenthesis ()).  

8. Type the slash (/) symbol for division.  

9. Click cell E3. This completes the formula that will calculate the percent change of last 

year’s actual spent dollars vs. this year’s budgeted spend dollars (see Figure 2.6 "Adding 

the Percent Change Formula").  

10. Press the ENTER key.  

11. Click cell F3 to activate it.  

12. Place the mouse pointer over the Auto Fill Handle in the lower right corner of the cell.  

13. When the mouse pointer turns from a white block plus sign to a narrow black plus sign, 
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click and drag down to cell F11. This pastes the formula into the range F4:F11.  

Figure 2.6 "Adding the Percent Change Formula" shows the formula that was added to the 

Budget Detail worksheet to calculate the percent change in spending. The parentheses 

were added to this formula to control the order of operations. Any mathematical 

computations placed in parentheses are executed first before the standard order of 

mathematical operations (see Table 2.3 "Standard Order of Mathematical Operations"). In 

this case, if parentheses were not used, Excel would produce an erroneous result for this 

worksheet. 

 

Figure 2.7 "Removing the Parentheses from the Percent Change Formula" shows the result 

of the percent change formula if the parentheses are removed. The formula produces a 

result of a 299900% increase. Since there is no change between the LY spend and the 

budget Annual Spend, the result should be 0%.  

 

However, without the parentheses, Excel is following the standard order of operations. This 

means the value in cell E3 will be divided by E3 first (3,000/3,000), which is 1. Then, the 

value of 1 will be subtracted from the value in cell D3 (3,000−1), which is 2,999. Since cell 

F3 is formatted as a percentage, Excel expresses the output as an increase of 299900%. 
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Auditing Formulas  
Follow-along file: Continue with Excel Objective 2.00 or use Excel Objective 2.03 if starting here. 

Excel provides a few tools that you can use to review the formulas entered into a 

worksheet. For example, instead of showing the outputs for the formulas used in a 

worksheet, you can have Excel show the formula as it was entered in the cell locations. This 

is demonstrated as follows:  

1. With the Budget Detail worksheet open, click the Formulas tab of the Ribbon.  

2. Click the Show Formulas button in the Formula Auditing group of commands. This 

displays the formulas in the worksheet instead of showing the mathematical outputs.  

3. Click the Show Formulas button again. The worksheet returns to showing the output of 

the formulas.  
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Figure 2.8 "Show Formulas Command" shows the Budget Detail worksheet after activating 

the Show Values command in the Formulas tab of the Ribbon. As shown in the figure, this 

command allows you to view and check all the formulas in a worksheet without having to 

click each cell individually. After activating this command, the column widths in your 

worksheet increase significantly. The column widths were adjusted for the worksheet 

shown in Figure 2.8 "Show Formulas Command" so all columns can be seen. The column 

widths return to their previous width when the Show Formulas command is deactivated. 

 

 

Two other tools in the Formula Auditing group of commands are the Trace Precedents 

and Trace Dependents commands. These commands are used to trace the cell references 

used in a formula. The Trace Dependents command shows where any given cell is 

referenced in a formula. The Trace Precedents command shows what cells have been 
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referenced in a formula that exists in an activated cell. The following is a demonstration of 

these commands:  

1. Click cell D3 in the Budget Detail worksheet.  

2. Click the Trace Dependents button in the Formula Auditing group of commands in the 

Formulas tab of the Ribbon. A double blue arrow appears, pointing to cell locations C3 and 

F3 (see Figure 2.9"Trace Dependents Example"). This indicates that cell D3 is referenced in 

formulas that are entered in cells C3 and F3.  

3. Click the Remove Arrows command in the Formula Auditing group of commands in the 

Formulas tab of the Ribbon. This removes the Trace Dependents arrow.  

4. Click cell F3 in the Budget Detail worksheet.  

5. Click the Trace Precedents button in the Formula Auditing group of commands in the 

Formulas tab of the Ribbon. A blue arrow running through cells D3 and E3 and pointing to 

cell F3 appears (see Figure 2.10 "Trace Precedents Example"). This indicates that cells D3 

and E3 are references in a formula entered in cell F3.  

6. Click the Remove Arrows command in the Formula Auditing group of commands in the 

Formulas tab of the Ribbon. This removes the Trace Precedents arrow.  

 

Figure 2.9 "Trace Dependents Example" shows the Trace Dependents arrow on the Budget 

Detail worksheet. The blue dot represents the activated cell. The arrows indicate where 

the cell is referenced in formulas. 
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Figure 2.10 "Trace Precedents Example" shows the Trace Precedents arrow on the Budget 

Detail worksheet. The blue dots on this arrow indicate the cells that are referenced in the 

formula contained in the activated cell. The arrow is pointing to the activated cell location 

that contains the formula. 
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2.2 Statistical Functions  

In addition to formulas, another way to conduct mathematical computations in Excel is 

through functions. Statistical functions apply a mathematical process to a group of cells in a 

worksheet. For example, the SUM function is used to add the values contained in a range of 

cells. A list of commonly used statistical functions is shown in Table 2.4 "Commonly Used 

Statistical Functions". Functions are more efficient than formulas when you are applying a 

mathematical process to a group of cells. If you use a formula to add the values in a range of 

cells, you would have to add each cell location to the formula one at a time. This can be very 

time-consuming if you must add the values in a few hundred cell locations. However, when 

you use a function, you can highlight all the cells that contain values you wish to sum in just 

one step. This section demonstrates a variety of statistical functions that we will add to the 

Personal Budget workbook. In addition to demonstrating functions, this section also 

reviews percent of total calculations and the use of absolute references. 
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The SUM Function  

Follow-along file: Continue with Excel Objective 2.00 or file Excel Objective 2.03 if starting here. 

The SUM function is used when you need to calculate totals for a range of cells or a group of 

selected cells on a worksheet. Regarding the Budget Detail worksheet, we will use the SUM 

function to calculate the totals in row 12. It is important to note that there are several 

methods for adding a function to a worksheet, which will be demonstrated throughout the 

remainder of this chapter. The following illustrates how a function can be added to a 

worksheet by typing it into a cell location: 

 

1. Click the Budget Detail worksheet tab to open the worksheet. 

2. Click cell C12. 

3. Type an equal sign (=). 

4. Type the function name SUM. 

5. Type an open parenthesis ((). 
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6. Click cell C3 and drag down to cell C11. This places the range C3:C11 into the function. 

7. Type a closing parenthesis Note: you can hit enter without the closing parenthesis and 

Excel will insert it for you. 

8. Press the ENTER key. The function calculates the total for the Monthly Spend column, 

which is $1,496. 

 

Figure 2.11 "Adding the SUM Function to the Budget Detail Worksheet" shows the 

appearance of the SUM function added to the Budget Detail worksheet before pressing the 

ENTER key. 

 

As shown in Figure 2.11 "Adding the SUM Function to the Budget Detail Worksheet", the 

SUM function was added to cell C12. However, this function is also needed to calculate the 

totals in the Annual Spend and LY Spend columns. The function can be copied and pasted 

into these cell locations because of relative referencing. Relative referencing serves the 

same purpose for functions as it does for formulas. The following demonstrates how the 
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total row is completed:  

1. Click cell C12 in the Budget Detail worksheet.  

2. Use the fill handle in the lower right corner to copy the formula across to cells D12:E12.  

3. Activate cell F12 and click on the AutoSum button in the Editing section of the Home 

ribbon. Hit Enter. Then increase decimal places to one.  

4. Click cell F11.  

5. Click the Copy button in the Home tab of the Ribbon.  

6. Click cell F12, then click the Paste button in the Home tab of the Ribbon. Since we now 

have totals in row 12, we can paste the percent change formula into this row.  

Figure 2.12 "Results of the SUM Function in the Budget Detail Worksheet" shows the 

output of the SUM function that was added to cells C12, D12, and E12. In addition, the 

percent change formula was copied and pasted into cell F12. Notice that this version of the 

budget is planning a 1.7% decrease in spending compared to last year. 
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Absolute References (Calculating Percent of Totals)  

Follow-along file: Continue with Excel Objective 2.00 or use Excel Objective 2.04 if starting here. 

Since totals were added to row 12 of the Budget Detail worksheet, a percent of total 

calculation can be added to Column B beginning in cell B3. The percent of total calculation 

shows the percentage for each value in the Annual Spend column with respect to the total 

in cell D12. However, after the formula is created, it will be necessary to turn off Excel’s 

relative referencing feature before copying and pasting the formula to the rest of the cell 

locations in the column. Turning off Excel’s relative referencing feature is accomplished by 

creating an absolute cell reference. An absolute cell reference will remain locked in a 
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formula no matter where the formula is copied. The following steps explain this:  

1. Click cell B3 in the Budget Detail worksheet.  

2. Type an equal sign (=).  

3. Click cell D3.  

4. Type a forward slash (/).  

5. Click cell D12.  

6. Press the ENTER key. You will see that Household Utilities represents 16.7% of the 

Annual Spend budget (see Figure 2.14 "Adding a Formula to Calculate the Percent of 

Total").  

 

Figure 2.14 "Adding a Formula to Calculate the Percent of Total" shows the completed 

formula that is calculating the percentage that Household Utilities Annual Spend represents 

to the total Annual Spend for the budget (see cell B3). Normally, we would copy this 

formula and paste it into the range B4:B11.  

 

However, because of relative referencing, both cell references will increase by one row as 

the formula is pasted into the cells below B3. This is fine for the first cell reference in the 
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formula (D3) but not for the second cell reference (D12). Figure 2.15 "#DIV/0 Error from 

Relative Referencing" illustrates what happens if we paste the formula into the range 

B4:B12 in its current state. Notice that Excel produces the #DIV/0 error code. This means 

that Excel is trying to divide a number by zero, which is impossible.  

 

Looking at the formula in cell B4, you see that the first cell reference was changed from D3 

to D4. This is fine because we now want to divide the Annual Spend for Insurance by the 

total Annual Spend in cell D12. However, Excel has also changed the D12 cell reference to 

D13. Because cell location D13 is blank, the formula produces the #DIV/0 error code. 
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To eliminate the divide-by-zero error shown in Figure 2.15 "#DIV/0 Error from Relative 

Referencing", we must add an absolute reference to cell D12 in the formula. An absolute 

reference prevents relative referencing from changing a cell reference in a formula. This is 

also referred to as locking a cell. 

 

Excel uses the $ to lock either the column letter, the row number, or both. In an absolute 

cell reference, Excel will lock both the column and row references. This prevents the cell 

from changing relatively when copied or moved.  

The following explains how this is accomplished:  

1. Double click cell B3.  

2. Place the mouse pointer in front of D12 and click. The blinking cursor should be in front 

of the D in the cell reference D12.  

3. Press the F4 key. You will see a dollar sign ($) added in front of the column letter D and 

the row number 12. You can also type the dollar signs in front of the column letter and row 

number.  

4. Press the ENTER key.  

5. Click cell B3.  

6. Click the Copy button in the Home tab of the Ribbon.  

7. Highlight the range B4:B11.  

8. Click the Paste button in the Home tab of the Ribbon.  

 

Figure 2.16 "Adding an Absolute Reference to a Cell Reference in a Formula" shows the 

percent of total formula with an absolute reference added to D12. Notice that in cell B4, the 

cell reference remains D12 instead of changing to D13 as shown in Figure 2.15 "#DIV/0 

Error from Relative Referencing". Also, you will see that the percentages are being 

calculated in the rest of the cells in the column, and the divide-by- zero error is now 

eliminated. 
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The COUNT Function  

Follow-along file: Continue with Excel Objective 2.00 or use Excel Objective 2.05 if starting here. 

The next function that we will add to the Budget Detail worksheet is the COUNT function. 

The COUNT function is used to determine how many cells in a range contain a numeric 

entry. The function will count only those cells that have a numeric entry. Cells that contain 

text, or are blank, will not be included in the total count.  

 

For the Budget Detail worksheet, we will use the COUNT function to count the number of 

items that are planned in the Annual Spend column (Column D). The following explains 

how the COUNT function is added to the worksheet by using the function list:  

1. Click cell D13 in the Budget Detail worksheet.  

2. Type an equal sign (=).  
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3. Type the letter C.  

4. Click the down arrow on the scroll bar of the function list (see Figure 2.17 "Using the 

Function List to Add the COUNT Function") and find the word COUNT.  

5. Double click the word COUNT from the function list.  

6. Highlight the range D3:D11.  

7. Type a closing parenthesis ()).  

8. Press the ENTER key. The function produces an output of 9 since there are 9 items 

planned on the worksheet.  

Figure 2.17 "Using the Function List to Add the COUNT Function" shows the function list 

box that appears after completing steps 2 and 3 for the COUNT function. The function list 

provides an alternative method for adding a function to a worksheet. 

 

Figure 2.18 "Completed COUNT Function in the Budget Detail Worksheet" shows the 

output of the COUNT function after pressing the ENTER key. The function counts the 

number of cells in the range D3:D11 that contain a numeric value. The result of 9 indicates 

that there are 9 categories planned for this budget. 
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The AVERAGE Function  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.06 if starting here.)  

The next function we will add to the Budget Detail worksheet is the AVERAGE function. 

This function is used to calculate the arithmetic mean for a group of numbers. For the 

Budget Detail worksheet, we will use the function to calculate the average of the values in 

the Annual Spend column. We will add this to the worksheet by using the Function Library. 

The following steps explain how this is accomplished:  

1. Click cell D14 in the Budget Detail worksheet.  

2. Click the Formulas tab on the Ribbon.  

3. Click the More Functions button in the Function Library group of commands.  

4. Place the mouse pointer over the Statistical option from the drop-down list of options.  

5. Click the AVERAGE function name from the list of functions that appear in the menu (see 

Figure 2.19 "Selecting the AVERAGE Function from the Function Library"). This opens the 

Function Arguments dialog box.  
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6. Click the Collapse Dialog button in the Function Arguments dialog box (see Figure 2.20 

"Function Arguments Dialog Box").  

7. Highlight the range D3:D11.  

8. Click the Expand Dialog button in the Function Arguments dialog box (see Figure 2.21 

"Selecting a Range from the Function Arguments Dialog Box"). You can also press the 

ENTER key to get the same result.  

9. Click the OK button on the Function Arguments dialog box. This adds the AVERAGE 

function to the worksheet.  

 

Figure 2.19 "Selecting the AVERAGE Function from the Function Library" illustrates how a 

function is selected from the Function Library in the Formulas tab of the Ribbon. 

 

Figure 2.20 "Function Arguments Dialog Box" shows the Function Arguments dialog box. 

This appears after a function is selected from the Function Library. The Collapse Dialog 

button is used to hide the dialog box so a range of cells can be highlighted on the worksheet 

and then added to the function. 
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Figure 2.21 "Selecting a Range from the Function Arguments Dialog Box" shows how a 

range of cells can be selected from the Function Arguments dialog box once it has been 

collapsed. 
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Figure 2.22 "Function Arguments Dialog Box after a Cell Range Is Defined for a Function" 

shows the Function Arguments dialog box after the cell range is defined for the AVERAGE 

function. The dialog box shows the result of the function before it is added to the cell 

location. This allows you to assess the function output to determine whether it makes sense 

before adding it to the worksheet. 

 

Figure 2.23 "Completed AVERAGE Function" shows the completed AVERAGE function in 

the Budget Detail worksheet. The output of the function shows that on average we expect 

to spend $1,994 for each of the categories listed in Column A of the budget. This average 

spend calculation per category can be used as an indicator to determine which categories 

are costing more or less than the average budgeted spend dollars. 
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The MAX and MIN Functions  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.07 if starting here.)  

 

The final two statistical functions that we will add to the Budget Detail worksheet are the 

MAX and MIN functions. These functions identify the highest and lowest values in a range 

of cells. The following steps explain how to add these functions to the Budget Detail 

worksheet:  

1. Click cell D15 in the Budget Detail worksheet.  

2. Type an equal sign (=).  

3. Type the word MIN.  

4. Type an open parenthesis (().  

5. Highlight the range D3:D11.  

6. Type a closing parenthesis ()).  

7. Press the ENTER key. The MINError! Bookmark not defined. function produces an output 

of $1,200, which is the lowest value in the Annual Spend column (see Figure 2.24 "MIN 

Function Added to the Budget Detail Worksheet"). 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                106 

  

 

 

 

Let’s try a different method using the AutoSum feature.  

8. Click cell D16.  

9. Click on the drop-down menu to the right of the AutoSum in the Editing section of the 

Home ribbon. (You can also use the AutoSum on the left side of the Formulas ribbon)  

10. Select MAX.  

11. Highlight the range D3: D11.  

12. Press the ENTER key. The MAX function produces an output of $3,500. This is the 

highest value in the Annual Spend column (see Figure 2.25 "MAX Function Added to the 

Budget Detail Worksheet"). 
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Copy and Paste Formulas (Pasting without Formats)  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.08 if starting here.)  

As shown in Figure 2.25 "MAX Function Added to the Budget Detail Worksheet", the 

COUNT, AVERAGE, MIN, and MAX functions are summarizing the data in the Annual Spend 

column. You will also notice that there is space to copy and paste these functions under the 

LY Spend column. This allows us to compare what we spent last year and what we are 

planning to spend this year. Normally, we would simply copy and paste these functions into 

the range E13:E16. However, you may have noticed the double-line style border that was 

used around the perimeter of the range B13:E16. If we used the regular Paste command, 

the double line on the right side of the range E13:E16 would be replaced with a single line. 

Therefore, we are going to use one of the Paste Special commands to paste only the 

functions without any of the formatting treatments. This is accomplished through the 

following steps:  

1. Highlight the range D13:D16 in the Budget Detail worksheet.  

2. Use the Fill handle and fill across to E13:16  

3. Click cell E13.  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                108 

  

4. Click the down arrow below the Paste button in the Home tab of the Ribbon.  

5. Click the Formulas option from the drop-down list of buttons (see Figure 2.26 "Paste 

Formulas Option").  

 

Figure 2.26 "Paste Formulas Option" shows the list of buttons that appear when you click 

the down arrow below the Paste button in the Home tab of the Ribbon. One thing to note 

about these options is that you can preview them before you make a selection by dragging 

the mouse pointer over the options. As shown in the figure, when the mouse pointer is 

placed over the Formulas button, you can see how the functions will appear before making 

a selection. Notice that the double-line border does not change when this option is 

previewed. That is why this selection is made instead of the regular Paste option. 

 

Alternatively, you can use the quick format button that appears when you copy the cells 

across using the auto fill handle. 
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Sorting Data (Multiple Levels) 

 Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.09 if starting here.)  

 

The Budget Detail worksheet shown in Figure 2.26 "Paste Formulas Option" is now 

producing several mathematical outputs through formulas and functions. The outputs 

allow you to analyze the details and identify trends as to how money is being budgeted and 

spent. Before we draw some conclusions from this worksheet, we will sort the data based 

on the Percent of Total column. As mentioned in Chapter 1 "Fundamental Skills", sorting is 

a powerful tool that enables you to analyze key trends in any data set. We demonstrated 

the process of executing a single-level sort in Chapter 1 "Fundamental Skills". For the 

purposes of the Budget Detail worksheet, we need to set multiple levels for the sort order. 

This is accomplished through the following steps:  

1. Highlight the range A2:F11 in the Budget Detail worksheet.  

2. Click the Data tab in the Ribbon.  

3. Click the Sort button in the Sort & Filter group of commands. This opens the Sort dialog 

box, as shown in Figure 2.27 "Sort Dialog Box". 
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4. Click the down arrow next to the “Sort by” box. 

5. Click the Percent of Total option from the drop-downlist.  

6. Click the down arrow next to the sort Order box.  

7. Click the Largest to Smallest option.  

8. Click the Add Level button. This allows you to set a second level for any duplicate values 

in the Percent of Total column.  

9. Click the down arrow next to the “Then by” box.  

10. Select the Last Year option.  

11. Click the OK button at the bottom of the Sort dialog box.  

Figure 2.28 "Budget Detail Worksheet after Sorting" shows the Budget Detail worksheet 

after it has been sorted. Notice that there are three identical values in the Percent of Total 

column. Therefore, a second sort level had to be created for this worksheet. The second 

sort level arranges the values of 8.4% based on the values in the LY Spend column in 

ascending order. Excel gives you the option to set as many sort levels as necessary for the 

data contained in a worksheet. 
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Now that the Budget Detail worksheet is sorted, a few key trends can be easily identified. 

The worksheet clearly shows that the top three categories as a percentage of total 

budgeted spending for the year are Taxes, Household Utilities, and Food. All three 

categories are necessities (or realities) of life and typically require a significant amount of 

income for most households. Looking at the Percent Change column, we can see how our 

planned spending is expected to change from last year. This is perhaps the most important 

column on the worksheet because it allows you to assess whether your plan is realistic. You 

will see that there are no changes planned for Taxes and Household Utilities. While Taxes 

can change from year to year, it is not too difficult to predict what they will be. In this case, 

we are assuming that there are no changes to the tax costs for our budget. We are also 

planning no change in Household Utilities. These costs can fluctuate from year to year as 

well. However, you can take measures to reduce costs, such as using less electricity, turning 

off heat when no one is in the house, keeping track of your cell’s data usage so you do not 

go over the maximum allowed in your plan, and so on. As a result, there is no change in 

planned spending for Household Utilities because we will assume that any rate increases 

will be offset with a decrease in usage. The third item that is planned not to change is 

Insurance. Insurance policies for cars and homes can change, but as is true for taxes, the 

changes are predictable. Therefore, we are assuming no changes in our insurance policy.  
 

The first big change that is noticeable in the worksheet is the Food and Entertainment 

categories in rows 5 and 6 (see definitions in Table 2.1 "Spend Category Definitions"). The 

Percent Change column indicates that there is an 11.1% decrease in Entertainment 

spending and an 11.1% increase in Food spending. This is logical because if you plan to eat 

in restaurants less frequently, you will be eating at home more frequently. Although this 

makes sense in theory, it may be hard to do in practice. Dinners and parties with friends 

may be tough to turn down. However, the entire process of maintaining a budget is based 

on discipline, and it certainly takes a significant amount of discipline to plan targets for 

yourself and stick to them.  
 

A few other points to note are the changes in the Gasoline and Vacation categories. If you 

commute to school or work, the price of gas can have a significant impact on your budget. It 

is important to be realistic if gas prices are increasing, and you should reflect these 

increases in your budget. To compensate for the increased spending for gas, the spending 

plan for vacations has been reduced by 25%. Budgeting often requires a certain degree of 

creativity. Although the Vacation budget has been reduced, there is still money you can set 

aside to make plans for spring break or winter break.  

 

Finally, the budget shows a decrease in Miscellaneous spending of 19.8%. This was defined 

as a group containing several expenses, such as textbooks, school supplies, software 
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updates, and so on (see Table 2.1 "Spend Category Definitions"). You may be able to reduce 

your spending in this category if you can use items such as online textbooks. This reduction 

in spending can free up funds for Clothes, a spend category that has increased by 20%. We 

will continue to develop the Personal Budget workbook further in Section 2.3 "Functions 

for Personal Finance". 
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2.3 Functions for Personal Finance 

 

In this section, we will discover the power of using named cells and ranges in our functions 

to better describe what is happening inside the function itself as we continue to develop 

the Personal Budget workbook. Notable items that are missing from the Budget Detail 

worksheet are the payments you might make for a car or a home. In addition, you may 

want to set and track a savings goal. This section demonstrates Excel functions used to 

calculate lease payments for a car, to calculate mortgage payments for a house, and to 

project future savings based on regular contributions and an average rate of return. This 

section also discusses the scenario capabilities of Excel once the Personal Budget workbook 

is complete. Before we continue with our Budget worksheet, we will explore how to name 

cells and ranges, modify them, rename them, or delete them. 

 

Defining and using names in formulas  

By using names, you can make your formulas much easier to understand and maintain. You 

can define a name for a cell, a range of cells, a function, a constant, or a table. Once you 

adopt the practice of using names in your workbook, you can easily update, audit, and 

manage these names. A name is a meaningful shorthand that makes it easier to understand 

the purpose of a cell reference, constant, formula, or table, each of which may be difficult to 
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comprehend at first glance. The following information shows common examples of names 

and how they can improve clarity and understanding. 

 

 

Types of names  

There are several types of names that you can create and use.  

Defined name - A name that represents a cell, range of cells, formula, or constant value. 

You can create your own defined name, and Microsoft Office Excel sometimes creates a 

defined name for you, such as when you set a print area.  

Table name - A name for an Excel table, which is a collection of data about a particular 

subject that is stored in records (rows) and fields (columns). We will discuss Tables later.  

The scope of a name - All names have a scope, either to a specific worksheet (also called 

the local worksheet level) or to the entire workbook (also called the global workbook 

level). The scope of a name is the location within which the name is recognized without 

qualification. For example:  

• If you have defined a name, such as Budget_FY18, and its scope is Sheet1, that name, if not 

qualified, is recognized only in Sheet1, but not in other sheets without qualification. To use 

a local worksheet name in another worksheet, you can qualify it by preceding it with the 

worksheet name, as the following example shows: Sheet1! Budget_FY18  

• If you have defined a name, such as Sales_Dept_Goals, and its scope is the workbook, that 

name is recognized for all worksheets in that workbook, but not for any other workbook. 
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A name must always be unique within its scope. You can override the local worksheet level 

for all worksheets in the workbook, except for the first worksheet, which always uses the 

local name if there is a name conflict and cannot be overridden.  

Defining and entering names  

You define a name by using the:  

• Name box on the formula bar. This is best used for creating a workbook level name for a 

selected range.  

• Create a name from selection. You can conveniently create names from existing row 

and column labels by using a selection of cells in the worksheet.  

• New Name dialog box. This is best used for when you want more flexibility in creating 

names, such as specifying a local worksheet level scope or creating a name comment.  

Note: By default, names use absolute cell references.  

 

You can select named cells and ranges to use in your functions and formulas by:  

• Typing: Typing the name, for example, as an argument to a formula.  

• Using Formula AutoComplete: Use the Formula AutoComplete drop-down list, where 

valid names are automatically listed for you.  

• Selecting from the Use in Formula command: Select a defined name from a list in the 

Use in Formula command in the Defined Names group on the Formulas ribbon.  

 

Pasting a defined names list:  

You can also create a list of defined names in a workbook. Locate an area with two empty 

columns on the worksheet (the list will contain two columns, one for the name and one for 

a description of the name). Select a cell that will be the upper-left corner of the list. On the 

Formulas tab, in the Defined Names group, click Use in Formula, click Paste Names and then, 

in the Paste Names dialog box, click Paste List.  
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Naming Rules  

The following is a list of naming rules that you need to be aware of when you create and 

edit names.  

• Valid characters: The first character of a name must be a letter, an underscore character 

(_), or a backslash (\). Remaining characters in the name can be letters, numbers, periods, 

and underscore characters.  

Tip: You cannot use the uppercase and lowercase characters "C", "c", "R", or "r" as a defined 

name, because they are all used as a shorthand for selecting a row or column for the 

currently selected cell when you enter them in a Name or Go To text box.  

• Cell references disallowed - Names cannot be the same as a cell reference, such as 

Z$100 or R1C1.  

• Spaces are not valid: Spaces are not allowed as part of a name. Use the underscore 

character (_) and period (.) as word separators, such as, Sales_Tax or First.Quarter.  

• Name length - A name can contain up to 255 characters.  

• Case sensitivity - Names can contain uppercase and lowercase letters. Excel does not 

distinguish between uppercase and lowercase characters in names. For example, if you 

created the name Sales and then create another name called SALES in the same workbook, 

Excel prompts you to choose a unique name.  

 

Define a name for a cell or cell range on a worksheet  

1. Select the cell, range of cells, or nonadjacent selections that you want to name.  

2. Click the Name box at the left end of the formula bar. 

3. Type the name that you want to use to refer to your 

selection. Names can be up to 255 characters in length.  

4. Press ENTER.  

Note: You cannot name a cell while you are changing the contents of the cell.  

 

Define a name by using a selection of cells in the worksheet  

You can convert existing row and column labels to names.  
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1. Select the range that you want to name, including the row or column labels.  

2. On the Formulas tab, in the Defined Names group, click Create from Selection. 

In the Create Names from Selection dialog box, designate 

the location that contains the labels by selecting the Top 

row, Left column, Bottom row, or Right column check 

box. A name created by using this procedure refers only to the cells that contain values and 

does not include the existing row and column labels. 

 

Define a name by using the New Name dialog box  

1. On the Formulas tab, in the Defined Names group, click Define Name.  

2. In the New Name dialog box, in the Name box, type the name that you want to use for 

your reference. Note: Names can be up to 255 characters in length.  

3. To specify the scope of the name, in the Scope drop-down list box, select Workbook or the 

name of a worksheet in the workbook. 

 

4. Optionally, in the Comment box, enter a descriptive comment up to 255 characters.  

5. In the Refers to box, do one of the following:  

o To enter a cell reference, type the cell reference.   

o If a cell or range of cells has already been selected, you can leave it.  

o You can use the up arrow to the right of the” Refers to:” to verify your cell or range 

reference. 
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Tip: The current selection is entered by default. To enter other cell references as an 

argument, click Collapse Dialog (which temporarily shrinks the dialog box), select the cells 

on the worksheet, and then click Expand Dialog.  

o To enter a constant, type = (equal sign) and then type the constant value.  

o To enter a formula, type = and then type the formula.  

6. To finish and return to the worksheet, click OK.  

Tip: To make the New Name dialog box wider or longer, click and drag the grip handle at 

the bottom. 

 

Manage names by using the Name Manager dialog box  

Use the Name Manager dialog box to work with the defined names and table names in the 

workbook. For example, you may want to find names with errors, confirm the value and 

reference of a name, view or edit descriptive comments, determine the scope, or delete a 

named range or cell. You can sort and filter the list of names, and easily add, change, or 

delete names from one location.  

To open the Name Manager dialog box, on the Formulas 

tab, in the Defined Names group, click Name Manager.  
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View names  

The Name Manager dialog displays the following information about each name in a list box:  

 

Icon and Name One of the following:  

• A defined name, which is indicated by a defined name icon.  

• A table name, which is indicated by a table name icon. 

Value: 

The current value of the name, such as the results of a formula, a string constant, a cell 

range, an error, an array of values, or a placeholder if the formula cannot be evaluated. 

Refers To: 

The current cell reference or cell reference range for the name. 

Scope: One of the following: 

• A worksheet name, if the scope is the local worksheet level.  

• "Workbook", if the scope is the global worksheet level. 

Comment: 

Additional information about the name up to 255 characters.  

 

Note: You cannot use the Name Manager dialog box while you are changing the contents of 

the cell. 

Change a name 

If you change a defined name or table name, all uses of that 

name in the workbook are also changed.  

1. On the Formulas tab, in the Defined Names group, click Name Manager. 

2. In the Name Manager dialog box, click the name that you want to change, and then click 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                120 

  

Edit.  

Tip: You can also double-click the name.  

3. In the Edit Name dialog box, in the Name box, type the new name for the reference.  

4. In the Refers to box, change the reference, and then click OK.  

5. In the Name Manager dialog box, in the Refers to box, change the cell, formula, or 

constant represented by the name. 

o To cancel unwanted or accidental changes, click Cancel, or press ESC.  

o To save changes, click Commit, or press ENTER.  

The Close button only closes the Name Manager dialog box. It is not required to commit 

changes that have already been made.  

Delete one or more names  

1. On the Formulas tab, in the Defined Names group, click Name Manager. 

2. In the Name Manager dialog box, click the name that you want to change.  

3. Select one or more names by doing one of the following:  

o To select a name, click it.  

o To select more than one name in a contiguous group, click and drag the names, or 

press SHIFT and click the mouse button for each name in the group.  

o To select more than one name in a noncontiguous group, press CTRL and click the 

mouse button for each name in the group. 

4. Click Delete. You can also press DELETE.  

5. Click OK to confirm the deletion. The Close button only closes the Name Manager dialog 

box. It is not required to commit changes that have already been made. 
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The Fundamentals of Loans and Leases  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.10 if starting here.)  

One of the functions we will add to the Personal Budget workbook is the PMT function. 

This function calculates the payments required for a loan or a lease. However, before 

demonstrating this function, it is important to cover a few fundamental concepts on loans 

and leases.  

A loan is a contractual agreement in which money is borrowed from a lender and paid back 

over a specific period of time. The amount of money that is borrowed from the lender is 

called the principal of the loan. The borrower is usually required to pay the principal of the 

loan plus interest. When you borrow money to buy a house, the loan is referred to as a 

mortgage. This is because the house being purchased also serves as collateral to ensure 

payment. In other words, the bank can take possession of your house if you fail to make 

loan payments. As shown in Table 2.5 "Key Terms for Loans and Leases", there are several 

key terms related to loans and leases. 
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Figure 2.29 "Example of an Amortization Table" shows an example of an amortization table 

for a loan. A lender is required by law to provide borrowers with an amortization table 

when a loan contract is offered. The table in the figure shows how the payments of a loan 

would work if you borrowed $100,000 from a lender and agreed to pay it back over 10 

years at an interest rate of 5%. You will notice that each time you make a payment, you are 

paying the bank an interest fee plus some of the loan principal. Each year the amount of 

interest paid to the bank decreases and the amount of money used to pay off the principal 

increases. This is because the bank is charging you interest on the amount of principal that 

has not been paid. As you pay off the principal, the interest rate is applied to a lower 

number, which reduces your interest charges. Finally, the figure shows that the sum of the 

values in the Interest Payment column is $29,505. This is how much it costs you to borrow 

this money over 10 years. Indeed, borrowing money is not free. It is important to note that 

to simplify this example, the payments were calculated on an annual basis. However, most 

loan payments are made monthly. 
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A lease is a contract in which you, the lessee, use an asset such as a car or a piece of 

equipment and you agree to make regular payments to the owner or the lessor. When you 

lease a car, the manufacturer or a leasing company retains ownership of the vehicle and 

you agree to make regular payments for a specific period of time. The amount of money 

you pay depends on the price of the car, the terms of the lease contract, and the car’s 

expected residual value at the end of the lease. The calculation of lease payments is like the 

calculation of loan payments. However, when you lease a car, you pay only the value of the 

car that is used. For example, suppose you are leasing a car that is priced at $25,000. The 

lease contract is for 4 years at an interest rate of 5%. The residual value of the car is 

$10,000. This means the car will lose $15,000 of its value over 4 years. Another way to 

state this is that the car will depreciate $15,000. A lease will be structured so that you pay 

this $15,000 in depreciation. However, the interest charges will be based on the purchase 

price of $25,000. We will look at a demonstration of leasing a car as well as buying a home 

in the next section. 

 

The PMT (Payment) Function for Loans  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.10 if starting here.)  

If you own a home, your mortgage payments are a major component of your household 

budget. If you are planning to buy a home, having a clear understanding of your monthly 

payments is critical for maintaining strong financial health. In Excel, mortgage payments 

are conveniently calculated through the PMT (payment) function. This function is more 

complex than the statistical functions covered in Section 2.2 "Statistical Functions". With 

statistical functions, you are required to add only a range of cells or selected cells within 

the parentheses of the function. With the PMT function, you must accurately define a series 

of arguments for the function to produce a reliable output. Table 2.6 "Arguments for the 

PMT Function" lists the arguments for the PMT function. It is helpful to review the key loan 

and lease terms in Table 2.5 "Key Terms for Loans and Leases" before reviewing the PMT 

function arguments.  
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The PMT function is: =PMT (RATE,NPER,PV,[FV],[Type]) 

 

 

We will use the PMT function in the Personal Budget workbook to calculate the monthly 

mortgage payments for a house. These calculations will be made in the Mortgage 

Payments worksheet and then displayed in the Budget Summary worksheet through a 

named cell reference link.  

The first thing we will do in this worksheet is name the cells we will be using in our 

functions. Next, we will discover a new method of adding functions to a worksheet. The 

following steps explain the new method using the Insert Function command for adding the 

PMT function:  

1. Click the Mortgage Payments worksheet tab.  
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2. Highlight the range A2:B6. On the Formula ribbon, Defined Names section click on Create 

from Selection. Make sure Left Column is checked. (see Figure 2.29b “Create from 

Selection”). Click OK. You have now named all of the cells in the B column. (You can verify 

your named cells by using the drop-down arrow in the Name Box.)  

 

3. Click cell B5.  

4. Click the Formulas tab on the Ribbon.  

5. Click the Insert Function button (see Figure 2.30 "Mortgage Payments Worksheet"). This 

opens the Insert Function dialog box, which can be used for searching all functions in Excel.  

6. In the “Search for a function:” input box at the top of the Insert Function dialog box, type 

payment (see Figure 2.31 "Insert Function Dialog Box"). Note that the current description 

in the “Search for a function:” input box will already be highlighted. You can begin typing 

and the description will be replaced with your entry.  

7. Click the Go button in the upper right side of the Insert Function dialog box. This adds all 

the Excel functions that match your description in the “Select a function:” box in the lower 

half of the Insert Function dialog box (see Figure 2.31 "Insert Function Dialog Box").  

8. Click the PMT option in the “Select a function:” box in the lower half of the Insert 

Function dialog box.  

9. Click the OK button at the lower right side of the Insert Function dialog box. This will 

open the Function Arguments dialog box.  
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10. The cursor automatically starts in the Rate box. This will be the first argument defined 

for the PMT function.  

11. Click cell B3 on the worksheet. This is the rate being charged on the loan. You will see 

your defined name Interest_Rate appear in the Rate argument box.  

12. Type a forward slash (/) for division.  

13. Click on cell B5. Since our goal is to calculate the monthly payments for the loan, we 

need to divide the rate, which is stated in annual terms, by the number of payments per 

year. The number of payments per year is found in cell B5. This converts the annual rate to 

a monthly rate. (periodic rate) Your defined name Payments_per_Year will appear after 

your /.  

14. Click in the Nper field in the Function Arguments dialog box. This is the second 

argument we define in the function. Nper is the total number of payments to be made over 

the life of the loan. It is the loan in years * the payments per year.  

15. Click cell B4 on the worksheet. This is the term or the amount of time we have to repay 

the loan. You will see the defined name Terms_of_Loan appear in your Nper argument box.  

16. Type an asterisk (*) for multiplication.  

17. Click on cell B5. Since our goal is to calculate the total number of payments for the loan, 

we need to multiply the term of the loan by payments per year.  

18. Click in the Pv argument field in the Function Arguments dialog box. This is the third 

argument we will define in the function.  

19. Type a minus sign (−). When defining the Pv argument of the PMT function, any cell 

location or value must be preceded with a minus sign.  

20. Click cell B2 on the worksheet. This is the principal of the loan. Your defined name 

Loan_Principal will appear in the PV argument field.  

21. You will now see the Rate, Nper, and Pv arguments defined for the function.  

22. Click the OK button at the bottom of the Function Arguments dialog box. The function 

will now be placed into the worksheet. Since we are not paying any lump sums of money at 

the end of the loan, there is no need to define the Fv argument. Also, we will assume that 

the monthly mortgage payments will be made at the end of each month. Therefore, there is 

no need to define the Type argument.  
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Figure 2.32 "Function Arguments Dialog Box for the PMT Function" shows the completed 

Function Arguments dialog box for the PMT function. Notice that the dialog box shows the 

values for the Rate and Nper arguments. The Rate is divided by 12 to convert the annual 

interest rate to a monthly interest rate. The Nper argument is multiplied by 12 to convert 

the terms of the loan from years to months. Finally, the dialog box provides you with a 

definition for each argument. The definition appears when you click in the input box for the 

argument. 

 

 

Figure 2.33 "Mortgage Payments Worksheet with the PMT Function" shows the final 

appearance of the Mortgage Payments worksheet after the PMT function is added. The 

result of the function in cell B6 will be displayed in the Budget Summary worksheet. 
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The PMT (Payment) Function for Leases  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.11 if starting here.)  

In addition to calculating the mortgage payments for a home, the PMT function will be used 

in the Personal Budget workbook to calculate the lease payments for a car. The details for 

the lease payments are found in the Car Lease Payments worksheet. Similar to the statistical 

functions, we can type the PMT function directly into a cell. However, you must know the 

definitions for each argument of the function and understand how these arguments need to 

be defined based on your objective. The terms for loans and leases are in Table 2.5 "Key 

Terms for Loans and Leases", and the definitions for the arguments of the PMT function are 

in Table 2.6 "Arguments for the PMT Function". The following steps explain how the PMT 

function is added to the Personal Budget workbook to calculate lease payments for a car:  

1. Highlight the range A2:B6. On the Formula ribbon, Defined Names section click on Create 

from Selection. Make sure Left Column is checked. (see Figure 2.29b “Create from 

Selection”). Click OK. You have now named all of the cells in the B column. (You can verify 

you named cells by using the drop-down arrow in the Name Box.) 

 

Note: When we use the same names on two different worksheets, the Name Manager assigns a 

different scope. The first time we named Interest rate the scope was for the Mortgage 
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Payments worksheet. This time it is for the Car Lease Payments worksheet. See Figure 2.33a. 

 

2. Click cell B6 in the Car Lease Payments worksheet.  

3. Type an equal sign (=). 

4. Type the letters PMT. A drop-down list of Excel functions will appear. Double click PMT. 

 

5. Click cell B4. This is the interest rate being charged for the lease.  
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6. Type the forward slash (/) for division.  

7. Type the number 12. Since our goal is to calculate the monthly lease payments, we divide 

the interest rate by 12 to convert the annual rate to a monthly rate.  

8. Type a comma. When you type a function containing arguments, you must separate each 

argument with a comma. This signals to Excel that one argument has been defined and you 

are ready to define the next argument in the function.  

9. Click cell B5. This is the term or the length of time for the lease contract. Since the term is 

already expressed in months, we can just reference cell B5 and move to the next argument.  

10. Type a comma. This advances the function to the Pv argument.  

11. Type a minus sign (−). Remember that cell locations or values used to define the Pv 

argument must be preceded with a minus sign.  

12. Click cell B2 on the worksheet, which is the price of the car.  

13. Type a comma. This advances the function to the [Fv] argument.  

14. Click cell B3 on the worksheet. This is the residual value of the car. Note that cell 

location and values used to define the [Fv] argument are NOT preceded by a minus sign.  

15. Type a comma. This advances the function to the [Type] argument. 

16. Type the number 1. We will assume that the lease payments will be due at the 

beginning of each month.  

17. Type a closing parenthesis ()).  

18. Press the ENTER key.  

19. Figure 2.34 "PMT Function Constructed to Calculate Lease Payments" shows how the 

PMT function should appear before pressing the ENTER key. Notice the commas that 

separate each argument of the function. Also, the tip box will show the current argument 

being defined in bold font. 
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Figure 2.35 "Results of the PMT Function in the Car Lease Payments Worksheet" shows the 

result of the PMT function. The monthly payments for this lease are $206.56. This monthly 

payment will be displayed in the Budget Summary worksheet. 

Figure 2.35 Results of the PMT Function in the Car Lease Payments Worksheet 

 

Creating an Amortization Schedule for a Loan  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.11b if starting here.)  

Now that we have determined how much a loan or lease will cost per month, it is useful to 

determine how interest and principal will be applied from our payment each month. Figure 

2.35b shows how interest and principal on a loan behave over time. You can see from this 

chart that it will take you over 16 years for your payments to go more toward principal 

than interest.  

One of the advantages of preparing an amortization schedule is that you can see exactly 
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how much is being applied to principal and interest each time you make a payment. You 

can also play with the monthly payment amount and see how increasing your payment will 

apply more to your principal payment while reducing your loan duration. 

 

To complete the amortization schedule, we will use two financial functions; the PPMT 

Principal Payment function that calculates the amount of any given period’s principal 

payment, and the IPMT Interest Payment function, which calculates the interest taken from 

any given period payment. The PPMT and the IPMT have the same arguments and are the 

same as the PMT with one exception. The exception is that you must tell the function which 

period you are calculating out the interest or principal.  

The arguments in either function are:  

RATE, Current period, NPER, PV 

• Where RATE = the periodic interest rate (RATE/payments per year)  

• Current period = the current period number 
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• NPER = total payments over the life of the loan  

• PV = the original amount of the loan  

Let’s set up an amortization schedule. Complete the following steps:  

1. On the Mortgage Payments worksheet enter the following column headers:  

a. Cell A9: Payment Number  

b. Cell B9: Beginning Balance  

c. Cell C9: Principal Payment  

d. Cell D9: Interest Payment  

e. Cell E9: Ending Balance  

2. Highlight cells B9:C9 and Wrap Text. Increase columns to letters in words stay together.  

3. Highlight cells A9:E9 and apply an All Borders style from the Font section of the Home 

ribbon.  

4. In cell A10 enter the number 1  

5. In cell A11 enter the number 2  

6. Highlight cells A10:A11 and use the Fill handle at the bottom right corner of A11 to drag 

down until you have 360 payments in column A. Note: The Fill handle will show you what 

number you have filled through outside the lower right corner. 

 

7. In cell B10 enter = and click on the Loan principal in cell B2.  
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8. In cell C10 enter the PPMT function =PPMT, then double click on the function in the box 

below the cell.  

9. To complete the function  

a. Click on cell B3 (Interest Rate) enter the / to divide the rate, click on B5 (Payment 

per year).  

b. Enter a comma to separate the arguments.  

c. Click on cell A10 to enter the current period, enter a comma,  

d. Click on cell B4 to enter the Term of the loan, enter an * to multiply the term by 

the payments per year in cell B5  

e. Enter a – minus sign and then click on B2 for the Loan Principal amount.  

f. Close your PPMT function with a closing ). The figure below shows the arguments 

after they have been entered into the function. (The cells were already named in this 

worksheet.)- 

 

10. In cell D10 inter the IPMT function using the steps for the PPMT above, except you will 

type the IPMT instead of PPMT.  

11. In cell E10 subtract the principal payment in cell C10 from the beginning balance in cell 

B10. =B10-C10  

12. In cell B11 enter = and click on the ending balance in cell E10.  

13. Highlight the range C10:E10 and copy down one row. (Using the fill handle makes this 

easy.)  

14. Highlight the cells B11:E11 and use the fill handle to fill the formulas down through the 

360th payment. You can do this quickly by double clicking the fill handle in the lower right 

corner of your highlighted area border. The balance in the last cell should = 0. 
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Linking Worksheets with 3-D Cell References. (Creating a Summary Worksheet)  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.12 if starting here.)  

So far, we have used cell references and named cells in formulas and functions, which 

allows Excel to produce new outputs when the values in the cell references are changed. 

Cell references can also be used to display values or the outputs of formulas and functions 

in cell locations on other worksheets. This is how data will be displayed on the Budget 

Summary worksheet in the Personal Budget workbook. Outputs from the formulas and 

functions that were entered into the Budget Detail, Mortgage Payments, and Car Lease 

Payments worksheets will be displayed on the Budget Summary worksheet using 3-D cell 

references. The following steps explain how this is accomplished:  

1. Click cell C3 in the Budget Summary worksheet.  

2. Type an equal sign (=). 

3. Click the Budget Detail worksheet tab.  

4. Click cell D12 on the Budget Detail worksheet.  

5. Press the ENTER key on your keyboard. The output of the SUM function in cell D12 on 

the Budget Detail worksheet will be displayed in cell C3 on the Budget Summary 

worksheet.  

 

Figure 2.36 "Cell Reference Showing the Total Expenses in the Budget Summary 

Worksheet" shows how the cell reference appears in the Budget Summary worksheet. 

Notice that the cell reference D12 is preceded by the Budget Detail worksheet name 

enclosed in apostrophes followed by an exclamation point (‘Budget Detail’!) This indicates 

that the value displayed in the cell is referencing a cell location in the Budget Detail 

worksheet. 
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As shown in Figure 2.36 "Cell Reference Showing the Total Expenses in the Budget 

Summary Worksheet", the Budget Summary worksheet is designed to show the expense 

budget for the mortgage payments and the auto lease payments. However, you will recall 

that we used the PMT function to calculate the monthly payments. In the Budget Summary 

worksheet, we need to show the total annual payments. As a result, we will create a 

formula that references cell locations in the Mortgage Payments and Car Lease Payments 

worksheets. The following steps explain how this is accomplished:  

1. Click cell C4 in the Budget Summary worksheet.  

2. Type an equal sign (=).  

3. Click the Mortgage Payments worksheet tab.  

4. Click cell B5 in the Mortgage Payments worksheet.  

5. Type an asterisk (*) for multiplication.  

6. Type the number 12. This multiplies the monthly payments by 12 to calculate the total 

payments required for the year.  

7. Press the ENTER key on your keyboard. The value of multiplying the monthly mortgage 
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payments by 12 is now displayed on the Budget Summary worksheet.  

8. Click cell C5 on the Budget Summary worksheet.  

9. Type an equal sign (=).  

10. Click the Car Lease Payments worksheet tab.  

11. Click cell B6 in the Car Lease Payments worksheet.  

12. Type an asterisk (*) for multiplication.  

13. Type the number 12. This multiplies the monthly lease payments by 12 to calculate the 

total payments required for the year.  

14. Press the ENTER key on your keyboard. The value of multiplying the monthly lease 

payments by 12 is now displayed on the Budget Summary worksheet.  

15. Highlight cells C4:C5, format Comma with no decimal places.  

 

Figure 2.37 "Formulas Referencing Cells in Mortgage Payments and Car Lease Payments 

Worksheets" shows the results of creating formulas that reference cell locations in the 

Mortgage Payments and Car Lease Payments worksheets. 
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We can now add other formulas and functions to the Budget Summary worksheet that can 

calculate the difference between the total spend dollars vs. the total net income in cell D2. 

The following steps explain how this is accomplished:  

1. Click cell D6 in the Budget Summary worksheet.  

2. Click on AutoSum at in the Editing section of the Home ribbon  

3. Highlight the range C3:C5  

4. Click Enter.  

5. Click cell D7 on the Budget Summary worksheet.  

6. Type an equal sign (=).  

7. Click cell D2.  

8. Type a minus sign (−) and then click cell D6.  

9. Press the ENTER key on your keyboard. This formula produces an output of $1,942, 

indicating our income is greater than our total expenses. 

Figure 2.38 "Formulas Added to Show Income Is Greater Than Expenses" shows the results 

of the formulas that were added to the Budget Summary worksheet. The output for the 

formula in cell D7 shows that the net income exceeds total planned expenses by $1,942. 

Overall, having your income exceed your total expenses is a good thing because it allows 

you to save money for future spending needs or unexpected events. 
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We can now add a few formulas that calculate both the spending rate and the savings rate 

as a percentage of net income. These formulas require the use of absolute references, which 

we covered earlier in this chapter. The following steps explain how to add these formulas:  

1. Click cell E6 in the Budget Summary worksheet.  

2. Type an equal sign (=).  

3. Click cell D6.  

4. Type a forward slash (/) for division and then clickD2.  

5. Press the F4 key on your keyboard. This adds an absolute reference to cell D2.  

6. Press the ENTER key. The result of the formula shows that total expenses consume 

94.1% of our net income.  

7. Click cell E6.  

8. Place the mouse pointer over the Auto Fill Handle. 

9. When the mouse pointer turns to a black plus sign, left click and drag down to cell E7. 

This copies and pastes the formula into cell E7.  

 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                141 

  

Figure 2.39 "Calculating the Savings Rate" shows the output of the formulas calculating the 

spending rate and savings rate as a percentage of net income. The absolute reference 

shown for cell D2 prevents the cell from changing when the formula is copied from cell E6 

and pasted into cell E7. The results of the formula show that our current budget allows for 

a savings rate of 5.9%. This is a fairly good savings rate. In the next section, we will discuss 

how these savings can grow over time by exploring the time value of money concepts. 

 

 

Time Value of Money Concepts  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.13 if starting here.)  

In reviewing the Budget Summary worksheet in Figure 2.39 "Calculating the Savings Rate", 

you will notice that the range B9:D14 contains data that can be used to assess a savings 

plan. We can project how much money can be saved over a specific period of time given set 

contributions and a rate of return. This calculation is accomplished through the future 
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value, or FV, function. We will use the FV function in cell D10 of the Budget Summary 

worksheet to calculate our savings plan projection. However, before we use the FV 

function, it is important to review a few basic concepts regarding the time value of money, 

as shown in Table 2.7 "Key Terms for Time Value of Money Concepts". 

 

 

Table 2.7 "Key Terms for Time Value of Money Concepts" provides definitions for several 

terms used when addressing the time value of money concepts. The time value of money is 

the opportunity to grow your money over time given a constant or average rate of return.  
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For example, consider the data shown in Figure 2.40 "Time Value of Money Example for a 

One-Time Investment". This data assumes that a person makes a one-time investment of 

$100 in a bond mutual fund that returns 5% interest per year. Notice that the interest paid 

in Column E increases every year. This is because the interest is reinvested in the mutual 

fund, which increases the total value of the investment. For example, the interest earned in 

year 1 is based on a $100 investment. Therefore, the interest paid is $5.00, or 5% of $100. 

However, in year 2, when the $5.00 interest payment is reinvested, the total investment 

increases to $105. Therefore, in year 2 the interest paid increases to $5.25, or 5% of $105. 

The value of the investment at the end of 5 years is $127.63. This is the value that can be 

calculated using the FV function. 

 

Figure 2.41 "Time Value of Money Example for an Annuity Investment" shows another 

example demonstrating the time value of money concept. Instead of making a one-time 

investment, we will assume that a person invests $100 at the beginning of every year in the 

same bond mutual fund. This is referred to as an annuity because the person is making 

reoccurring investments over a specific period of time. Notice that the value of this 

investment after 5 years is $580.19. Also, the total interest earned on this investment is 

$80.19 as opposed to the $27.63 earned on the one-time investment in Figure 2.40 "Time 

Value of Money Example for a One-Time Investment". 
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The FV (Future Value) Function  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.13 if starting here.)  

Establishing a personal savings plan is one of the most important financial exercises you 

can do. For example, a savings plan is critical for establishing financial security for your 

retirement years. Many people mistakenly believe that saving for retirement is something 

you do when you get older. However, the greatest financial gains for your retirement can be 

achieved if you start saving in the earliest years of your career. Now that you understand 

the time value of money, you can see that the more years you can earn interest on your 

investments and reinvest those earnings, the more money you will have when you retire. 

Savings plans are also important for other key life events, such as going to college or buying 

a home.  

FV = (RATE, NPER, PMT,[PV],[TYPE]) 

The FV function is a convenient tool that can help you establish savings goals and project 

the value of your investments over time. Like the PMT function, the FV function requires 

you to accurately define specific arguments in order to produce a reliable result. Table 2.8 

"Arguments for the FV Function" provides definitions for each of the arguments in the FV 

function. It is helpful to review the time value of money terms in Table 2.7 "Key Terms for 

Time Value of Money Concepts" before using the FV function. 
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With respect to the Personal Budget workbook, we will use the FV function to project the 

value of the savings plan in 10 years. We will type the function directly into the Personal 

Budget worksheet for this demonstration. However, you can use any of the methods 

demonstrated in this chapter for future use. 
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The following steps explain how this function is added to the worksheet:  

1. Click cell D10 in the Budget Summary worksheet.  

2. Type an equal sign (=).  

3. Type the letters FV followed by an open parenthesis (().  

4. Click cell D13. This is the expected rate of return for the investments.  

5. Type a comma.  

6. Click cell D12. This is the amount of time the investments are expected to grow.  

7. Type a comma.  

8. Type a minus sign (−). All values or cell locations used to define the Pmt argument must 

be preceded by a minus sign.  

9. Click cell D7. This is the change in cash that was calculated by subtracting the total 

expenses from the net income. We are expecting to save this amount of money for the 10-

year period this investment is being measured.  

10. Type a comma.  

11. Type a minus sign (−). All values and cell locations used to define the Pv argument must 

be preceded by a minus sign.  

12. Click cell D14. Since the savings plan has a current balance, we use this to define the Pv 

argument of the function. This is equivalent to starting with a lump-sum investment. 

13. Type a closing parenthesis ()). There is no need to define the last argument of the 

function because we will assume that the savings in cash achieved in our budget will be 

invested at the end of each year of the savings plan. Press the ENTER key Now we will 

check to see if our savings plan is over, or short of, its goal.  

14. Check that cell D11 is activated.  

15. Type an equal sign (=).  

16. Click cell D10.  

17. Type a minus sign (−) and then click cell D9. This subtracts the savings plan from the 

current savings plan projection.  

18. Press the ENTER key. 
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Figure 2.42 "Results of the Savings Plan Projections" shows the results of the FV function. 

Notice that the current savings plan projection is $25,606. This is $606 higher than the 

target of $25,000 entered into cell D9, which shows that the current budget is working to 

achieve the goals of this savings plan. In other words, given the current net income, we are 

saving enough money to achieve our savings plan goals. 

 

There are two important factors to notice about this plan. The first factor is that our 

spending plan allows us to save enough money so that it can be invested to achieve our 

target of $25,000. The second factor is that the expected rate of return is 3.5%. This is a 

relatively low expected rate of return and could be achieved by investing in relatively 

lowrisk investments such as bonds as opposed to stocks. This rate can be considered good 
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because we can achieve our savings goals without having to make high-risk investments 

that could result in a significant loss of our savings. If the results of the PMT function or FV 

function are negative, check the Pv or Pmt arguments. Remember that these arguments 

must be preceded by a minus sign. If the minus sign is omitted, the functions produce a 

negative output. 

 

NPER  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.14 if starting here.)  

Given the home loan example above there are other financial functions that can be used to 

help make financial decisions when borrowing money. For instance, if we can afford to pay 

$1,000 per month for our loan and the bank will loan to us at 5% interest on a $165,000 

loan, how long will it take to pay off that loan?  

The NPER function solves for the total number of payments it will take to pay off this loan. 

The function is:  

=NPER (RATE,PMT,-PV,[FV],[Type]) 

Return to the Mortgage Payments worksheet and complete the following steps:  

1. In cell E1 type: What if Analysis  

2. In cell E2 type: Years to payoff loan if: (NPER)  

3. In cell E4 type: Payment per month:  

4. In cell E5 enter $1,000  

5. In G2 enter =NPER (  

6. Click on cell B3 – the interest rate in the mortgage analysis section. Enter the divisor (/) 

and click on the Payments per year in cell B5 to calculate the periodic interest rate. Type a 

comma. 

7. Click on the $1,000 in cell F3 for the PMT argument and then enter a comma.  

8. Enter a minus sign (-) and click on B2, the Loan Principal and then hit Enter. The result 

shows 279.74 payments.  

9. To solve for the number of years we must divide the total number of payments by the 
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payments per year. Click in the formula bar for G3. After the closing parenthesis divide (/) 

the result by the payments per year in cell B5.  

10. Format cell G3 for comma with one decimal place. 

Figure 2.43 shows the result that being able to pay an extra $115 per month on a 30-year 

loan will cut 7 years off the length of this loan. 

 

RATE  

Follow-along file: Continue with Excel Objective 2.00. (Use file Excel Objective 2.15 if starting here.)  

Another what if analysis you can play with when making financial decisions around loans is 

what is the highest interest rate you can afford to pay given your financial situation. Let’s 

assume that the most we can afford to pay monthly for the loan is $800. Everything else 

will remain the same in our Mortgage analysis, but we will know before entering into a loan 

how much interest we can afford. We will do this by solving for the RATE.  

The RATE function solves for the periodic interest rate. The arguments in the function are: 

=RATE (NPER,PMT, -PV,[FV],[Type]) 

1. On the Mortgage Payments worksheet, in cell E5 type: Payment per month.  

2. In F5, type: $800  

3. In cell E6, type Interest rate (RATE)  

4. In cell F6 enter =RATE (  

5. Calculate the NPER by clicking on cell B4 and multiply (*) by B5. Enter a comma  

6. Enter the payment amount by clicking on cell F5 and enter a comma  

7. Enter a minus sign (-) and click on the loan principal in cell B2. 
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8. Finish the function by typing the closing parenthesis.  

9. The result in cell F6 may show 0%. Increase decimal places to show 3 decimal places. 

The periodic interest rate is 0.344%. To calculate the annual interest rate, you must 

multiply the result of the RATE function by the number of payments per year.  

10. Make cell F6 active and click in the formula bar. At the end of your RATE function 

multiply the function by payments per year in B5.  

Figure 2.44 shows the results of the RATE function. You would have to get an interest rate 

of 4.125% to be able to afford the $165,000 house at $800 per month. 
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Chap 2 Sample Exercise 

Running your own lawn care business can be an excellent way to make money over the summer 

while on break from college. It can also be a way to supplement your existing income for the purpose 

of saving money for retirement or for a college fund. However, managing the costs of the business 

will be critical in order for it to be a profitable venture. In this exercise you will create a simple 

financial plan for a lawn care business by using the skills covered in this chapter. Begin this exercise 

by opening the file named Chapter 2 CiP Exercise 1. 

1. Click cell C5 in the Annual Plan worksheet. 

2. Enter a formula that calculates the average price per lawn cut. Type an equal sign (=), then 

click cell B3. Type the asterisk symbol (*) for multiplication, then click cell B4. Press the 

ENTER key. 

3. Click cell C8 in the Annual Plan worksheet. 

4. Enter a formula that calculates the total number of lawns that will be cut during the year. 

Type an equal sign (=), then click cell B6. Type the asterisk symbol (*) for multiplication, 

then click cell B7. Press the ENTER key. 

5. Click cell D9 in the Annual Plan worksheet. 

6. Enter a formula that calculates the total sales for the plan. Type an equal sign (=), then click 

cell C5. Type the asterisk symbol (*) for multiplication, then click cell C8. Press the ENTER 

key. 

7. Click cell F3 in the Leases worksheet. The PMT function will be used to calculate the 

monthly lease payment for the first item. For many businesses, leasing (or renting) 

equipment is a more favorable option than purchasing equipment because it requires far less 

cash. This enables you to begin a business such as a lawn care business without having to put 

up a lot of money to buy equipment. 
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8. Type an equal sign (=) followed by the function name PMT and an open parenthesis ((). 

Define the arguments of the function as follows: 

o Rate: Click cell B3, type a forward slash (/) for division, type the number 12, and type 

a comma. Since we are calculating monthly payments, the annual interest rate must 

be converted to a monthly interest rate. 

o Nper: Click cell C3, type an asterisk (*) for multiplication, type the number 12, and 

type a comma. Similar to the Rate argument, the terms of the lease must be 

converted to months since we are calculating monthly payments. 

o Pv: Type a minus sign (−), click cell D3, and type a comma. Remember that this 

argument must always be preceded by a minus sign. 

o Fv: Click cell E3 and type a comma. 

o Type: Type the number 1, type a closing parenthesis ()), and press the ENTER key. 

We will assume the lease payments will be made at the beginning of each month, 

which requires that this argument be defined with a value of 1. 

9. Copy the PMT function in cell F3 and paste it into the range F4:F6. 

10. Click cell F10 in the Leases worksheet. A SUM function will be added to calculate the total 

for the monthly lease payments. 

11. Type an equal sign (=) followed by the word SUM and an open parenthesis ((). Highlight the 

range F3:F9, type a closing parenthesis ()), and press the ENTER key. You will notice that 

blank rows were included in this range for the SUM function. If other items are added to the 

worksheet, they will be included in the output of the SUM function. 

12. Highlight the range A2:F6 on the Leases worksheet. The data in this range will be sorted. 

13. Click the Sort button in the Data tab of the Ribbon. In the Sort dialog box, select the Interest 

Rate option in the “Sort by” drop-down box. Select Largest to Smallest for the sort order. 

Then, click the Add Level button on the Sort dialog box. Select the Price option in the “Then 

by” drop-down box. Select Largest to Smallest for the sort order. Click the OK button in the 

Sort dialog box. 
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14. Click cell B11 on the Annual Plan worksheet. The monthly lease payments that are 

calculated in the Lease worksheet will be displayed in this cell. 

15. Type an equal sign (=). Click the Leases worksheet tab, click cell F10, and press the ENTER 

key. 

16. Click cell C12 on the Annual Plan worksheet. 

17. Type an equal sign (=) and click cell B11. Type an asterisk (*), type the number 12, and press 

the ENTER key. This formula calculates the annual lease payments. 

18. Format the output of the formula in cell C12 so the decimal places are reduced to zero. 

19. Click cell C14 on the Annual Plan worksheet. 

20. Type an equal sign (=) and click cell B13. Type an asterisk (*), click cell C8, and press the 

ENTER key. 

21. Click cell D16 on the Annual Plan worksheet. 

22. Type an equal sign (=) followed by the word SUM and an open parenthesis ((). Highlight the 

range C11:C15, type a closing parenthesis ()), and press the ENTER key. This SUM function 

adds the total expenses for the business. 

23. Click cell D17 on the Annual Plan worksheet. 

24. Type an equal sign (=). Click cell D9, type a minus sign (–), click cell D16, and press the 

ENTER key. This formula calculates the annual profit for the business. 

25. Click cell B10 on the Investments worksheet. 

26. Type an equal sign (=) followed by the word COUNT and an open parenthesis ((). Highlight 

the range B3:B8, type a closing parenthesis ()), and press the ENTER key. This function 

counts the number of investments that currently have a balance. Notice that additional blank 

rows were included in the range for this function. The function output will automatically 

change if any new investments are added to the worksheet. 

27. Click cell D3 on the Investments worksheet. 

28. Type an equal sign (=). Click the Annual Plan worksheet tab. Click cell D17 and type a 

forward slash (/) for division. Click the Investments worksheet tab. Click cell B10 and press 

the ENTER key. This formula divides the profit calculated on the Annual Plan worksheet 
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by the number of investments in the Investments worksheet. We will assume that the 

profits from this business will be invested evenly among the funds listed in Column A of 

the Investments worksheet. 

29. Before copying and pasting the formula created in step 28, absolute references must be 

added to the cell locations in the formula. Double click cell D3 on 

the Investments worksheet. Place the mouse pointer in front of D17 in the formula and 

click. Press the F4 key on your keyboard. Place the mouse pointer in front of cell B10 in the 

formula and click. Press the F4 key on your keyboard. Press the ENTER key. 

30. Copy cell D3 and paste it into cells D4 and D5. 

31. Click cell E3 on the Investments worksheet. The future value function will be added to 

project the total growth of the investments listed in Column A. We will assume that the 

business will be able to consistently generate the profit, which will be invested evenly in the 

funds every year. 

32. Type an equal sign (=) followed by the function name FV and an open parenthesis ((). Define 

the arguments of the function as follows: 

o Rate: Click cell C3 and type a comma. This is the expected growth rate of the first 

fund. 

o Nper: Type the number 10 and then type a comma. We will project the growth of 

these investments in 10 years. 

o Pmt: Type a minus sign (−), click cell D3, and type a comma. Remember that this 

argument must always be preceded by a minus sign. We are assuming that the 

business will consistently generate the profits calculated in the Annual 

Plan worksheet and that these profits will be invested evenly into each fund. 

o Pv: Type a minus sign (–) and click cell B3. Since each fund currently has a balance, 

we need to add this to the Pv argument of the function. Similar to the Pmt argument, 

remember that this argument must also be preceded by a minus sign. 

o Type: Type a closing parenthesis ()) and press the ENTER key. We will assume the 

investments will be made at the end of each year. Therefore, it is not necessary to 
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define this argument since Excel will assume zero, or end of the period, if it is not 

defined. 

33. Copy the FV function in cell E3 and paste it into cells E4 and E5. 

34. Click cell B9 on the Investments worksheet. 

35. Type an equal sign (=) followed by the word SUM and an open parenthesis ((). Highlight the 

range B3:B8, type a closing parenthesis ()), and press the ENTER key. This SUM function 

adds the current balance for all investments. Blank rows are added to the range for the 

function so additional investments will automatically be included in the function output. 

36. Copy the SUM function in cell B9 and paste it into cells D9 and E9. 

37. We will use Goal Seek to determine how many customers we need to service in order to reach 

a savings goal of $250,000. Click cell E9 on the Investments worksheet. Click the What-If 

Analysis button in the Data tab of the Ribbon and select Goal Seek. Click in the “To value” 

input box on the Goal Seek dialog box. Type the number 250000. Click the Collapse Dialog 

button next to the “By changing cell” input box on the Goal Seek dialog box. Click 

the Annual Plan worksheet tab and click cell B6. Press the ENTER key, and click the OK 

button on the Goal Seek dialog box. Click the OK button on the Goal Seek Status dialog box. 

View the number of customers showing in cell B6 in the Annual Plan worksheet. 

38. Save the workbook by adding your name in front of the current workbook name (i.e., “your 

name Chapter 2 CiP Exercise 1”). 

39. Close the workbook and Excel. 

Compare your worksheets with the illustrations on the next two pages. 
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Figure 2.49 Completed CiP Exercise 1 Annual Plan Worksheet 
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Figure 2.50Completed CiP Exercise 1 Investments Worksheet 

 

Figure 2.51Completed CiP Exercise 1 Leases Worksheet 
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Chapter 3 
 

Logical & Lookup Functions 
 

Going beyond the basic computational tools of Excel unlocks unlimited potential for 

processing and analyzing data. This chapter takes you beyond basic Excel computations by 

introducing logical functions and lookup functions. Logical functions are used to assess the 

contents within cell locations and produce custom outputs or mathematical computations. 

We will look at two types of logical functions in this chapter. The first is the IF function, 

which uses a logical test to evaluate the contents in a cell location. The OR and AND 

functions also use logical tests to evaluate the contents in a cell location and are often used 

within the IF function. The second type of logical function that we will look at are statistical 

IF functions. These functions combine the logical test feature of the IF function with the 

mathematical computation features of statistical functions (which were reviewed in 

Chapter 2 "Mathematical Computations"). The last section of this chapter demonstrates the 

use of two lookup functions. These functions are used to find data in one worksheet and 

display it in another. We will demonstrate the skills for this chapter through the 

construction of a personal investment portfolio.  

This theme builds on the personal budget project introduced in Chapter 2 "Mathematical 

Computations". In the personal budget project, we analyzed the impact of investing money 

in an account that provides a continuous rate of return. In this chapter, we look at how you 

can decide where to invest your money and how to analyze the performance of those 

investments. 
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3.1. Logical Functions 

 

This section reviews the use of logical functions in Excel through the construction of an 

investment portfolio. Although it may seem that managing investments is a specialized 

career choice, the reality is that almost everyone will become an investor at some point in 

their lives. Many companies offer employees retirement savings benefits through 401(k) or 

403(b) plans. These plans allow you to deduct money from your paycheck every month, 

tax-free, and invest it. In addition to the tax benefits afforded by such plans, many 

employers match a percentage of your monthly savings or deposit money into your 

retirement account as an added form of compensation. When you sign up for these savings 

plans, your company will give you a list of options as to how your money can be invested, 

and you choose the type of investments you would like the company to make on your 

behalf. Because of this process, you become an investor. Excel can be an extremely valuable 

tool to help you make these investment decisions and analyze the performance of the 

money you have invested. 
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Figure 3.1 "Completed Personal Investment Portfolio Workbook" shows the completed 

investment portfolio workbook that we will complete in this chapter. Like the personal 

budget example in Chapter 2 "Mathematical Computations", the Portfolio Summary 

worksheet contains a summary of the data entered or calculated in other worksheets in the 

workbook. This project begins by building on the Investment Detail worksheet. 

 

 

Freeze Panes  

Follow-along file: Excel Objective 3.00  

The Investment Detail worksheet shown in Figure 3.2 "Investment Detail Worksheet" 

contains the majority of the information used to create the Portfolio Summary worksheet 

shown in Figure 3.1 "Completed Personal Investment Portfolio Workbook". When you first 

open the worksheet, you will notice it is not possible to view all twenty-four columns on 

your computer screen. As you scroll to the right to view the rest of the columns, you will 

lose site of the row headings in Columns A and B. The headings in these columns show the 

investment that pertains to the data in Columns C through X. To solve this problem of 

viewing the row headings while scrolling through the remaining columns in the worksheet, 

we will use the Freeze Panes command. 
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The Freeze Panes command allows you to scroll across the Investment Detail worksheet 

while keeping the row headings in Columns A and B locked in place. The following steps 

explain how to do this:  

1. Click cell C4 on the Investment Detail worksheet. We select this cell because the Freeze 

Panes option locks the columns to the left of the activated cell as well as the rows above the 

activated cell.  

2. Click the View tab on the Ribbon.  

3. Click the Freeze Panes button (see Figure 3.3 "Freeze Panes Command").  

4. Click the Freeze Panes option from the drop-down list of options.  
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Once you click the Freeze Panes option, Columns A and B are locked in place as you scroll 

through the columns in the worksheet. Since this is a large worksheet, you may find it 

easier to navigate the columns by using the arrow keys on your keyboard. However, since 

rows 1 and 2 contain merged cells, make sure a cell location is activated below Row 2 

before you begin using the arrow keys. Figure 3.4 "Freeze Panes Command Activated on 

the Investment Detail Worksheet" shows the appearance of the Investment Detail 

worksheet after the Freeze Panes command has been activated. To deactivate the Freeze 

Panes command, click the Freeze Panes button again and select the Unfreeze Panes option. 

 

Formula and Functions Review 

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.01 if starting here.)  

We will begin developing the personal investment portfolio workbook by adding several 

formulas and functions. The formulas and functions we will add were illustrated in detail in 

Chapter 2 "Mathematical Computations". Therefore, the steps provided in this chapter will 

be brief. After the formulas and functions are added to the Investment Detail worksheet, we 

can add the logical and lookup functions.  

However, before proceeding, let’s review the investment type definitions in Table 3.1 

"Investment Types in Column A of the Investment Detail Worksheet". Table 3.1 provides a 

definition for each of the investment types listed in Column A of the Investment Detail 

worksheet. This project assumes that the personal investment portfolio comprises four 

types of investments. The reason we include a variety of investment types in any portfolio 

is to manage our total risk, or potential of losing money. When building an investment 

portfolio, it is important to keep in mind that investments of all types can dramatically 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                163 

  

increase or decrease in value over a short period of time. Managing risk requires that your 

money is not concentrated in one type of investment. 

 

 

 

We will begin adding formulas and functions to the Investment Detail worksheet in 

sections. If you scroll across all the columns in the worksheet, you will notice the 

worksheet includes five distinct sections. Four of the five sections contain columns that 

need to be completed with formulas and functions before we can add the logical and lookup 

functions. Table 3.2 "Definitions for Columns A through G of the Investment Detail 

Worksheet" contains definitions for each of the columns in the Descriptive Information 

section (Columns A through D) and the Purchase section (Columns E through G). It will be 

helpful to understand the purpose of these columns as we complete this worksheet. 
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The Descriptive Information section of the Investment Detail worksheet (Columns A 

through D) contains only one blank column, which will be completed using a lookup 

function. Therefore, we will proceed to the Purchase section (Columns E through G) where 

the Cost of Purchase column is blank. The following steps explain how to enter the formula 

into this column:  

1. Click cell G4 on the Investment Detail worksheet.  

2. Type an equal sign (=).  

3. Enter a formula that multiplies the Shares Purchased (cell E4) by the Purchase Price per 

Share (cell F4).  
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4. Copy the formula in cell G4.  

5. Highlight the range G5:G18.  

6. Click the down arrow on the Paste button in the Home tab of the Ribbon.  

7. Click the Formulas button from the list of options. This is the Paste Formulas command, 

which pastes only the formula without any associated formats for the copied cell location.  

8. While G5:G18 is highlighted format the cells for comma with no decimal places.  

9. Click cell E19 on the Investment Detailworksheet.  

10. Press and hold the ALT key on your keyboard, then press the equal sign (=). This is the 

shortcut for the Auto Sum feature.  

11. Press the ENTER key on your keyboard. 

12. Click cell G19 on the Investment Detail worksheet.  

13. Repeat step 9.  

14. Press the ENTER key on your keyboard.  

 

Figure 3.5 "Completed Formula in the Cost of Purchase Column" shows the formula that 

was entered into cell G4 in the Purchase section of the Investment Detail worksheet. You 

can also see the results of the formula after it is pasted into the range G5:G18. The Paste 

Formulas option was used to paste the formula into this range so the borders would not be 

altered. 

 
Table 3.3 "Definitions for Columns H through K of the Investment Detail Worksheet" shows 

the definitions for the Current Value section (Columns H through K) of the Investment 

Detail worksheet. 
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Before we continue with the formulas in this worksheet, we will name ranges for future 

use. Highlight A3:X18. On the Formulas ribbon use the Create from selection. Make sure 

Top Row is selected. Uncheck Left Column.  

We will add a basic formula to the Current Purchase Value and Current Investment Value 

columns. For the Estimated Dividend Payments column, we will use the FV (future value) 

function to estimate the dividend payments. The rate for the dividend payments comes 

from the anticipated dividend yield column (D) The following explains how we add the FV 

function to the Estimated Dividend Payments column:  

1. Click cell J4 and type an equal sign (=).  

2. Type the function name FV followed by an open parenthesis (().  

3. For the Rate argument, we will use the Dividend Yield divided by 12 months. From Use in 

Formula select Dividend Yield or start typing Dividend and double 

click on the range name when it appears in the dropdown 

selection window. type a forward slash (/) for division, and then 

type 12. This divides the rate in the Dividend/Yield column by 12. 

The length of ownership of an investment is expressed in terms of 

months in Column Q. Therefore, the rate for the FV function must be expressed in terms of 

months by dividing the annual rate by 12.  

4. Type a comma.  

5. For the Nper we will use the Months Owned from column Q, which contains the number 

of months owned or the term of the future value calculation. Type in Months_Owned  
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6. Type a comma followed by a zero (,0). We are not calculating an annuity or periodic 

investment in this example, so the PMT argument will be defined with a zero. Type a 

comma to advance the function to the Pv argument.  

7. For the PV argument, we will use the Cost of Purchase previously calculated in column G. 

Type a minus sign (−) and start typing cost. Double click on the named range when it 

appears in the drop-down selection box This is the cost of the investment purchase  

8. Type a closing parenthesis ()).  

9. By itself, the FV function is calculating the total value of the investment with dividends or 

interest earned. To show only the amount of dividends or interest earned, we subtract the 

cost of the investment purchase in G4 from the result of the FV function. Type a minus sign 

(−) and click cell G4.  

10. Press the ENTER key on your keyboard.  

11. If necessary, adjust the decimal places for the output of the FV function to zero.  

12. Copy the FV function in cell J4 and paste it into the range J5:J18 using the Paste 

Formulas command.  

13. In J19, sum the column of estimated dividends.  

 

Figure 3.6 "Completed FV Function in the Estimated Dividend Payments Column" shows 

the completed FV function in cell J4 of the Estimated Dividend Payments column. It is 

important to reduce the decimal places to zero after you enter the function into cell J4. 

Excel does not display the result of the function until the decimal places are removed 

because of the column width. 
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The following steps explain how to add the formulas for the Current Purchase Value and 

Current Investment Value columns:  

1. Click cell I4 on the Investment Detail worksheet.  

2. Enter a formula that multiplies the Current Price in cell H4 by the Shares Purchased in 

cell E4.  

3. Copy the formula in cell I4 and paste it into the range I5:I18 using the Paste Formulas 

command. While the range is still highlighted, format for comma with zero decimal places.  

4. Click cell K4 on the Investment Detail worksheet.  

5. Enter a formula that adds the Current Purchase Value in cell I4 to the Estimated Dividend 

Payments in cell J4.  

6. Copy the formula in cell K4 and paste it into the range K5:K18 using the Paste Formulas 

command.  

7. Click cell K19 on the Investment Detail worksheet.  

8. Enter a SUM function that adds the values in the rangeK4:K18. 
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Figure 3.7 "Completed Current Value Section of the Investment Detail Worksheet" shows 

the completed columns of the Current Value section in the Investment Detail worksheet. 

The formula used to calculate the Current Investment Value illustrates why we used the FV 

function to calculate the estimated dividend or interest payments for an investment. 

Investments that earn interest or dividends can achieve growth in two ways. The first way 

is through interest or dividend payments. The second way is through changes in the price 

paid for the investment. The formula used to calculate the Current Purchase Value is taking 

the number of shares purchased for each investment and multiplying it by the current 

market price. Therefore, the Current Investment Value takes into account any changes in 

the investment price by adding the purchase value at the current market price to any 

dividends or interest payments earned. 

 

 
 

Table 3.4 "Definitions for Columns L through R of the Investment Detail Worksheet" 

provides definitions for the Percent of Portfolio section of the Investment Detail worksheet 

(Columns L through R). 

  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                170 

  

 

 

The Percent of Portfolio section of the Investment Detail worksheet (Columns L through R) 

requires two formulas and one function. The following steps explain how we add them to 

the worksheet:  

1. Click on cell K19 and name the cell Total_Current_Value.  

2. Click cell L4 in the Investment Detail worksheet.  
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3. Enter a formula that divides the Current Investment Value in cell K4 by the 

Total_Current_Value in cell K19.  

4. Copy the formula and paste it into the range L5:L18 using the Paste Formulas command.  

5. Click cell N4 in the Investment Detail worksheet.  

6. Enter a formula that subtracts the Target Percent of Portfolio (cell M4) from the Current 

Percent of Portfolio (cell L4): L4−M4.  

7. Copy the formula and paste it into the range N5:N18 using the Paste Formulas command.  

8. Click cell Q19 in the Investment Detail worksheet.  

9. Enter an AVERAGE function that calculates the average of the values in the range Q4:Q18.  

 

Figure 3.8 "Percent of Portfolio Section of the Investment Detail Worksheet “shows the 

results of adding two formulas and a function to the Percent of Portfolio section of the 

Investment Detail worksheet. Notice the absolute reference added to the cell reference for 

K19 in the formula in the Current Percent of Portfolio column. 
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Table 3.5 "Definitions for Columns S through X of the Investment Detail Worksheet" 

provides definitions for the columns in the Performance Analysis section of the Investment 

Detail worksheet. 

 
 

 

 

 

 

 

 

 

Most of the columns in the Performance Analysis section of the Investment Detail 

worksheet will be completed with formulas and functions. The following steps explain how 

we add them to the worksheet:  

1. Click cell S4 on the Investment Detail worksheet.  

2. Enter a formula that subtracts the value in the Cost of Purchase column (cell G4) from 

the value in the Current Investment Value column (cellK4): K4−G4.  

3. Copy the formula and paste it into the range S5:S19 using the Paste Formulas command. 

While the range is still selected, format for comma with not decimal places. Note that this 

formula will be used to calculate the output for the Total row in this column. The results of 

the formula are showing how much money has been earned or lost for each investment. It 

is important to note that these gains or losses do not actually happen unless the investment 

is sold.  

4. Click cell T4 on the Investment Detail worksheet.  

5. Enter a formula that divides the Unrealized Gain/Loss (cell S4) by the Cost of Purchase 

(cell G4): S4/G4.  
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6. Copy the formula in cell T4 and paste it into the range T5:T19 using the Paste Formulas 

command.  

7. Click cell V4 on the Investment Detail worksheet.  

8. Enter a formula that divides the Percent Gain/Loss (cell T4) by the result of dividing the 

Months Owned (cell Q4) by 12: T4/(Q4/12). Dividing the Months Owned value by 12 

expresses the amount of time an investment has been owned in terms of years. The 

benchmark growth rates for most investments are expressed in terms of annual return 

rates. Therefore, this formula must first express the amount of time an investment has been 

owned in terms of years. Then the total percentage gain or loss for each investment is 

divided by the length of ownership in years to calculate the actual annual rate of return. 

9. Copy the formula in cell V4 and paste it into the range V5:V19 using the Paste Formulas 

command.  

10. Click cell W4 on the Investment Detail worksheet.  

11. Enter a formula that subtracts the Target Annual Growth Rate (cell U4) from the Actual 

Annual Growth Rate (cell V4): V4−U4.  

12. Copy the formula in cell W4 and paste it into the range W5:W18 using the Paste 

Formulas command.  

Figure 3.9 "Performance Analysis Section of the Investment Detail Worksheet" shows the 

results of the formulas added to the Performance Analysis section of the Investment Detail 

worksheet. This completes the required formulas and functions necessary to add before 

moving on to the logical and lookup functions of the chapter. 
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The Logical Test 
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.02 if starting here.)  

A key component for the logical functions that will be demonstrated in this section is the 

logical test. A logical test is used in logical functions to evaluate the contents of a cell 

location. The results of the logical test can be either true or false. For example, the logical 

test C7 = 25 (read as “if the value in cell C7 is equal to 25”) can be either true or false 

depending on the value that is entered into cell C7. A logical test can be constructed with a 

variety of comparison operators, as shown in Table 3.6 "Comparison Operator Symbols and 

Definitions". These comparison operators will be used in the logical test arguments for the 

logical functions demonstrated in this chapter. 

 
A logical test will be used to evaluate the contents of a cell location in the Investment Detail 

worksheet. We will first demonstrate how the logical test is used to evaluate the contents of 

a cell location. Then we will use this logical test in the IF function, which will be 

demonstrated next. The following steps explain how the logical test is constructed:  

1. Click cell R4 on the Investment Detail worksheet.  

2. Type an equal sign (=).  

3. Click cell Q4.  

4. Type the greater than sign (>) followed by an equal sign(=).  

5. Type the number 12. This completes the logical test, which is shown in Figure 3.10 

"Logical Test Entered into the Investment Detail Worksheet". The logical test would be 

stated as: “If the value in cell Q4 is greater than or equal to 12.”  

6. Press the ENTER key on your keyboard. Notice that the output of the logical test is the 

word TRUE. This is because the value in cell Q4 is 48, which is greater than 12. 7. Copy the 

logical test in cell R4 and paste it into the range R5:R18 using the Paste Formulas 

command. 
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Figure 3.11 "Output of the Logical Test" shows the results of the logical test after it is 

pasted into the range R5:R18. Notice that for any values that are less than 12 in the range 

Q4:Q18, the logical test produces an output of FALSE. 
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IF Function  

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.03 if starting here.)  

The IF function is used to produce a custom output based on the results of a logical test. If 

the results of the logical test are TRUE, the IF function will display a specific number or 

text, or perform a calculation. If the results of the logical test are FALSE, the IF function will 

display a different number or text, or perform a different calculation.  

=IF(Logical_Test, Value_if_true, Value_if_false) 

The arguments of the IF function are defined in Table 3.7 "Arguments for the IF Function". 

 
We will use the IF function in the Percent of Portfolio section of the Investment Detail 

worksheet. We will use the logical test that was previously demonstrated within the IF 

function to determine if an investment has been held for a short or long period of time. For 

tax purposes, an investment is considered short-term if it is held less than twelve months. 

This requires the investor to pay a higher tax percentage for any profit earned on the 

investment. An investment held twelve months or longer is considered a long- term 

investment. The following explains how the IF function is used to identify which 

investments are long term or short term:  
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1. Highlight the range R4:R18 on the Investment Detail worksheet and press the DELETE 

key on your keyboard. This will remove the logical test and allow us to replace it with an IF 

function.  

2. Click cell R4 on the Investment Detail worksheet.  

3. Click the Formulas tab on the Ribbon.  

4. Click the Logical button in the Function Library group of commands.  

5. Click the IF function from the list of functions (see Figure 3.12 "Selecting the IF Function 

from the Function Library"). This opens the Function Arguments dialog box. 

 
6. Click in the Logical_test argument (see Figure 3.13 "Logical_Test Argument Defined").  

7. From the Use in Formula select the range Months_Owned. 

8. Type the greater than sign (>) followed by an equal sign(=).  

9. Type the number 12.  

Figure 3.13 "Logical_Test Argument Defined" shows the appearance of the IF Function 

Arguments dialog box after defining the Logical_test argument. Notice that next to the 

Logical_test input box, Excel shows that the results of the test are true. This makes sense 

given that the value in cell Q4 is 48, which is greater than 12. 
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10. Press the TAB key on your keyboard to advance to the next argument, which is 

Value_if_true.  

11. Type the word Long in quotation marks. If you forget to put words or text in quotation 

marks using the Function Arguments dialog box, Excel will insert the quotation marks for 

you.  

12. Press the TAB key on your keyboard to advance to the next argument, which is 

Value_if_false.  

13. Type the word Short in quotation marks.  

14. Click the OK button on the Function Arguments dialog box to complete the function.  

15. Copy the IF function in cell R4 and paste it into the range R5:R18. 
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Figure 3.14 "Completed Function Arguments Dialog Box for the IF Function “shows the 

completed Function Arguments dialog box for the IF function. Notice that the results of the 

function are displayed in the dialog box. Since the value in cell Q4 is greater than 12, the 

word Long will be displayed in cell R4. 

 
Figure 3.15 "IF Function Output" shows the completed Long/Short Indicator column on the 

Investment Detail worksheet. Notice the word Short is displayed for any investment held 

less than twelve months.  

 

Figure 3.15 IF Function Output 
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Assumption Tables  

Assumption tables are set up and used in Excel worksheets to avoid entering actual 

numbers into a function. Instead, they provide a convenient area to enter the variables in 

your data that might change. For instance, payments on a mortgage could be 12 (monthly), 

26 (every two weeks), 4 (quarterly), or 2 (semi-annually). By providing a cell to link to in 

your functions, you only need to change that one cell to change the results of your formulas.  

We will set up assumption tables in our Excel file. The fields in the file will be named so that 

the function arguments are easy to understand. Remember that naming a cell will make it 

an absolute cell reference. It is the equivalent of $A$1 where both the row and column 

reference are anchored.  

 

The OR Function  

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.04 if starting here.)  

The OR function is like the IF function in that it uses a logical test to evaluate the contents 

of a cell location. However, the OR function allows you to define several logical tests as 

opposed to just one.  

If one of the logical tests is true, the output of the function will be the word TRUE. If all the 

logical tests are false, the output of the function will be the word FALSE. This differs from 

the IF function because the output of the function is only the word TRUE or the word 

FALSE. As a result, the OR function is commonly used within the IF function to enable 

specific outputs to be defined. 
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 The purpose of this column is to identify any investment where either the Unrealized 

Gain/Loss is less than zero or the Target vs. Actual Growth Rate is less than –1%. We will 

use the function in the logical test of an IF function so we can define a specific output based 

on the results of the OR function. We will set up the assumption table and then 

demonstrate how the OR function works by itself, which is outlined in the following steps: 

1. Click cell A21 in the Investment Detail worksheet.  

2. Type Assumption Table and press Enter  

3. In cell A22 type Unrealized Gain Loss <  

4. In cell B22 type 0  

5. In cell A23 type Actual Growth Rate <  

6. In cell B23 type ( -1%) (minus 1 percent)  

7. Highlight cells A22:B23, on the Formula Ribbon, Defined Names section, Create from 

Selection. Make sure column is checked and click OK  

8. Click cell X4 and type an equal sign (=).  

9. Type the function name OR and double click on the function when it appears in the 

function list.  

10. Click cell S4 on the Investment Detail worksheet. (This is the first cell we are testing in 

our logical test.)  

11. Type the less than symbol (<) then click on cell B22. This completes the first logical test, 

which is evaluating if the value in cell S4 is less than zero. The named cell 

Unrealized_Gain_Loss will appear in your function. 

12. Type a comma. This advances the function to a second logical test. 

13. Click cell W4 on the Investment Detail worksheet. (This is the second cell we are testing 

in our logical test.) 

14. Type the less than symbol (<) then click on cell B23. (The named cell 

Actual_Growth_Rate will appear in your function.) This completes the second logical test, 

which is evaluating if the value in cell W4 is less than –1%. 

15. Type a closing parenthesis ()) and press the ENTER key on your keyboard. 

16. Copy the OR function in cell X4 and paste it into the range X5:X18 using the Paste 

Formulas command. 
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Figure 3.16 "Completed OR Function by Itself" shows the construction and result of the OR 

function by itself. Notice that the only output of the function is the word TRUE or the word 

FALSE. If either the Unrealized Gain/Loss is less than zero or the Target vs. Actual Growth 

Rate is less than −1%, the function shows the word TRUE. However, these descriptions will 

not be helpful for the person using this worksheet. Displaying the words OK or Warning 

would be far more helpful in identifying investments that need to be evaluated. The only 

way we can return a text response to the result of the OR function is to nest it in an IF 

function. We can do this if we use the OR function as the logical test argument of the IF 

function. 

 

 

 

The following steps explain how to accomplish this: 

1. Highlight the range X4:X18 on the Investment Detail worksheet and press the DELETE 

key on your keyboard. We are going to start over by creating an IF function. 

2. Click cell X4 on the Investment Detail worksheet. 

3. Type an equal sign (=). 

4. Type the function name IF followed by an open parenthesis ((). 

5. Type the function name OR followed by an open parenthesis ((). The OR function is being 

placed into the logical_test argument of this IF function. 

6. Click cell S4 on the Investment Detail worksheet. 

7. Type the less than symbol (<) click cell B22. 

8. Type a comma. This advances the function to a second logical test. 

9. Click cell W4 on the Investment Detail worksheet. 
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10.Type the less than symbol (<) then click cell B23. 

11. Type a closing parenthesis ()). 

12. Type an equal sign (=). 

13. Type the word TRUE. Do not put the word inside quotation marks. 

14. Type a comma. This completes the logical_test argument of the IF function. We can now 

go on to define the value_if_true and the value_if_false arguments. This will allow us to 

specify what the output of the function should be instead, using the OR function outputs of 

either TRUE or FALSE. 

15. Type the word Warning. Be sure to enclose the word in quotation marks. 

16. Type a comma. This will advance the function to the value_if_false argument. 

17. Type the word OK. Be sure to enclose the word in quotation marks. 

18. Type a closing parenthesis ()) and press the ENTER key on your keyboard. 

19. Copy the IF function in cell X4 and paste it into the range X5:X18 using the Paste 

Formulas command. 

Figure 3.17 "OR Function in the Logical Test of the IF Function" shows the OR function 

within the logical_test argument of the IF function. The logical test of the IF function is now 

evaluating if the results of the OR function are true. 

 

The AND Function  
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.05 if starting here.)  

The portfolio manager wants to create a function that will help him make decisions about 

buying, holding, or selling different investments in the portfolio. The criteria around the 

decision will be: 

• Buy when the fund’s Current vs Target percent of portfolio value is less than 1% 

AND the fund’s Unrealized Gain/Loss is greater than 0.  

• Otherwise sell or hold the fund in the portfolio.  
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He will do that by using the AND as the logical test to decide to buy, sell or hold the fund.  

The AND function is almost identical to the OR function in that it is composed of only logical 

tests and produces one of two possible outputs: TRUE or FALSE. However, all logical tests 

defined for the AND function must be true to produce a TRUE output. If one logical test is 

false, the function will produce a FALSE output. We will use the AND function to complete 

the Buy/Sell Indicator column on the Investment Detail worksheet. This column will show 

either the word Buy or the words Hold or Sell based on the results of the logical test 

argument of an IF function. We will expand our assumption table to incorporate these new 

parameters and then use the AND function to define the logical test argument of the IF 

function. The following steps explain how to accomplish this:  

1. In cell A25 Type: Hold/Sell Criteria:  

2. In cell A26 type Buy Current vs Target<  

3. In cell B26 enter (-1%)  

4. In cell A27 type Long Term >  

5. In cell B27 enter (12)  

6. In cell A28 enter Sell Target vs Growth >  

7. In cell B28 enter 1%  

8. In cell A29 enter Unrealized Gain >=  

9. In cell B29 enter (0).  

10. We need to name the new cells. Name the new assumption cells by highlighting 

A26:B29 and on the Formula ribbon, Create from selection. Make sure left column is 

checked and click OK.  

11. Click cell P4 on the Investment Detail worksheet.  

12. Type an equal sign (=).  

13. Type the function name IF followed by an open parenthesis ((). The logical test we will 

use is the criteria given above. We will test to see if the Current vs Target percent of 

portfolio value is less than 1% AND the fund’s Unrealized Gain/Loss is greater than 0.  
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14. Type the function name AND followed by an open parenthesis ((). The AND function is 

being placed into the logical_test argument of this IF function.  

15.Click cell N4(the fund’s current vs. target value) and then type the less than symbol(<). 

16. Click cell B26. Buy Current_vs_Target named cell will appear. 

17. Type a comma. This advances the AND function to the second argument in the AND 

function.  

18. TypeS4. (Unrealized gain/loss) (Your function maybe overlapping S4 and you may not 

be able to click on it.)  

19. Type a greater than symbol (>) followed by an equal sign (=). These symbols are used 

to evaluate if the value in a cell location is greater than or equal to a target value.  

20. Click on cell B22. This will place your named cell Unrealized_Gain into the AND.  

21. Close the AND function by closing parenthesis ())  

22. Type an equal sign (=) followed by the word TRUE. Do not enclose the word in 

quotation marks.  

23. Type a comma. This advances the IF function to the value_if_true argument.  

24. Type the word Buy enclosed in quotation marks as shown in Figure 3.19 "Results of the 

AND Function in the Logical Test Argument of an IF Function". If the Current vs. Target 

value is less than −1% and the Unrealized Gain/Loss is greater than or equal to zero, the 

function will show the word Buy. In other words, if the investment is less than the desired 

percentage for the total portfolio and it is currently not losing money, we will buy more of 

that investment, so it is in line with the target percentage of the portfolio.  

25. Type a comma.  

26. Type the words “Hold or Sell” enclosed in quotation marks. For all other investments 

that are not designated with a Buy indicator, the function will show the words Hold or Sell. 

This indicates that an investment could either be held or sold.  

27. Type the closing parenthesis ()). Then press the ENTER key on your keyboard. You 

should see the result “Buy” in cell P4.  
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28. Copy the IF function in cell P4 and paste it into the range P5:P18 using the Paste 

Formulas command or the Auto fill.  

29. Increase the width of Column P to 12 points.  

Figure 3.18 "AND Function Placed in the Logical Test of an IF Function" shows the 

appearance of the AND functions that has been added to the logical test of the IF functions. 

 

 

Figure 3.19 "Results of the AND Function in the Logical Test Argument of an IF Function" 

shows the results of the completed AND function within an IF function after it is copied and 

pasted into the range P5:P18. 
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Simple Nested IF Functions  
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.06 if starting here.)  

When constructing the IF function, the logical test can produce only two potential 

outcomes when evaluating the data in a cell. In addition, the function can produce only two 

possible outputs, which are defined in the value_if_true and value_if_false arguments. 

However, there may be situations when you need to test for several possible outcomes, 

which may require more than two possible outputs. To accomplish this, you need to create 

a nested IF function. A nested IF function is when either the value_if_true or value_if_false 

arguments are defined with another IF function.  

For the Personal Investment workbook, a nested IF function is required to complete the 

Rebalance Indicator column (Column O) on the Investment Detail worksheet (see Figure 

3.19 "Results of the AND Function in the Logical Test Argument of an IF Function"). The 

purpose of this column is to indicate where the portfolio needs to be rebalanced.  

Looking at the Current vs. Target column (Column N) you can see that several investments 

have a significant negative number where the investment value has fallen below the target 

percentage for the portfolio. Other investments have a significant positive number where 

the investment has exceeded the target percentage for the portfolio. For this portfolio, a 

number greater than 1% or less than –1% will be considered significant. Therefore, we will 

need to assess three possible outcomes when creating a logical test that evaluates the 

values in Column N. Those are: 

• The first test will be if the Current vs. Target value is greater than 1% we will 

Rebalance the portfolio.  

• The second test will be if the Current vs. Target value is less than –1% we will 

Rebalance the portfolio.  

• The third test will be if both the first test and the second test are false, we are OK 

with the portfolio.  

Because this problem involves three tests, we need to construct a nested IF function to 

produce the outputs in the Rebalance Indicator column. The first thing we will do is add to 

our assumption table.  

1. In cell A31 type Rebalance Portfolio  

2. In cell A32 type Low Current vs. Target  
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3. In cell B32 type -1% (It is important to use the percent symbol (%) after the number 1. If 

you omit the percent symbol, Excel will test if the value in cell N4 is greater than 100%.)  

4. In cell B33 type High Current vs. Target  

5. In cell C33 type 1%  

6. Name the new assumptions by highlighting cells A32:B33 and Create from selection on 

the Formula ribbon. Make sure Left Column only is checked.  

Now that the assumption table has been created we can use the following steps to create 

the Nested IF:  

1. Click cell O4 on the Investment Detail worksheet.  

2. Type an equal sign (=).  

3. Type the function name IF followed by an open parenthesis (().  

Now the logical test:  

4. Click cell N4.  

5. Type the greater than symbol (>) then click on cell B33 or find the named cell 

(High_Current_vs_Target), in the Use in Formula drop-down from the Formulas ribbon.  

6. Type a comma. 

Now the Value_if_true:  

7. Type the word Rebalance inside quotation marks. When using text data to define any of 

the arguments for the IF function, the text must be placed inside quotation marks.  

8. Type a comma.  

The Value_if_false argument will be another IF function.  

9. Start another IF function by typing the function name IF followed by an open parenthesis 

(().  

Second IF function’s logical test.  

10. Click cell N4.  
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11. Type the less than symbol (<) then click on cell B32 or find the named cell 

(Low_Current_vs_Target), in the Use in Formula drop-down from the Formulas ribbon. 

12. Type a comma. 

Second IF’s Value_if_true argument. 

13. Type the word Rebalance inside quotation marks. 

14. Type a comma. 

Second IF’s Value_if_false argument. 

15. Type the word OK inside quotation marks. 

16. Type two closing parentheses ())). Since two IF functions were started, there are two 

open parentheses in the function. As a result, we need to add two closing parentheses; 

otherwise, Excel will produce an error message stating that a closing parenthesis is 

missing. Excel color codes the parenthesis so you know which function you are closing with 

each colored parenthesis. 

17. Press the ENTER key on your keyboard.  

18. Copy the nested IF function in cell O4 and paste it into the range O5:O18 using the Paste 

Formulas command. 

 

Figure 3.20 "Completed Nested IF Function" shows how the completed nested IF function 

should appear in cell O4 of the Investment Detail worksheet. In addition, we see the results 
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of the function after it was pasted into the range O5:O18. Notice that for any investment 

where the Current vs. Target value is between plus or minus 1%, the word OK appears. 
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Nested Logical Functions  

Let’s revisit the IF(AND) function we created earlier. We will change the IF function so that 

it will nest a second IF and give us a Hold or Sell decision. The additional condition we are 

adding to our previous function is:  

• Sell when  

o the Current vs Target percent is greater than 1,  

o the Unrealized Gain/Loss is greater than or equal to zero,  

o AND the Months Owned is greater than 12.  

• Otherwise Hold  

Change the existing IF(AND) by:  

1. Return to the Buy/Sell Indicator Column  

2. Click the F2 function key to enter the edit mode. (You can also double-click in the cell.)  

3. Position your cursor after the “Buy”, Make sure you are on the right side of the comma.  

Now we will test to see if we should Hold or Sell by inserting a second IF function as the 

false result for our first IF function.  

4. Type the function name IF followed by an open parenthesis (().  

5. Type the function name AND followed by an open parenthesis ((). The AND function is 

being placed into the logical_test argument of this IFfunction.  

6. Click cell N4(the fund’s current vs. target value) and then type the less than symbol(=).  

7. Click cell B26. Your Current_vs_Target named cell will appear.  

8. Type a comma. This advances the AND function to the second logical test.  

9. Click cellS4. (Unrealized gain/loss)  

10. Type a greater than equal to (>=). These symbols are used to evaluate if the value in a 

cell location is greater than or equal to a target value.  

11. Click on cell B22. This will place your named cell Unrealized_Gain_Loss into the AND.  
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12. Type a comma.  

13. Last, we will test to see if the Months Owned is greater than 12 which will put us into 

the long-term investment category. Click on cell R4.  

14. Type a greater than (>) 

15. Click on cell B27. Long Term will show in your formula.  

16. Close the parenthesis for the AND function.  

17. Type an equal sign (=) followed by the word TRUE. Do not enclose the word in 

quotation marks. Type a comma.  

18. Type the word “Sell” enclosed in quotation marks.  

19. Type a comma  

20. Type the word “Hold” enclosed in quotation marks. For all other investments that are 

not designated with a Buy indicator, the function will show the words Hold or Sell. This 

indicates that an investment could either be held or sold.  

21. Type two closing parenthesis ())) one to close the second IF function and the second to 

close the first IF function.  

22. Then press the ENTER key on your keyboard.  
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Basic Conditional Formats 

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.07 if starting here.)  

A feature related to the skills used to create logical functions is conditional formatting. 

Conditional formats allow you to apply a variety of formatting treatments based on the 

contents of a cell location. A logical test like the ones used in the IF, AND, and OR functions 

is used to evaluate the contents of a cell and apply a designated formatting treatment. For 

example, looking at Figure 3.20 "Completed Nested IF Function", you will notice that the 

Unrealized Gain/Loss column is formatted using the accounting number format. Negative 

numbers are enclosed in parentheses. However, to make these numbers stand out, we can 

use conditional formatting to change the font color to red. We will do this for the 

Unrealized Gain/Loss and Percent Gain/Loss columns. The following steps explain how 

conditional formats are applied to the cell locations in these columns:  

1. Highlight the range S4:T18 on the Investment Detail worksheet.  
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2. Click the Conditional Formatting button in the Styles group of commands on the Home 

tab of the Ribbon.  

3. Click the New Rule command from the list of options. This will open the New Formatting 

Rule dialog box. 

4. At the top of the New Formatting Rule dialog box, you will find a list of options under the 

Select a Rule Type heading. Click the second option that states “Format only cells that 

contain.” 

5. In the lower portions of the New Formatting Rule dialog box, you will see several 

dropdown boxes under the heading Edit the Rule Description. Make sure the first drop-

down box is set to Cell Value. 

 
6. Click the second drop-down box in the Edit the Rule Description section of the New 

Formatting Rule dialog box and select the “less than” option.  

7. Click in the input box, which is next to the drop-down box that was set in the previous 

step and type a zero. This completes the logical test of the conditional format, which is 

going to evaluate if the value in any of the cells in the range S4:T18 is less than zero. 

8. Click the Format button, which is near the bottom of the New Formatting Rule dialog box. 

This will open the Format Cells dialog box.  

9. Click the drop-down box in the Color section of the Format Cells dialog box and select the 

red square from the color palette (see Figure 3.22 "Format Cells Dialog Box"). 
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10. Click the OK button at the bottom of the Format Cells dialog box.  

11. Click the OK button at the bottom of the New Formatting Rule dialog box. This 

completes the Conditional Formatting rule that will be applied to cells in the range S4:T18.  

12. Figure 3.22 "Format Cells Dialog Box" shows the Format Cells dialog box. This opens 

when the Format button is clicked on the New Formatting Rule dialog box. Notice the tabs 

running across the top of the dialog box. All formatting features in Excel are grouped by 

category, which can be accessed by clicking the related tab on the Format Cells dialog box. 

You will see some of the formatting commands in light grey. This indicates that these 

commands cannot be used with the Conditional Formatting feature. You can use the Format 

Cells dialog box to apply any formatting features by clicking the Format Cells dialog button 

on the Home tab of the Ribbon.  
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Figure 3.23 "New Formatting Rule Dialog Box" shows the final settings for the New 

Formatting Rule dialog box. It is important to note that the “Format only cells that contain” 

option was selected in the New Formatting Rule dialog box to set a basic logical test that 

can be used to apply formatting commands automatically based on the values in cell 

locations. 
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Figure 3.24 "Conditional Format Applied to the Range S4:T18" shows the results of the 

conditional formatting rule that was applied to the range S4:T18. Notice the font color is 

automatically changed to red for negative numbers. 
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3.2. Statistical IF Functions 

 

This section will demonstrate the use of statistical IF functions. Statistical IF functions 

provide you with the ability to evaluate the contents in a cell location before including them 

in a mathematical calculation. This allows you to selectively include targeted cell locations 

when executing statistical calculations such as sum, average, count, and so on. We will use 

several statistical IF functions to construct the Portfolio Summary worksheet shown in 

Figure 3.1 "Completed Personal Investment Portfolio Workbook", which contains two main 

sections. The Total Summary section (Rows 2 through 8) shows an overview for all 

investments in the portfolio by investment type. This will allow us to compare the growth 

performance among the Bond Funds, Domestic Stock Funds, and others. The Poor 

Performing Investments section (Rows 9 through 15) will provide an overview of poor 

performing investments by investment type. For the purposes of this exercise, we will 

define a poor performing investment as one where the growth rate is below the target 

growth rate by more than 1% (see Column W on the Investment Detail worksheet). The 

statistical IF functions will allow us to establish criteria to select targeted investments that 

can be included in the calculations for each section of the Portfolio Summary worksheet. 

 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                200 

  

The COUNTIF Function 

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.08 if starting here.) 

The COUNTIF function differs from the regular COUNT function in two ways. First, the 

regular COUNT function counts only the number of cells in a range that contain numeric 

data. The COUNTIF function counts the number of cells in a range that contain numeric or 

text data. Second, the COUNTIF function allows you to selectively count the cells in a range 

based on specific criteria.  

The COUNTIF function contains two arguments: range and criteria.  

• The range argument is defined with the range of cells that will be counted.  

• The criteria argument is defined with the criteria that will be used to decide if a 

cell in the range should be included in the output of the function.  

In the Portfolio Summary worksheet, we want to count the number of investments of each 

type without having to rearrange our source data accomplish the task. The advantage of 

using the COUNTIF function is that it does not matter how the source data is sorted. It will 

find a match for the criteria and add one to the running total it is calculating. We will also 

see the power of naming the ranges in the Investment Detail worksheet because it will 

make these functions much easier to construct.  

The following steps explain how we can use the COUNTIF function to calculate the number 

of investments by investment type on the Portfolio Summary worksheet:  

1. Click on the Portfolio Summary tab if the worksheet is not already active.  

2. Click cell B4 on the Portfolio Summary worksheet.  

3. Click the Formulas tab of the Ribbon.  

4. Click the Insert Function button in the Function Library group of commands.  

5. In the Search for a function box type COUNT, then click Go. A list of Excel functions that 

include the Count or an ability to count show in the Select a function box.  

6. Click the scroll down arrow on the second drop-down list to find the COUNTIF function 

(see Figure 3.25 "Selecting the COUNTIF Function from the Function Library"). 
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7. Click the COUNTIF function. This will open the Function Arguments dialog box.  

8. Click in the Range argument on the Function Arguments dialog box and from the 

Formulas ribbon in the Defined Names section click the drop-down arrow next to Use in 

Formula. (see Figure 3.26 "Completed Function Arguments Dialog Box for the COUNTIF 

Function").  

9. Select Investment Type from the drop-down list of named cells and ranges. After 

selecting it you will see a list of the investment types to the right of the Range box. 

10. Press the TAB key on your keyboard to advance to the next argument, which is the 

Criteria argument. Then type the cell location A4. The criteria for the function will be the 

investment type entered into cell A4 on the Portfolio Summary worksheet. 
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11. Click the OK button at the bottom of the Function Arguments dialog box. Figure 3.26 

"Completed Function Arguments Dialog Box for the COUNTIF Function" shows the 

completed Function Arguments dialog box for the COUNTIF function. Notice the absolute 

references that were placed on each cell location in the range that was used to define the 

Range argument. The Criteria argument is defined with the cell A4, which means the 

function will only count cell locations in the range A4:A18 where the contents in the cell 

match the contents in cell A4. 

 

12. Copy the function in cell B4 and paste it into the range B5:B7 using the Paste Formulas 

command. (You can copy the function because you have linked to the investment type in 

column A)  

13. Enter a SUM function in cell B8 that sums the values in the range B4:B7. 

Figure 3.27 "COUNTIF Function Output in the Portfolio Summary Worksheet “shows the 

results of the COUNTIF function after it is pasted into the range B5:B7. Because of relative 

referencing, the cell location used in the criteria argument is changed after the function is 

pasted into the range B5:B7. For example, in cell B6, the function is counting the cell 

locations in the range A4:A18 where the contents match the contents of cell A6. This allows 

you to use the function to count the number of investments per investment type. As shown 

in the figure, the range B4:B7 now shows the number of investments in this portfolio by 

investment type. Naming the range for the Range criteria creates an absolute range 

reference. 
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The AVERAGEIF Function 

The AVERAGEIF Function Follow-along file: Continue with Excel Objective 3.00. (Use file 

Excel Objective 3.09 if starting here.) The AVERAGEIF function performs the identical 

mathematical calculation as the regular AVERAGE function. However, like the COUNTIF 

function, it allows you to define criteria that will select cells in a range that will be used in 

the function output. The AVERAGEIF function differs from the COUNTIF function in that it 

allows you to define two cell ranges instead of one.  

• The first range pertains to the criteria that will be used to select cells for the function 

output. 

• The second range contains the values that will be used to calculate the arithmetic mean. 

Table 3.8 "Arguments for the AVERAGEIF and SUMIF Functions" provides definitions for 

the arguments contained in the AVERAGEIF and SUMIF functions. 
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The AVERAGEIF function will be used in the Portfolio Summary worksheet to calculate the 

average length of time that investments for each investment type are held. The following 

steps explain how to add this function to the worksheet:  

1. Go to the Portfolio Summary worksheet and click cell C4.  

2. Click the Formulas tab of the Ribbon.  

3. Click the Insert Function button in the Function Library group of commands.  

4. In the Search for a function box type AVERAGE, then click Go. A list of Excel functions 

that include the AVERAGE or an ability to average show in the Select a function box.  

5. Click the scroll down arrow on the second drop-down list to find the AVERAGEIF 

function.  

6. Click in the Range argument on the Function Arguments dialog box and from the 

Formulas ribbon in the Defined Names section click the drop-down arrow next to Use in 

Formula. (see Figure 3.26 "Completed Function Arguments Dialog Box for the COUNTIF 

Function"). 

7. Select Investment Type from the drop-down list of named cells and ranges. After 

selecting it you will see a list of the investment types to the right of the Range box.  
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8. Press the TAB key on your keyboard to advance to the Criteria argument and type the 

cell location A4. The criteria for the function will be the investment type entered into cell 

A4 on the Portfolio Summary worksheet.  

9. Click in the Average_Range box and from the Formula Ribbon, Defined Names section, 

click on the Use in Formula drop down arrow and select Months_Owned. (see Figure 3.28 

"Defined Arguments for the AVERAGEIF Function").  

10. Click the OK button at the bottom of the Function Arguments dialog box.  

Figure 3.28 "Defined Arguments for the AVERAGEIF Function" shows the Function 

Arguments dialog box for the AVERAGEIF function that will be input into cell C4. Use of 

named ranges creates absolute cell references in the Range and Average_range arguments. 

The function will evaluate the cells in the range A4:A18 using the value that exists in cell A4 

on the Portfolio Summary worksheet. When a cell in the range A4:A18 meets the criteria, 

the function will pull the cell location in the same row from the range Q4:Q18 and include it 

in the average calculation. 

 

11. Copy the function in cell C4 and paste it into the range C5:C7 using the Paste Formulas 

option.  

12. In cell C8 create an AVERAGE function that will average the months owned for all the 

investments in the portfolio by typing =AVERAGE(Months_Owned). Note: You cannot add 

averages together because it creates a nonsense number. A number that has no meaning 

because it is out of context. 
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Figure 3.29 "AVERAGEIF Function Output on the Portfolio Summary Worksheet" shows the 

output of the AVERAGEIF function in the Average Months Owned column on the Portfolio 

Summary worksheet.  

The function calculates the average months owned in Column Q on the Investment Detail 

worksheet where the investment type is equal to the description entered in the range 

A4:A7 on the Portfolio Summary worksheet. 

 

The SUMIF Function  

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.10 if starting here.)  

The SUMIF function performs the same mathematical calculation as the regular SUM 

function. However, like the AVERAGEIF function, this function allows you to select specific 

cells from a range that will be used in the output. The arguments for the SUMIF function are 

identical to the AVERAGEIF function except instead of averaging the result, Excel will be 

adding the result. (see Table 3.8 "Arguments for the AVERAGEIF and SUMIF Functions").  

We will use the SUMIF function in two columns on the Portfolio Summary worksheet. The 

first column will show the total investment cost for each investment type. The second 

column will show the total current value for each investment type. This will allow us to 
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calculate the total annual growth rate for each investment type. The following steps explain 

how we will use this function to complete the first column:  

1. On the Investment Detail worksheet highlight the Cost of Purchase range G3:G18. From 

the Formula ribbon, Defined Names section, Click on Create from Selection. Make sure top 

row is selected and OK.  

2. Go to the Portfolio Summary worksheet and click cell D4. 

3. In cell D4 type an = sum. You will see a list of functions or named cells that start with the 

letters sum. Double click on the SUMIF from the list of 

functions.  

4. The first argument in the function is the range that will be 

used to find a match to the criteria. In this case it will be the 

named range Investment_Type. We will access this named 

range by typing the name in the function. When you see the 

named range appear in the drop-down list of Function and 

named ranges, double click the named range to insert it into 

your function.  

5. Type a comma.  

6. The next argument is the Criteria, click in cell A4 and then type another comma.  

7. From the Use in Formula drop down on the Formulas ribbon, select the named range 

Cost_of_Purchase.  

8. Type your closing parenthesis ()). 

 

9. Copy the function in cell D4 and paste it into the range D5:D7.  

10. While the range D5:D7 is selected, format Comma with zero decimal places.  

11. Use AutoSum to total the column in cell D8.  

12. Format the top and total row with a $ and zero decimal places. Format the cells D5:D7 

comma style with zero decimal places. 
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To complete the Current Value data on the Portfolio Summary worksheet, follow the steps 

above except we will use the Current Investment Value range K3:K18 from the Investment 

Detail worksheet and use that range in our new SUMIF.  

1. On the Portfolio Summary worksheet and click cell E4.  

2. In cell E4 type an = sum. You will see a list of functions or named cells that start with the 

letters sum. Double click on the SUMIF from the list of functions.  

3. The first argument in the function is the range that will be used to find a match to the 

criteria. In this case it will be the named range Investment_Type. We will access this named 

range by typing the name in the function. When you see the named range appear in the 

drop-down list of Function and named ranges, double click the named range to insert it into 

your function.  

4. Type a comma.  

5. The next argument is the Criteria, click in cell A4 and then type another comma.  

6. From the Use in Formula drop down on the Formulas ribbon, select the named range 

Current_Investment_Value.  

7. Type your closing parenthesis ()). 

 

8. Copy the function in cell E4 and paste it into the range E5:E7.  

9. Use AutoSum to total the column in cell E8.  

10. Format the top and total row with a $ and zero decimal places.  

11. Format the cells E5:E7 comma style with zero decimal places.  

Figure 3.31 "SUMIF Function Outputs in the Portfolio Summary Worksheet" shows the 

results of the SUMIF function in the Total Purchase Cost and Current Value columns in the 

Portfolio Summary worksheet. 
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A formula can now be added to show the annual growth for each investment category. The 

following steps explain how to add this formula to the Portfolio Summary worksheet:  

A few things to know before you begin. When creating a percent change between an old 

value (in this case the Purchase Cost) and the new value (Current Value) you always 

subtract the old from the new, then divide by the old. The formula would look like: =(new 

value-old value)/old value. The (new value – old value) is the amount of change that has 

occurred.  

Remember back to the order of operations. For this formula to work correctly Excel must 

subtract before it does the division. We will force our formula to do that by enclosing the 

subtraction inside parenthesis which will tell Excel to do the subtraction first.  

The steps to accomplish this are:  

1. Click cell F4 on the Portfolio Summary worksheet.  

2. Type an equal sign (=) followed by two open parentheses ((().  

3. Click cell E4 and type a minus sign (−). 
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4. Click cell D4 and type a closing parenthesis ()).  

5. Type a slash (/) for division and click cellD4.  

6. Type a closing parenthesis ()). This completes the first part of the formula, which is 

calculating the growth rate between the Total Purchase Cost (cell D4) and the Current 

Value (cell E4).  

7. Type a slash (/) for division followed by an open parenthesis (().  

8. Click cell C4, which is the Average Months Owned.  

9. Type a slash (/) for division and the number 12. This part of the formula converts the 

number of months owned to years by dividing it by 12. This result is being divided into the 

growth rate, which will then show the average growth per year.  

10. Type a closing parenthesis ()) and press the ENTER key on your keyboard. 

 

11. Copy the formula in cell F4 and paste it into the range F5:F8 using the Paste Formulas 

command.  

Figure 3.32 "Completed Annual Growth Column in the Portfolio Summary Worksheet" 

shows the results of the statistical IF functions that were added to the Total Summary 

section of the Portfolio Summary worksheet. The statistical IF functions used on this 

worksheet allowed us to group the details in the Investment Detail worksheet by 

investment type. Once this was accomplished, we added a formula to show the annual 

growth rate by investment type. 
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The COUNTIFS Function  

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.11 if starting here.)  

Up to this point, the statistical IF functions that were demonstrated provided the ability to 

define one criteria or logical test used to select cells from a targeted range. The next set of 

statistical functions that will be demonstrated provides the ability to define multiple sets of 

criteria for selecting cells from a targeted range. These multiple sets of criteria act like an 

AND function. All the criteria have to be TRUE to be included in the function results. We 

will begin with the COUNTIFS function.  

It is easy to distinguish the difference between a statistical IF function that allows one 

criteria argument to be defined and one that allows multiple criteria arguments. If the IF at 

the end of the function name is plural, you can define multiple sets of criteria arguments. 

Therefore, the COUNTIFS function provides the option of defining multiple sets of criteria 

for selecting cells from a targeted range that will be used in the function output.  

The arguments for the COUNTIFS function are established in pairs. For example, the first 

arguments for the function are Criteria_range1 and Criteria1. The function will use the 

Criteria1 argument to select cells in the Criteria_range1 argument. A second pair of 

arguments, Criteria_range2 and Criteria2, can be defined to select a subset of cell locations 

that were selected in the Criteria_range1 and Criteria1 arguments. This process can be 

repeated for several pairs of criteria arguments.  
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We will continue to work on the Portfolio Summary worksheet by adding the COUNTIFS 

function to count the number of poor performing investments by investment type. The 

criteria for determining if an investment is poor performing is if the Targeted vs. Actual 

Growth rate is less than -1%. The following steps explain how to add this function to the 

worksheet:  

1. First, we will establish our assumption table. In cell A17 type Poor Performing 

Investment Criteria  

2. In cell A18 type “Target vs Actual Growth <”. 

3. In cell B18 type -1% (Note: This is for informational purposes only). 

4. Click cell B11 on the Portfolio Summary worksheet. 

5. Click the Formulas tab of the Ribbon. 

6. Click the More Functions button in the Function Library group of commands. 

7. Place the mouse pointer over the Statistical option from the drop-down list. 

8. Click the scroll down arrow on the second drop-down list to find the COUNTIFS function. 

9. Click the COUNTIFS function. This will open the Function Arguments dialog box. 

10. Click in the Criteria_range1 argument on theFunction Arguments dialog box and   then 

from the Use in Formulas option on the Formulas ribbon select the named range 

Investment_Type. 

11. Press the TAB key on your keyboard to advance to the Criteria1argument and click on 

cell A11 (Bond Fund). The criteria for the function will be the investment type that is 

entered into cell A11 on the Portfolio Summary worksheet. Notice that when you 

define this argument, theCriteria_range2 argument will appear on the Function 

Arguments dialog box. 

12. Click in the Criteria_range2 argument onthe Function Arguments dialog box. 

13. From the Use in Formula drop down select the named range  

Target_vs_Actual_Growth_Rate. You should see a string of numbers to the right of the 

range box. 

14. Press the TAB key on your keyboard to advance to the Criteria2 argument. 
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15. Type an open quotation mark followed by the logical test. 

 

16. Click the OK button at the bottom of the Function Arguments dialog box.  

17. Copy the function in cell B11 into the range B12:B14.  

18. Enter a SUM function in cell B15 on the Portfolio Summary worksheet that sums the 

values in the range B11:B14. 
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The AVERAGEIFS Function  

Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.12 if starting here.)  

The AVERAGEIFS function is like the COUNTIFS function in that multiple sets of criteria can 

be defined instead of one. However, the arguments for the AVERAGEIFS function are 

slightly different from those for the COUNTIFS function. Table 3.9 "Arguments for the 

AVERAGEIFS and SUMIFS Functions" provides definitions for the arguments of the 

AVERAGEIFS and the SUMIFS functions. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The AVERAGEIFS function will be used to calculate the average months of ownership for 

poor performing investments in the portfolio. The following steps explain how to add this 

function to the Portfolio Summary worksheet:  
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1. Click cell C11 on the Portfolio Summary worksheet.  

2. Click the Formulas tab on the Ribbon.  

3. Click the More Functions button in the Function Library group of commands.  

4. Place the mouse pointer over the Statistical option from the drop-down list.   

5. Click the AVERAGEIFS function near the top of the list of functions. This will open the 

Function Arguments dialog box.  

6. Click in the Average_range argument on the Function Arguments dialog box. 

7. From the Use in Function on the Functions Ribbon select the named range 

Months_Owned. Selected cells from this range will be averaged by the function based on 

the defined criteria in ensuing arguments.  

8. Click in the Criteria_range1 argument on the Function Arguments dialog.  

9. From the Use in Function on the Functions Ribbon select the named range 

Investment_Type.  

10. Press the TAB key on your keyboard to advance to the Criteria1 argument and click on 

cell A11. The criteria for the function will be the investment type entered into cell A11 on 

the Portfolio Summary worksheet. You will notice that as you define this argument, the 

Criteria_range2 argument will appear on the Function Arguments dialog box.  

11. Click in the Criteria_range2 argument on the Function Arguments dialog box.  

12. From the Use in Function on the Functions Ribbon select the named range 

Target_vs_Actual_Growth_Rate.  

13. Press the TAB key on your keyboard to advance to theCriteria2argument.  

14. Type an open quotation mark followed by the logical test <−1% and then type a closing 

quotation mark (“<−1%”). The second criterion for this function is a logical test that 

will identify cell locations where the value is less than −1%. For the purposes of this 

exercise, a poor performing investment is one that is below the target growth rate by 

more than1%. 

15. Click the OK button at the bottom of the Function Arguments dialog box. 

16. Copy the function in cell C11 and paste it into the range C12:C14 using the Paste 

Formulas command. 
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Figure 3.35 "Completed Arguments for the AVERAGEIFS Function" shows the defined 

arguments for the AVERAGEIFS function. Notice that two sets of criteria arguments are 

defined. Values that meet all criteria defined in the function will be selected from the 

named range Months_Owned. 

 

 
17. Enter an AVERAGEIF function in cell C15 by typing an equal sign (=) followed by the 

function name AVERAGEIF followed by an open parenthesis (().  

18. Use the named range Target_vs_Actual_Growth_Rate to define the Range argument. 

Type a comma.  

19. Type the following to define the criteria argument: “<–1%”. Type a comma. 

20. Use the named range Months_Owned to define the [Average_range] argument. Then 

type a closing parenthesis ()) and press the ENTER key on your keyboard. 

Figure 3.36 "Results of the AVERAGEIFS Function" shows the results of the AVERAGEIFS 

function in the Portfolio Summary worksheet. The function shows the average months of 

ownership for the poor performing investments by investment type. 
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The SUMIFS Function  
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.13 if starting here.)  

The SUMIFS function is like the AVERAGEIFS function in that multiple criteria arguments 

can be defined to select cells from a targeted range. The function will use the selected cells 

from this targeted range to calculate a total or sum.  

The SUMIFS function will be used to complete the Total Purchase Cost and Current Value 

columns in the Poor Performing Investments section of the Portfolio Summary worksheet. 

The following steps explain how to construct this function for the Total Purchase Cost 

column:  

1. Click cell D11 on the Portfolio Summary worksheet.  

2. Click the Formulas tab on the Ribbon.  

3. From the Insert Function select SUMIFS. This will open the Function Arguments dialog 

box.  

4. In the Sum_range argument on the Function Arguments dialog box use the Use in 

Formulas to select the named range Cost_of_Purchase. Selected cells from this range will be 

summed based on the defined criteria in ensuing arguments.  

5. Click in the Criteria_range1 argument on the Function Arguments dialog and use the 

named range Investment_Type from the Use in Formulas on the Formulas ribbon. Once the 

Criteria_range1argument is defined, the Criteria1 argument will appear in the Function 

Arguments dialogbox.  

6. Press the TAB key on your keyboard to advance to the Criteria1argument and type the 

cell location A11. The criteria for the function will be the investment type that is entered 

into cell A11 on the Portfolio Summary worksheet. You will notice that as soon as you 
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define this argument, theCriteria_range2 argument will appear on the Function Arguments 

dialog box.  

7. In the Criteria_range2 argument onthe Function Arguments dialog box use the named 

range Target_vs_Actual_Growth_Rate  

8. Press the TAB key on your keyboard to advance to theCriteria2argument.  

9. Type an open quotation mark followed by the logical test <−1% and then type a closing 

quotation mark (“<−1%”). The second criterion for this function is a logical test that 

will identify cell locations where the value is less than −1%. For the purposes of this 

exercise, a poor performing investment is one that is below the target growth rate by more 

than-1%.  

10. Click the OK button at the bottom of the Function Arguments dialog box.  

11. Copy the function in cell D11 into the range D12:D14. Format the cells D12LD14 with a 

comma style and no decimal places.  

12. Enter a regular SUM function in cell D15 on the Portfolio Summary worksheet that 

sums the values in the range D11:D14.  

13. Figure 3.37 "Completed Arguments for the SUMIFS Function" shows the defined 

arguments for the SUMIFS function. Values that meet all criteria defined in the function will 

be selected from the named range Cost_of_Purchase which is the range G4:G18. From the 

Investment Detail worksheet. Notice that the results for each argument of the function are 

shown along the right side of the Collapse Dialog buttons. 
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Figure 3.38 "SUMIFS Function Output for the Total Purchase Cost Column" shows the 

results of the SUMIFS function used to complete the Total Purchase Cost column. In total, 

over $45,000 was invested in funds and stocks that are not meeting the performance goals 

of the portfolio. 

 
In addition to the Total Purchase Cost column, the SUMIFS function will also be used to 

complete the Current Value column for the Poor Performing Investments section on the 

Portfolio Summary worksheet. Notice that the Sum ranges change, but the criteria ranges 

and the criteria remain the same as the other functions looking at the poor performance 

based on the criteria outlined in cell A18.  

The following steps explain how to add the function to the worksheet to complete this 

column:  

1. Click cell D11 on the Portfolio Summary worksheet.  

2. Click the Formulas tab on the Ribbon.  

3. From the Insert Function select SUMIFS. This will open the Function Arguments dialog 

box.  

4. In the Sum_range argument on the Function Arguments dialog box use the Use in 

Formulas to select the named range Current_Investment_Value. Selected cells from this 

range will be summed based on the defined criteria in ensuing arguments.  
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5. Click in the Criteria_range1 argument on the Function Arguments dialog and use the 

named range Investment_Type from the Use in Formulas on the Formulas ribbon. Once the 

Criteria_range1argument is defined, the Criteria1 argument will appear in the Function 

Arguments dialog box.  

6. Press the TAB key on your keyboard to advance to the Criteria1argument and type the 

cell location A11. The criteria for the function will be the investment type that is entered 

into cell A11 on the Portfolio Summary worksheet. You will notice that as soon as you 

define this argument, the Criteria_range2 argument will appear on the Function Arguments 

dialog box.  

7. In the Criteria_range2 argument onthe Function Arguments dialog box use the named 

range Target_vs_Actual_Growth_Rate.  

8. Press the TAB key on your keyboard to advance to theCriteria2 argument.  

9. Type an open quotation mark followed by the logical test <−1% and then type a closing 

quotation mark (“<−1%”). The second criterion for this function is a logical test that 

will identify cell locations where the value is less than −1%. For the purposes of this 

exercise, a poor performing investment is one that is below the target growth rate by 

more than1%. 

10. Click the OK button at the bottom of the Function Arguments dialog box. 

11. Copy the function in cell D11 into the range D12:D14. Format the cells D12LD14 with a 

comma style and no decimal places. 

12. Enter a regular SUM function in cell D15 on the Portfolio Summary worksheet that 

sums the values in the range D11:D14. 
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Now that the Total Purchase Cost and Current Value columns are completed for the Poor 

Performing Investments section on the Portfolio Summary worksheet, we can add a 

formula to show the annual growth rate by investment type. Since this is the same formula 

that was used in the Total Summary section of the Portfolio Summary worksheet, we can 

just copy and paste it. The following steps explain how to do this:  

 

1. Copy the formula in cell F4 on the Portfolio Summary worksheet.  

2. Highlight the range F11:F15 on the Portfolio Summary worksheet.  

3. Paste the formula using the Paste Formulas command. 

 

 
Figure 3.41 "Completed Poor Performing Investments Section of the Portfolio Summary 

Worksheet" shows the completed Poor Performing Investments section on the Portfolio 

Summary worksheet. Notice that even though an investment is considered “poor 

performing” it does not mean that money is lost on the investment. As shown in the figure, 

only one investment in the International Stock Fund category is losing money, with an 
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annual growth rate of −5.4%. However, the total annual growth rate for all investments in 

the Poor Performing section is 2.2% (see cell F15). This is less than half the growth rate for 

the overall portfolio, which is 6.2% (see cell F8). A final observation is that all the 

investments in the Domestic Stock Fund category are “poor performing.” The same number 

of investments in the Total Summary section appears in the Poor Performing Investments 

section. This completes the Portfolio Summary worksheet except for one column. We will 

complete this column in the next section with a lookup function. 
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3.3. Data Validation 

 
Some of the documents you will prepare for your business will be what are called 

templates. A template is simply a pre-made form that others can use to complete the work 

for a company. A common template would be a sales invoice form. On the invoice, you 

would want your salespeople to be able to select from a drop down of products and have 

the resulting selection fill in the price per unit and the product description. The salespeople 

could enter the number of units, but could not change the description fields or the price 

fields. We will look at the use of data validation to help limit what can be entered into fields. 

For this conversation, we will describe a cell as a field.  

When a data validation rule is created, you can specify what kind of data is allowed. You 

can also prohibit the entry of anything other than the allowed data, you can warn that the 

data is not what is expected, or you can just let the data be entered with an explanation of 

what is expected to be in the field. 

 
 

Data Validation List – Created Source  
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.14 if starting here.)  
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We will use data validation to create a buy/sell form for the various investments. The steps 

we will use to do this are:  

1. Activate the Buy/Sell worksheet. We use a different data validation rule in each of the 

cells in the range B3:B7.  

2. In cell B3, we will create text data validation rule that describes the type of transaction 

this will be. Click in cell B3. From the Data Tools section of the Data ribbon, use the drop-

down button to select Data Validation. 

 
3. In the Data Validation dialog box, use the drop-down button next to the Allow: box and 

choose List.  

4. In the Source field, type Buy, Sell. Make sure the two words are separated by a comma. 

5. Click on the Input Message tab. In the tile 

type Buy/Sell.  

6. In the Input message field type: Select 

the type of transaction you are ordering.  

7. Click the Ok button.  

8. Note that cell B3 now has a drop-down 

arrow next to the cell. When the cell is 

active, the input message you just entered 

will show below the cell. When clicked, the 

drop down will show the choices available 

for what can go in the cell. 
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Data Validation List Named Range  
Data validation can also be used to create a list using a range of cells. If you are going to use 

a range of cells there are two rules you must follow:  

• The range of cells must be on the same worksheet as the data validation cell, OR  

• Use a named range of cells from a different worksheet. The named range must be 

one column or one row of data only.  

The steps we will follow to create a drop-down list for the investment symbols are:  

1. Select Sell from the drop-down list.  

2. Cell B4 will contain the stock symbol for the investment to be traded. We will use a 

named range to create the data validation list for this cell. Go to the Investment List 

worksheet. Highlight the range B3:B22 From the Defined Names section of the Formula 

Ribbon, select Define Name.  

3. In the Define Name section, type in Trade_Symbol. (Don’t forget to use the underscore 

between the words Trade and Symbol. Defined names cannot contain spaces.)  

4. Go back to the BuySell Order worksheet and make cell B4 active.  

5. From the Data ribbon click the data validation drop-down list and select List in the Allow 

box. 

6. Click in the Source box. From the Defined Names section of the Formula ribbon, select 

Use in Formula. Scroll down the list of names until you see Trade_Symbol. Click on 

Trade_Symbol. (Excel will insert an = sign before the named range.) 

7. Click on the Input Message and type: Select the investment symbol from the list. 

8. Click on the Error Alert. 

 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                227 

  

 
9. There are three options for the error alert dialog box. Stop: the data that is being input 

must match the data allowed. Alert: the data does not match, and the user must choose to 

proceed or not, and Information: the user will be alerted that the data does not match, but 

no choice will be given before the data can be entered. 
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10. Because this is a buy/sell situation, we may be buying an investment that is not already 

in the portfolio. We will select a Warning message that will alert the user that the symbol is 

not in the list of currently owned investments.  

11. On the Error message box type: That investment symbol is not in the list of owned 

investments.  

12. Click OK. 

 
13. Try typing a symbol into B4 that is not in the list. You will get an error message, but you 

will also get the choice to proceed or not. Choose to not proceed. Delete the characters you 

entered from B4 and select VFICX from the drop-down list.  

14. Select cells A3:C3. Right click and Insert. Shift cells down, and then click OK. 

Data Validation – Date  
Next, we will validate the transaction date to ensure the date of the order will be today or 

later. The steps we will use are:  

1. Insert a row at A3 by highlighting A3: C3. Then use the Ctrl and + keys to insert cells. 

Select Shift Cells Down.  

2. In Cell A3 type: Today’s Date:  

3. In cell B3 type the formula =TODAY() Note: this will insert a dynamic formula that will 

change each time the workbook is opened to reflect the current date.  

4. Activate cell B6. Open the data validation dialog box and select Date from the list of 

options.  
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5. New Data choices will be given: 

 
6. Select greater than or equal to. We can’t tell the broker to sell something yesterday-only 

today or later. 

7. Tab to the Start date box. Click on cell B3 as the start date. This will dynamically link your 

valid date the TODAY() function. 

 
8. Click on the input message tab and in the Input message box type: Trade date must be 

today or after today’s date.  

9. Click the Error Alert tab, select Stop as the alert. In the Error message type: Date entered 

is before today’s date. Note: your error message should always inform the user why the 

error has occurred.  

10. Put yesterday’s date into the cell. Excel will stop you and tell you why the entry is 

invalid.  

11. Enter tomorrow’s date into B6.  
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Data Validation - Number  
1. Click on cell B7. In this cell, the price will be entered. We will control the entry to be a 

number with 0 decimal places.  

2. From the data validation settings dialog box, select Whole Number.  

3. In the Data box select greater than  

4. In the Minimum box type in 0.  

5. In the Input Message tab type: Enter the buy/sell price in whole numbers. We won’t have 

an error message for this cell.  

6. On the Home ribbon format cell B7 for $ with 0 decimal places. 

 

Data Validation – Text  
The last validation we will add to our worksheet it a text validation to limit the number of 

characters the user can add when explaining why the investment is being bought or sold. 

The steps we will use to do that are:  

1. Make cell B8 active. Because we are looking for a buy/sell reason, we will make cell B8 

accept text input only.  

2. From the data validation Settings Allow drop-down, select Text length.  

3. In the Data box select: less than.  

4. In the Maximum box type: 100. Note: this will limit the number of characters to less than 

100. 

 

5. For the input message type: Enter 

reason for buying/selling.  

6. Do not put in an error alert.  

7. In cell B8 type: Not hitting target 
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Data Validation – Calculated Field  
While not using a specific example in this 

worksheet, we can create a data validation 

based on a calculation. For example: We can 

have the data validation test to see if the value 

entered is at least 5% of a value in another cell. 

The calculation must begin with an =. 
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3.4. Lookup Functions 

 

The final section of this chapter addresses lookup functions. Lookup functions are typically 

used to search for and display data located in other worksheets or workbooks. The two 

lookup functions we will use in our example of the personal investment portfolio are the 

VLOOKUP and HLOOKUP functions. In addition to demonstrating these functions, we will 

also show how we can enhance the personal investment portfolio workbook with a web 

query. Web queries are used to bring live or current data into a worksheet from a website. 
 

The VLOOKUP Function  
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.15 if starting here.)  

The VLOOKUP function is typically used to access and display data located in another 

worksheet or workbook. The function can also be used to access and display data located in 

the same worksheet. This is a very powerful and versatile function because it eliminates 

the need to copy or recreate data that exists in other worksheets or workbooks. 

It is called a VLOOKUP function because the function will search vertically down the first 

column of a range of cells to find what is called a lookup value. This process is very similar 

to the statistical IF functions in Section 3.2 "Statistical IF Functions". You will recall that 

these functions used criteria to select cells from a range that was used in the mathematical 

output. The VLOOKUP function is essentially performing the same process; however, 

instead of selecting multiple cells from a range, the function is only looking for one specific 

cell location. Once the function finds the specific cell location, it will display the contents of 

that cell location or another cell location in the range. Before using the VLOOKUP function 

in the personal investment portfolio workbook, it is strongly recommended that you 

carefully read the definitions for the function arguments listed in Table 3.10 "Arguments 

for the VLOOKUP Function". 

=VLOOKUP(lookup_value,table_array,row_index_num,[range_lookup]) 
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You may have noticed that on the Investment Detail worksheet, the Description column is 

blank. Descriptions for several investments are included in the workbook in the Investment 

List worksheet as shown in Figure 3.42 "Investment List Worksheet". The VLOOKUP 

function will be used to search for a specific symbol in Column A of the Investment List 

worksheet and display the description for that symbol located in Column B. It is important 

to note that once the Table_array has been defined, the VLOOKUP can return any column 

number within that array. For example, to return the investment type you would select 

column 3. For 5-year growth, you would select column 6. 

 

 
 

Naming a Table_array:  
To name a Table_array select all the columns and rows in the array EXCEPT the column 

headers. If you include the column headers Excel will treat them as values in your array 

and may return erroneous results.  

The following steps explain how to accomplish this:  

1. First, we will name our table_array. It is much easier to name the array and use the 

named range than to constantly have to re-select the data for a different VLOOKUP 

function.  

2. Click on the Investment List worksheet.  

3. Select the range A3:F23 (this range excludes the column headers.)  
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4. On the Formulas ribbon in the Defined Names section click on Define Name. 

 
5. In the Name box type in Investment_List. Notice that the Refers to: box at the bottom 

shows the worksheet name and range of cells this name will apply to. Make sure it shows 

the correct range. The $ indicate that naming this range will create an absolute reference to 

these cells in your workbook.  

6. In the Investment Detail worksheet, click on cell C4. 

7. Click the Formulas tab on the Ribbon.  

8. Click the Lookup & Reference button in the Function Library group of commands.  

9. Select the VLOOKUP function from the list of functions. Use the scroll bar to scroll down 

to the bottom of the list. This will open the Function Arguments dialog box for the 

VLOOKUP function.  

10. Click in the Lookup_value argument on the Function Arguments dialog box.  

11. Click cell B4. The symbol in cell B4 is the lookup value that will be searched in the first 

column of the range defined for the Table_array argument.  

12. Click in the Table_array argument on the Function Arguments dialog box.  

13. From the Formulas ribbon click on Use in Formula and select Investment_List.  
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14. Press the TAB key on your keyboard to advance to the Col_index_num argument and 

type the number 2. Once the function finds the lookup value in the first column of the range 

Investment_List, it will display the description that is in the second column of the same 

row.  

15. Press the TAB key on your keyboard to advance to the Range_lookup argument and 

type the word FALSE. This will direct the function to search for only exact matches to 

lookup value.  

16. Click the OK button at the bottom of the Function Arguments dialog box.  

17. Copy the VLOOKUP function in cell C4 and paste it into the range C5:C18  

 

Figure 3.43 "Completed Function Arguments Dialog Box for the VLOOKUP Function" shows 

the completed Function Arguments dialog box for the VLOOKUP function. Notice that the 

Range_lookup argument is defined with the word FALSE. This will direct the function to 

search for an exact match to the lookup value and will also direct the function to search the 

entire first column of the table array range.  

Finally, it is important to note the absolute reference on the table array range. This will 

prevent the table array range from changing when the function is pasted into other cell 

locations. 

 
Figure 3.44 "Results of the VLOOKUP Function in the Investment Detail Worksheet" shows 

the results of the VLOOKUP function in the Investment Detail worksheet. The function is 
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searching for each symbol in Column B of the Investment Detail worksheet in Column A of 

the Investment List worksheet.  

 

When the function finds a match, it will display whatever is in the cell location two columns 

to the right, or Column B, in the Investment List worksheet. For example, the symbol 

VDMIX, which is in cell B8 on the Investment Detail worksheet (see Figure 3.44 "Results of 

the VLOOKUP Function in the Investment Detail Worksheet"), is also in cell A15 on the 

Investment List worksheet. As a result, the function is displaying whatever is in cell B15 on 

the Investment List worksheet, which is the description “Developed Markets.” 
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The HLOOKUP Function  
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.15 if starting here.)  

The HLOOKUP function serves the same purpose as the VLOOKUP function. The HLOOKUP 

function can be used to display data from another worksheet or workbook. However, 

instead of searching for the lookup value vertically down the first column of the table array 

range, the HLOOKUP function searches horizontally across the first row of the table array 

range. When the function finds a match for the lookup value, it will display the contents in a 

cell location based on a row index number. This number designates which row in the table 

array range the function should display. 

=HLOOKUP(lookup_value,table_array,row_index_num,[range_lookup]) 

Table 3.11 "Arguments for the HLOOKUP Function" provides a definition for each argument 

of the HLOOKUP function. It is best to review the definitions of these arguments carefully 

before using the function. 
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The HLOOKUP function will be used on the Portfolio Summary worksheet to display the 

benchmark growth rates in the range G4:G7. A benchmark is a value that can be used as a 

standard point of comparison. The Benchmarks worksheet contains growth rates at 

different year intervals for the benchmarks that will be used to compare the performance 

for each investment type (see Figure 3.45 "Benchmarks Worksheet"). For the purposes of 

this workbook, we will be comparing the growth rates for each investment type to the 5- 

year average growth rate for the benchmarks categories listed in the range H4:H7. The 

following steps explain how to construct the HLOOKUP function to display the 5-year 

benchmark values in the Portfolio Summary worksheet: 
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1. Go to the Benchmarks worksheet by clicking on the Benchmarks tab.  

2. We will name the Benchmarks range for use in the HLOOKUP function. The range we will 

name is B2:E6. The top row contains the look up values the function will use to find a 

match. The remaining rows will be the results returned once a match is found.  

3. Highlight B3:B6 and name the range Benchmarks by typing the name in the Cell address 

block on the left side of the formula bar.  

4. Click cell G4 in the Portfolio Summary worksheet.  

5. Click the Formulas tab on the Ribbon.  

6. Click the Lookup & Reference button in the Function Library group of commands.  

7. Select the HLOOKUP function from the list of functions. This will open the Function 

Arguments dialog box for the HLOOKUP function.  

8. Click in the Lookup_value argument on the Function Arguments dialog box.  

9. Click cell H4. The description in cell H4 will be the lookup value that will be searched in 

the first row of the range defined for the Table_array argument.  

10. Click in the Table_array argument on the Function Arguments dialog box. 

11. From the Formulas ribbon, Use in Formula, select the named range Benchmarks.  
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12. Press the TAB key on your keyboard to advance to the Row_index_num argument and 

type the number 4. 

 
Remember that the Excel row number from the left side of the worksheet window is 

irrelevant in table arrays. It is the number of rows in the array itself that are counted.  

13. Press the TAB key on your keyboard to advance to the Range_lookup argument on the 

Function Arguments dialog box and type the word FALSE. This will direct the function to 

search for only exact matches of the lookup value. Without an exact match, the results may 

be erroneous because Excel will stop looking when it finds an approximate match, or one 

higher in value.  

14. Click the OK button at the bottom of the Function Arguments dialog box.  

15. Copy the HLOOKUP function in cell G4 and paste it into the range G5:G7 using the Paste 

Formulas command.  
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Figure 3.46 "Completed Function Arguments Dialog Box for the HLOOKUP Function" shows 

the completed Function Arguments dialog box for the HLOOKUP function. The row index 

number 4 indicates that the function will display the contents of the cell location in the 

fourth row of the table array range. 

 

 
 

  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                245 

  

Figure 3.47 "Completed Portfolio Summary Worksheet" shows the output of the HLOOKUP 

function. Notice that the output of the function in cell G4 is 6.0%. This is because the lookup 

value was defined with the entry in cell H4, which is the Barclays index. Looking at Figure 

3.45 "Benchmarks Worksheet", if you count the first row of the table array range as Row 1, 

the value 6.03% is the fourth row in the Barclays column. Since the values in Column G on 

the Portfolio Summary worksheet are set to 1 decimal place, the value is displayed as 6.0%. 
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IFERROR  
Follow-along file: Continue with Excel Objective 3.00. (Use file Excel Objective 3.16 if starting here.)  

Suppose your spreadsheet formulas have errors that you anticipate and don't need to 

correct, but you want to improve the display of your results. For example, when creating an 

invoice template you will want the invoice to look blank, but have the functions set up, so 

that when data is entered into the invoice, the invoice will correctly calculate the amount 

due. You will want the errors in the functions to not show as errors and not keep Excel 

from being able to perform the mathematical operations necessary in the invoice.  

 

There are many reasons why formulas can return errors. For example, division by 0 is not 

allowed, and if you enter the formula =1/0, Excel returns #DIV/0. Error values include 

#DIV/0!, #N/A, #NAME?, #NULL!, #NUM!, #REF!, and #VALUE!. 
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There are several ways you can hide error messages you are expecting in a worksheet. You 

can hide error values by converting them to a number such as 0, and then applying a 

conditional format that hides the value, or by having what looks like a blank cell returned 

when an error is encountered. 

 

Create an example error  

1. Open a blank workbook, or create a new worksheet.  

2. Enter 3 in cell B1, enter 0 in cell C1, and in cell A1, enter the formula =B1/C1. The 

#DIV/0! error appears in cell A1.  

3. Select A1, and press F2 to edit the formula.  

4. After the equal sign (=), type IFERROR followed by an opening parenthesis. IFERROR(  

5. Move the cursor to the end of the formula.  

6. Type ,0) – that is, a comma followed by a zero and a closing parenthesis. The formula 

=B1/C1 becomes =IFERROR(B1/C1,0).  

7. Press Enter to complete the formula. The contents of the cell should now display 0 

instead of the #DIV! error.  

 

Apply the conditional format  

1. Select the cell that contains the error, and on the Home tab, click Conditional Formatting.  

2. Click New Rule.  

3. In the New Formatting Rule dialog box, click Format only cells that contain.  

4. Under Format only cells with, make sure Cell Value appears in the first list box, equal to 

appears in the second list box, and then type 0 in the text box to the right.  

5. Click the Format button.  

6. Click the Number tab and then, under Category, click Custom.  

7. In the Type box, enter ;;; (three semicolons), and then click OK. Click OK again. The 0 in 

the cell disappears. This happens because the ;;; custom format causes any numbers in a 

cell to not be displayed. However, the actual value (0) remains in the cell. 
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Hide error values by turning the text white  

Use the following procedure to format cells that contain errors so that the text in those cells 

is displayed in a white font. This makes the error text in these cells virtually invisible.  

1. Select the range of cells that contain the error value.  

2. On the Home tab, in the Styles group, click the arrow next to Conditional Formatting and 

then click Manage Rules. The Conditional Formatting Rules Manager dialog box appears.  

3. Click New Rule. The New Formatting Rule dialog box appears.  

4. Under Select a Rule Type, click Format only cells that contain.  

5. Under Edit the Rule Description, in the Format only cells with list, select Errors.  

6. Click Format, and then click the Font tab.  

7. Click the arrow to open the Color list, and under Theme Colors, select the white color.  

 

Hide error values by making the cell look empty  

In the error example given above the formula =B1/C1, where the #DIV/0! error appeared 

in cell A1 we can use quoted in the IFERROR to show a blank cell. The function would then 

look like =IFERROR(B1/C1,””). The two quotes at the end of the IFERROR will make the cell 

look blank. 
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Sample VLOOKUP Exercise from Microsoft Copilot: 

 

Scenario: 

You are given a list of employees with their departments and salaries. You need to find the 

salary of an employee based on their name and department using the VLOOKUP function 

combined with the CONCATENATE function.  

 

The CONCATENATE function in Excel is used to join two or more text strings into one 

string. This function is particularly useful when you need to combine data from different 

cells into a single cell. 

Syntax: 

CONCATENATE(text1, [text2], ...) 

• text1 is the first text string to be joined. 

• [text2], ... are additional text strings to be joined. You can include up to 255 text 

arguments. 

 

Step-by-Step Instructions: 

1. Create the Employee List Table: 

• In cells A1 to C6, enter the following data: 

 A B C 
1 Employee     Department   Salary   
2 John Doe     HR $50,000 
3 Jane Smith IT           $60,000 
4 Emily Davis Finance      $55,000 
5 Michael Brown IT $65,000 
6 Sarah Wilson HR $52,000 

 

2. Create the Lookup Tables: 

• In cells F1 to H3, enter the following data: 

 F G H 
1 Employee     Department   Salary   
2 John Doe     HR  
3 Michael Brown IT  

 

• In cells F6 to H8, enter the following data: 

 F G H 
6 Employee     Department   Salary   
7 John Doe     HR  
8 Sarah Wilson HR  
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3. Combine Employee and Department Columns: 

• In cell D2, enter the following formula and drag it down to D6: 

• =A2 & " - " & B2 

• This will create a combined column with the format "Employee - 

Department". 

• Autofit the column widths as appropriate. 

 

4. Sort the table in ascending order by Employee. Your data in A1:D6 should now 

appear as: 

 

 
 

5. Add Salary data to column E.  

• Since the lookup value must be in the leftmost column of a table, and column 

D will be our lookup values, we must copy & paste the Salary data to cells 
E2:E6. 

6. Use the VLOOKUP Function without CONCATENATE: 

• In cell H2, enter the following formula: 

• =VLOOKUP(F2, $A$1:$C$6, 2, FALSE) 

• Drag the formula down from H2 to H3 to fill in the salaries for the employees. 

 

7. Use the VLOOKUP Function with CONCATENATE: 

• In cell H7, enter the following formula: 

• =VLOOKUP(F7 & " - " & G7, $D$1:$E$6, 2, FALSE) 

• Drag the formula down from H7 to H8 to fill in the salaries for the employees. 

 

Explanation: 

• F7 & " - " & G7 combines the employee name and department to match the format in 

the combined column. 

• $D$1:$E$6 is the table array (the range of cells that contains the combined data and 

the salaries). 

Employee    Department  Salary  

Emily Davis Finance     $55,000 Emily Davis - Finance     

Jane Smith IT          $60,000 Jane Smith - IT          

John Doe    HR $50,000 John Doe     - HR

Michael Brown IT $65,000 Michael Brown - IT

Sarah Wilson HR $52,000 Sarah Wilson - HR
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• 2 is the column index number (the column number in the table array from which to 

retrieve the value). 

• FALSE specifies that you want an exact match. 

 

Expected Result: 

After completing the exercise, the salaries for the employees in the lookup table should be 

filled in as follows: 

 

 
 

This exercise demonstrated how to use VLOOKUP with multiple criteria by combining 

columns. 
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Chapter 4 
 

Presenting Data with Charts 
 

Chapter 1 "Fundamental Skills" provided a brief introduction to creating charts in Excel. 

This chapter provides more details for enhancing the appearance of your charts and 

addresses how to choose the best chart type for your data.  

One of the most important things to consider when using charts in Excel is that they are 

intended to be used for communicating an idea to an audience. Your audience can be 

reading your charts in a written document or listening to you in a live presentation. In fact, 

Excel charts are often imported or pasted into Word documents or PowerPoint slides. This 

serves the purpose of communicating ideas to an audience. Although there are no rules set 

in stone for using specific charts for certain data types, some chart types are designed to 

communicate certain messages better than others. This chapter explores numerous charts 

that can be used for a variety of purposes. In addition, we will examine formatting charts 

and using those charts in Word and PowerPoint documents.  

4.1 Choosing a Chart Type 

 

This section reviews the most commonly used Excel chart types. To demonstrate the 

variety of chart types available in Excel, it is necessary to use a variety of data sets. 

Therefore, instead of addressing a specific theme, we will use a variety of themes. This is 

necessary not only to demonstrate the construction of charts but also to explain how to 

choose the right type of chart given your data and the idea you intend to communicate. 
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Before we begin, let’s review a few key points you need to consider before creating any 

chart in Excel. 

•  The first is identifying your idea or message. It is important to keep in mind that the 

primary purpose of a chart is to present quantitative information to an audience. 

Therefore, you must first decide what message or idea you wish to present. This is 

critical in helping you select specific data from a worksheet that will be used in a chart. 

Throughout this chapter, we will reinforce the intended message first before creating 

each chart.  

•  The second key point is selecting the right chart type. The chart type you select will 

depend on the data you have and the message you intend to communicate. The table 

below describes how each chart type is used. 
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•  The third key point is identifying the values that should appear on the X and Y axes. One 

of the ways to identify which values belong on the X and Y axes is to sketch the chart on 

paper first. If you can visualize what your chart is supposed to look like, you will have 

an easier time using Excel to construct an effective chart that accurately communicates 

your message. Table 4.2 "Key Steps before Constructing an Excel Chart" provides a 

summary of these points.  

•  The fourth key point is determining how you can best label your chart to clearly explain 

to your audience the meaning of the message you are presenting. Your reader should be 

able to understand what the chart is presenting without having it explained to them. 
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Line Chart  
Follow-along file: Excel Objective 4.00  

The first chart we will demonstrate is a line chart. Figure 4.1 "52 Week Data for the S&P 

500 and Microsoft" shows part of the data that will be used to create two-line charts. The 

first line chart will show the trend of the S&P 500 stock index. This is an aggregate price 

index of five hundred of the largest publicly traded companies. This chart will be used to 

communicate a simple message: to show how the index has performed over a fifty-two- 

week period. We can use this chart in a presentation to show whether stock prices have 

been increasing, decreasing, or remaining constant over the designated period. 

 

Before we create the line chart, it is important to identify why it is an appropriate chart 

type given the message we wish to communicate and the data we have. When presenting 

the trend for any data over a designated time period, the most commonly used chart type is 

the line chart. A column chart could be used, but is typically used to show comparative data 

rather than data over time. Given the four steps outlined above, let’s determine how we will 

set up our line chart.  

• Define the message: Our line chart will show the closing price for the S&P 500 over a 52-

week period.  

• Define the data needed: The data needed is the week and the closing price of the S&P 

500. 
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• Select a chart type. Since we are looking at the changes in closing price over a designated 

time period we will use a line chart which most clearly conveys changes over time.  

• Identify the values on the X and Y axis. We will put the week number on the X axis 

because the audience is used to see a time-line progress horizontally and the closing price 

on the Y axis because it will show the price changes at each point in time.  

The following steps explain how to construct this line chart:  

1. Highlight the range A3:B55 on the Stock Trend worksheet. Note: Do not select more data 

than that needed to create a specific chart.  

2. Click the Insert tab of the Ribbon. Note: When constructing a chart, you want to have the 

data labels included. The data labels in A3:B3 will be displayed on the chart and will help 

identify the data being presented.  

3. Click the Line button in the Charts group of commands (see Figure 4.2 "Selecting the 

Basic Line Chart").  
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4. Click the first option from the list, which is a basic line chart. This adds, or embeds, the 

line chart to the worksheet, as shown in Figure 4.3 "Embedded Line Chart in the Stock 

Trend Worksheet". 

 
Figure 4.3 "Embedded Line Chart in the Stock Trend Worksheet" shows the embedded line 

chart in the Stock Trend worksheet. Notice that three additional tabs, or contextual tabs, 

are added to the Ribbon. We will demonstrate the commands in these tabs throughout this 

chapter. These tabs appear only when the chart is activated. 
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As shown in Figure 4.3 "Embedded Line Chart in the Stock Trend Worksheet", the 

embedded chart is not placed in an ideal location on the worksheet since it is covering 

several cell locations that contain data. The following steps demonstrate common 

adjustments that are made when working with embedded charts:  

1. Moving a chart: Click and drag the upper left corner of the chart to the center of cell H2.  

2. Resizing a chart: Place the mouse pointer over the left middle sizing handle, hold down 

the ALT key on your keyboard, and click and drag the chart so it “snaps” to the left side of 

Column H. Repeat step 2 to resize the chart so the top “snaps” to the top of Row 2, the 

bottom “snaps” to the bottom of Row 17, and the right side “snaps” to the right side of 

Column P. 

3. Adjusting the chart title: Click the chart title once. In the formula bar type: 52 Week 

Closing Price Trend for the S&P 500. Hold the Alt key down and press Enter. This will add a 

second row to your title. Type June 2017to May 2018. Click Enter.  

4. Removing the legend: (If the chart you just inserted does not contain a legend, skip this 

step.) Because the chart contains only one data series (the Closing Price) we will remove 

the legend because it is unnecessary. Click the legend once and press the DELETE key on 

your keyboard. This removes the legend from the chart. Once you remove the legend, the 

plot area automatically expands.  

 

Figure 4.4 "Line Chart Moved and Resized" shows the line chart after it is moved and 

resized. You can also see that the title of the chart has been edited to read 52 Week Trend 

for the S&P 500. Also notice that the sizing handles do not appear around the perimeter of 

the chart. This is because the chart has been deactivated. To activate the chart, click 

anywhere inside the chart perimeter. 
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Adjusting the Y Axis Scale  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.01 if starting here.)  

After creating an Excel chart, you may find it necessary to adjust the scale of the Y axis. 

Excel automatically sets the maximum value for the Y axis based on the data used to create 

the chart. However, the minimum value is usually set to zero. Depending on the data you 

are using to create the chart, setting the minimum value to zero can substantially minimize 

the graphical presentation of a trend. For example, the trend shown in Figure 4.4 "Line 

Chart Moved and Resized" appears to be increasing slightly. However, the S&P 500 

increased by over 20% during this period, which is substantial. The presentation of this 

trend can be improved if the minimum value started at eight hundred. While it is certainly 

possible for the S&P 500 to fall below eight hundred, it is most likely remote. The following 

steps explain how to make this adjustment to the Y axis:  

1. Right click anywhere on the Y axis on the 52 Week Trend for the S&P 500 line chart 

(Stock Trend worksheet) and select Format Axis.  

2. The Format Axis dialog box will appear on the right of your worksheet. 

3. In the Axis Options Window, click in the Minimum box and change the minimum value to 

be displayed on the Y axis from 0 to 1000. This will eliminate white space on your chart 

that adds no visual value. Press the tab key to display the change in your chart.  

4. Because we are dealing in whole numbers we will adjust the values on the Y axis to 

display with no decimal places. Click on the Number label to expand the Number menu. 

Under Decimal places, change the value from 2 to 0.  
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Figure 4.6 "Adjusted Y Axis for the S&P 500 Chart" shows the change in the presentation of 

the trendline. Notice that with the Y axis starting at 1,000, the trend for the S&P 500 is 

more pronounced and reflects the substantial increase over the 52-week period. This 

adjustment makes it easier for the audience to see the magnitude of the trend. 
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Line Chart 2: Trend Comparisons Over Time 
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.02 if starting here.) 

We will now create a second line chart using the data in the Stock Trend worksheet. The 

purpose of this chart is to compare two trends: 

• the change in value for the S&P 500 and 

• the change in value of a single stock - Microsoft common stock. 

 

Chapter 3 "Logical and Lookup Functions" presented a personal investment portfolio 

where the investments were compared to a benchmark. The S&P 500 is a benchmark that 

is commonly used to judge the performance of individual stocks. The purpose and message 

of this chart is to show whether Microsoft is performing better or worse than the S&P 500 

index. This type of analysis can be used as a visual tool to determine whether a stock 

should be sold, purchased, or held. 

 

Before creating the chart to compare the S&P 500 and Microsoft, it is important to review 

the data in the range E4:F55 on the Stock Trend worksheet. For a simple line chart, we 

cannot use the price data for Microsoft and the S&P 500 because the values are not 

comparable. That is, the data for Microsoft is in a range of $22.00 to $28.00, but the data for 

the S&P 500 is in a range of $1,022 to $1,363. If we used these values to create a chart, we 

would not be able to see any substantial change in the trend for either the S&P 500 or 

Microsoft. Therefore, formulas were used to calculate the percent change in value for the 

S&P 500 and Microsoft for each week. For example, looking at cells E5 and F5 on the Stock 

Trend worksheet, you see that the S&P 500 increased 2.4% in week 2, whereas Microsoft 

increased 3.1%. The percent change calculations now provide an appropriate method of 

comparison. This is a very important step to consider when comparing trends. 
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The construction of this second line chart will be like the first line chart. The X axis will be 

the 52 weeks in the range A4:A55. However, the Y axis will be the percentages in the range 

E4:F55. This creates a problem because Columns B, C, and D will not be used in this chart. 

Therefore, we cannot simply highlight one contiguous range of cells to create the chart. In 

this chapter, we will demonstrate two options for charting data that is not in a contiguous 

range. The following steps demonstrate the first option: 

 

1. Highlight the range A3:A55 on the Stock Trend worksheet. 

2. Hold down the CTRL key on your keyboard and highlight the range E3:F55. 

3. Click the Insert tab of the Ribbon. 

4. Click the Line button in the Charts group of commands. 

5. Click the first option from the list, which is a basic line chart. 

 

Figure 4.7 "Trend Comparison Line Chart" shows the appearance of the line chart 

comparing the S&P 500 and Microsoft before it is moved and resized. 

 

 
6. Move the chart so the upper left corner is in the middle of cell H20.  

7. Resize the chart so the left side is locked to the left side of Column H, the right side is 

locked to the right side of Column P, the top is locked to the top of Row 20, and the bottom 

is locked to the bottom of Row 35.  
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8. Click the Design tab in the Chart Tools section of the Ribbon.  

9. Click the drop-down next to the Add Chart Element. Select Chart Title from the 

dropdown list. Chart. Because there is a lot of white space above the line chart we will 

select the Above Chart option from the drop-down list (see Figure 4.8 "Adding a Title to a 

Chart"). This adds a generic title above the plot area of the chart. 

10. While the title box is selected, click in the formula bar and type 52 Week Trend - S&P 

500 and Microsoft Comparison, alt Enter to add a new row to the chart title and then type 

June 2016 – June 2017. When you hit enter the new chart title will appear in the Chart Title 

box. 

 

11. To reposition the X axis labels so that the trend lines are not over lapping the axis and 

hiding the weeks, click anywhere on the weeks to activate the X axis. Right click and select 

Format Axis from the drop-down menu. Click on Labels, then Label Position. Choose Low to 

position the weeks below the lowest value in the chart.  

Figure 4.9 "Final Trend Comparison Line Chart" shows that Microsoft has not performed as 

well as the S&P 500 benchmark. From week 31 to week 52, Microsoft is showing a 

significant decline compared to the S&P 500, which continues to grow. What makes this 

chart effective is that an audience can quickly see how Microsoft compares with the S&P 

500 over the 52-week period.  
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Figure 4.9 Final Trend Comparison Line Chart 

 

Column Chart 1: Frequency Distribution  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.03 if starting here.)  

 

A professor at the school wants to chart the performance of his students in his class based 

on the grades earned during the class. He decides to use a column chart to show the results 

because column charts are typically used to compare several items, (in this case the grade 

distribution,) over a specific range of values, (the number of students in his class.). Column 

charts should be used when comparing a single category of data between individual 

subitems.  

 

In column charts, categories are typically organized along the horizontal axis and values 

along the vertical axis. For example, in Chapter 1 "Fundamental Skills" we showed a sales 

trend over a twelve-month period.  

 

Another common use for column charts is frequency distributions. A frequency distribution 

shows the number of occurrences by established categories. For example, a common 

frequency distribution used in most academic institutions is a grade distribution. A grade 

distribution shows the number of students that achieve each level of a typical grading scale 

(A, A−, B+, B, etc.). The Grade Distribution worksheet contains the final grades for the 

professor’s academic class. To show the grade frequency distribution, the numbers of 

students appear on the Y axis and the grade categories appear on the X axis. The following 

steps explain how to create this chart:  

 

1. Highlight the range A3:B8 on the Grade Distribution worksheet. Column B shows the 

number of students that achieved a grade within the grade category shown in Column A.  
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2. Click the Column button in the Charts group section on the Insert tab of the Ribbon. 

Select the first format from the drop-down list of options, which is the Clustered Column 

format.  

3. Click and drag the chart so the upper left corner is in the middle of cell H2.  

4. Resize the chart so the left side is locked to the left side of Column H, the right side is 

locked to the right side of Column P, the top is locked to the top of Row 2, and the bottom is 

locked to the bottom of Row 16.  

5. From the Chart Tools Design ribbon add a Y axis title to explain what the Y axis is 

referring to. Click the drop-down arrow next to Add a Chart Element and select Axis Titles, 

then select Primary Vertical Axis. While the axis title is still selected, click in the Formula 

bar and type Number of Students. Then click Enter.  

6. Click the title of the chart to activate the title box.  

7. In the formula bar type the following in front of the word Class: Final Grades for the 

Class.  

8. Click any cell location on the Grade Distribution worksheet to deactivate the chart.  

Figure 4.10 "Grade Frequency Distribution Chart" shows the completed grade frequency 

distribution chart. By looking at the chart, you can immediately see that the greatest 

number of students earned a final grade in the B+ to B− or the C+ to C− categories. 
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Moving a Chart to a Chart Sheet  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.04 if starting here.)  

 

The charts we have created up to this point have been added to, or embedded in, an 

existing worksheet. Charts can also be placed in a dedicated worksheet called a chart sheet. 

It is called a chart sheet because it can contain only an Excel chart. Chart sheets are useful if 

you need to create several charts using the data in a single worksheet. If you embed several 

charts in one worksheet, it can be cumbersome to navigate and browse through the charts. 

It is easier to browse through charts when they are moved to a chart sheet because a 

separate sheet tab is added to the workbook for each chart. The following steps explain 

how to move the grade frequency distribution chart to a dedicated chart sheet:  

 

1. Click anywhere on the Final Grades for the Class chart on the Grade Distribution 

worksheet.  

2. Click the Move Chart button in the Design tab of the Chart Tools set of commands. This 

opens the Move Chart dialog box. You can use this dialog box to move the chart to a 

different worksheet or create a dedicated chart sheet.  

3. Click the New sheet option on the Move Chart dialog box.  

4. The entry in the input box for assigning a name to the chart sheet tab should 

automatically be highlighted once you click the New sheet option (see Figure 4.11 "Moving 

a Chart to a Chart Sheet"). Type Class Grades. This replaces the generic name in the input 

box.  

5. Click the OK button at the bottom of the Move Chart dialog box. This adds a new chart 

sheet to the workbook with the name Class Grades. 
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Figure 4.12 "Chart Sheet Added to the Workbook" shows the Final Grades for the Class 

column chart in a separate chart sheet. Notice the new sheet tab added to the workbook 

matches the tab name entered into the Move Chart dialog box. Since the chart is moved to a 

separate chart sheet, it no longer is displayed in the Grade Distribution worksheet. 
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Clustered Column Chart: Frequency Comparison  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.05 if starting here.)  

 

Next, the professor would like to see how the students in his class students compared to all 

the students taking the course at the school. We will create a second column chart to show 

a comparison between two frequency distributions. Column C on the Grade Distribution 

worksheet contains data showing the number of students who received grades within each 

category for the entire college. We will use a clustered column chart to compare the grade 

distribution for the class (Column B) with the overall grade distribution for the college 

(Column C).  

However, since the number of students in the class is significantly different from the total 

number of students in the college, we must calculate percentages to make an effective 

comparison. The following steps explain how to calculate the percentages: 

1. Highlight the range B9:C9 on the Grade Distribution worksheet.  

2. Click the AutoSum button in the Editing group of commands on the Home tab of the 

Ribbon. This automatically adds SUM functions that sum the values in the range B4:B8 and 

C4:C8.  
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3. Activate cell E4 on the Grade Distribution worksheet.  

4. Enter a formula that divides the value in cell B4 by the total in cell B9. Add an absolute 

reference to cell B9 in the formula =B4/$B$9.  

5. Copy the formula in cell E4 and paste it into the range E5:E8 using the Paste Formulas 

command.  

6. Activate cell F4 on the Grade Distribution worksheet.  

7. Enter a formula that divides the value in cell C4 by the total in cell C9. Add an absolute 

reference to cell C9 in the formula =C4/$C$9.  

8. Copy the formula in cell F4 and paste it into the range F5:F8 using the Paste Formulas 

command. 

 

 

Figure 4.13 "Completed Grade Distribution Percentages" shows the completed percentages 

added to the Grade Distribution worksheet. The column chart uses the grade categories in 

the range A4:A8 on the X axis and the percentages in the range E4:F8 on the Y axis. Like the 

trend comparison line chart, this chart uses data that is not in a contiguous range. This 

method is more cumbersome then the first method presented but provides an excellent 

learning example of how to edit your chart data. The following steps explain a second 

method for creating charts with data that is not in a contiguous range:  

1. Activate cell H2 on the Grade Distribution worksheet. It is important to note that this is a 

blank cell that is not adjacent to any data on the worksheet.  

2. Click the Insert tab of the Ribbon.  
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3. Click the Column button in the Charts group of commands. Select the first option from 

the drop-down list of chart formats, which is the Clustered Column. This adds a blank chart 

to the worksheet.  

4. Click and drag the blank chart so the upper left corner is in the middle of cell H2.  

5. Resize the blank chart so the left side is locked to the left side of Column H, the right side 

is locked to the right side of Column P, the top is locked to the top of Row 2, and the bottom 

is locked to the bottom of Row 16.  

6. Click the Select Data button in the Design tab of the Chart Tools section of the Ribbon. 

This opens the Select Data Source dialog box.  

7. Click the Add button on the Select Data Source dialog box. This opens the Edit Series 

dialog box.  

8. In the Series name input box on the Edit Series dialog box, type the word Class.  

9. Press the TAB key on your keyboard to advance to the Series values input box on the Edit 

Series dialog box.  

10. Highlight the range E4:E8 on the Grade Distribution worksheet. This automatically adds 

the range to the Series values input box. You also see bars added to the column chart (see 

Figure 4.14 "Completed Data Series for the Class Grade Distribution").  

11. Click the OK button on the Edit Series dialog box. 

 
12. Click the Add button on the Select Data Source dialog box.  

13. In the Series name input box on the Edit Series dialog box, type the word College.  

14. Press the TAB key on your keyboard to advance to the Series values input box on the 

Edit Series dialog box.  
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15. Highlight the range F4:F8 on the Grade Distribution worksheet. This automatically adds 

the range to the Series values input box. You also see bars added to the column chart.  

16. Click the OK button on the Edit Series dialog box.  

17. Click the Edit button on the right side of the Select Data Source dialog box under the 

Horizontal (Category) Axis Labels section. This is used to define the labels that will appear 

on the X axis of the chart and opens the Axis Labels dialog box.  

18. Highlight the range A4:A8 on the Grade Distribution worksheet. This adds the range to 

the Axis Labels dialog box, and the labels appear on the X axis on the column chart (see 

Figure 4.15 "Final Settings for the Select Data Source Dialog Box").  

19. Click the OK button on the Axis Labels dialog box.  

20. Click the OK button on the Select Data Source dialog box. 

 

Figure 4.15 Final Settings for the Select Data Source Dialog Box 

 
21. Click the drop-down next to the Add Chart Element. Select Chart Title from the 

dropdown list. Chart. Because there is a lot of white space above the line chart we will 

select the Above Chart option from the drop-down list (see Figure 4.8 "Adding a Title to a 

Chart"). This adds a generic title above the plot area of the chart.  

22. Click in the text box containing the chart title. Delete the generic chart title and replace 

it with the following: Grade Distribution Comparison.  

23. From the Add Chart Element drop-down, select Legend, Bottom. This places the legend 

below the chart which does not compress the chart size as much as if it were placed on the 

sides.  
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Figure 4.16 "Completed Grade Distribution Column Chart" shows the final appearance of 

the clustered column chart. The clustered column chart is an appropriate type for this data 

because there are fewer than twenty data points and we can easily see the comparison for 

each category. An audience can quickly see that the class issued fewer A’s compared to the 

college. However, the class had more B’s and C’s compared with the college population. 

 
Selecting Non-Contiguous Ranges:  

The previous steps walked you through how to create a chart “from scratch” by building all 

the data series within the Select Data Source dialog box. A quicker method to build a chart 

using non-contiguous ranges is to select the first range, typically the row with labels, hold 

down the Ctrl key and select any other cells you want to chart. 
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Combo Chart: Non-comparative values  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.06 if starting here.)  

Remember, when building the second frequency chart above we created percentages to 

create a chart that had comparative value. However, we do have a chart type that can take 

disparate values like those of comparing a class to the college as a whole. This chart is the 

Combo chart. It uses both columns and lines to display data in such a way that it can be 

meaningful. The combo chart uses the vertical Axis to convey meaning to the data being 

presented. We will create a Combo chart to show a comparison between two frequency 

distributions. Column C on the Grade Distribution worksheet contains data showing the 

number of students who received grades within each category for the entire college. We 

will use a column chart to compare the grade distribution for the class (Column B) with the 

overall grade distribution for the college (Column C). 

However, since the number of students in the class is significantly different from the total 

number of students in the college, we will make the class grades a column chart and the 

college grades a line chart. The steps to do this are:  

1. On the Grade Distribution worksheet, highlight the range B3:C8  

2. From the Insert ribbon click on Recommended Charts, then select the All Charts tab, and 

then Combo Chart. 

 

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                276 

  

3. You’ll notice that our chart example looks a bit strange. We need to define which series 

will be the line and which will be the clustered column. We will take the default selected 

here, but the chart types can be change by using the drop-down next to each chart type.  

4. Next, we need to tell Excel which series we want to be our secondary vertical axis. The 

values for this axis will show on the left side of the chart and the values for the primary will 

show on the right. We will select the line chart to be our secondary axis.  

5. You will see the chart example change so that now there is a meaningful chart showing. 

Click the OK button.  

6. Next, we will put in our vertical axis titles so the chart is easier to read. From the Chart 

Tools Design ribbon, Add Chart Element, select Axis Titles and Primary Vertical Axis. 

7. With the Axis Title box active, type Class Students in the Formula bar and hit Enter.  

8. Now we will add the secondary vertical axis following the same steps above, excepting 

selecting Secondary Vertical Axis.  

9. With the Axis Title box active, type College Students in the Formula bar and hit Enter.  

10. We will rotate the College Students axis label by going to the Home ribbon and in the 

Alignment section rotate the text down. 
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Pie Chart: Percent of Total  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.07 if starting here.)  

The Health Care worksheet contains data that shows total spending in the United States for 

the years 1975 and 2015. In 1975, the total amount spent in the United States for health-

related expenses was over $135 billion. The total amount spent in 2015 was over $3.2 

trillion.  

The next chart we will demonstrate is a pie chart. A pie chart is used to show a percent of 

total for a data set at a specific point in time. In the case of our health care data, you can 

choose either the 1975 data, the 2015 data, or the total spent for the two time periods. You 

cannot use a pie chart to chart all three columns.  

The data we will use to demonstrate a pie chart is related to the overall spending activity in 

the health-care industry for 1975. The pie chart shows how this $135 billion was funded. 

The following steps explain how to accomplish this:  

 

1. Highlight the range A2:B7 on the Health Care worksheet. 

 

2. Click the Insert tab of the Ribbon.  

3. Click the Pie button in the Charts group of commands.  

4. Select the “3-D Pie chart” option in the middle section of drop-down list of options.  

5. Click and drag the pie chart so the upper left corner is in the middle of cell E2.  

6. Resize the pie chart so the left side is locked to the left side of Column E, the right side is 

locked to the right side of Column M, the top is locked to the top of Row 2, and the bottom is 

locked to the bottom of Row 17 (see Figure 4.18 "Pie Chart Moved and Resized"). 
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7. Click the chart legend once and press the DELETE key on your keyboard. A pie chart 

typically shows labels next to each wedge. Therefore, the legend is not needed.  

8. Click the Add Chart Element button on the Design tab of the Chart Tools section of the 

Ribbon and select Data Labels from the drop-down list.  

9. Select More Data Label Options from the drop-down list. This opens the Format Data 

Labels dialog box.  

10. Click the box next to the Value option under the Label Options section in the Format 

Data Labels dialog box. This removes the check mark.  

11. Click the Percentage option under the Label Options section in the Format Data Labels 

dialog box. A green check should appear in the box next to this option.  

12. Click the Category Name option under the Label Options section in the Format Data 

Labels dialog box. A check should appear in the box next to this option.  

13. Click the Close button at the top of the Format Data Labels dialog box.  

14. Click the Home tab of the Ribbon and then click the Bold button. This should bold the 

data labels on the pie chart. 
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15. This is looking better, but some of our data labels are overlapping. We will correct that 

by rotating our 3-D chart. While the chart is still selected, right click and select 3-D rotation 

from the drop-down menu. Note: Only 3-D charts can be rotated. 

 
16. From the 3-D Rotation format area, rotate the X rotation by 180 degrees. Close the 

Format Chart Area options.  

17. Make the chart title active by clicking on the 1975.  

18. Click in front of the year 1975 and type Health Care Spending by Source. 
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Figure 4.20 "Final Health Care Pie Chart" shows the completed pie chart. You can quickly 

see that Health Insurance and Out of Pocket made up the majority of health-care spending 

in 1975. Like the column chart, the key to creating an effective pie chart is the number of 

categories presented on the chart.  

 

Although there are no specific limits for the number of categories you can use on a pie 

chart, a good rule of thumb is ten or less. As the number of categories exceeds ten, it 

becomes more difficult to identify key categories that make up the majority of the total. In 

this example, it is easy to see that two categories compose 75% of the total. 
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Stacked Column Chart: Percent of Total Trend:  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.07 if starting here.)  

The last chart type we will demonstrate is the stacked column chart. We use a stacked 

column chart to show how a percent of total changes over time. For example, the data on 

the Health Care worksheet shows spending by source for 1975 and 2015. A stacked column 

chart can show whether there is any change in the percent of total for each source between 

the two years. Remember that with a pie chart we are limited to one data series only. In a 

stacked column chart, we can have multiple data series and use them for comparative 

purposes.  

On the stacked column chart the Y axis of the chart shows the percentage from 0% to 

100%. The X axis shows the two years: 1975 and 2015. The following steps explain how to 

create this chart:  

1. Highlight the range A2:C7 on the Health Care worksheet. Note: never include the total 

row or column unless that is the only data you are charting.  

2. Click the Insert tab of the Ribbon.  

3. Click the Column button in the Charts group of commands. Select the 100% Stacked 

Column format option from the drop-down list (see Figure 4.21 "Selecting the 100% 

Stacked Column Format"). 

 
Figure 4.22 "Initial Construction of the 100% Stacked Column Chart" shows the column 

chart that is created after selecting the 100% Stacked Column format option. As mentioned, 

the goal of this chart is to show the percentages on the Y axis and the years 1975 and 2015 
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on the X axis. However, notice that Excel places the spend sources on the X axis. The 

remaining steps explain how to correct this problem and complete the chart: 

 
4. Click the Switch Row/Column button in the Design tab on the Chart Tools section of the 

Ribbon. This reverses the legend and current X axis categories.  

5. Click and drag the chart so the upper left corner is in the middle of cell E19.  

6. Resize the chart so the left side is locked to the left side of Column E, the right side is 

locked to the right side of Column N, the top is locked to the top of Row 19, and the bottom 

is locked to the bottom of Row 37.  

7. Click the legend one time and press the DELETE key on your keyboard.  

8. Click the Layout tab on the Chart Tools section of the Ribbon. 

9. Click the Add Chart Element and select Data Table with Legend Keys option from the 

drop-down menu. This is another way of displaying a legend for a column chart along with 

the numerical values that make up each component. Note: It is generally better to not 

include the data table in your charts as it clutters more than helps. In this example, it is 

appropriate. 
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10. Click in the chart title button in the Layout tab of the Chart Tools section of the Ribbon.  

11. Select the Above Chart option for the drop-down menu.  

12. Click the chart title two times. Delete the generic chart title name and type Change in 

Health Care Spend Source.  

Figure 4.23 "Final 100% Stacked Column Chart" shows the final stacked column chart. 

Notice that the Out-of-Pocket category, or the amount of cash people paid for health-care 

expenses, decreased significantly from 1975 to 2015. However, the Health Insurance 

category increased significantly from 1975 to 2015.  

Overall, the chart shows that the total out-of-pocket and health insurance expense 

increased significantly from 1975 to 2015. These two categories made up approximately 

77% of total health-care spending in 1975. By 2015, these two categories increased to over 

85% of total health-care spending. 
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4.2 Formatting Charts 

 
There are a variety of formatting techniques to enhance the appearance of a chart once you 

have created it. Formatting commands are applied to a chart for the same reason they are 

applied to a worksheet: to make the chart easier to read. However, formatting techniques 

can help you qualify and explain the data in a chart. For example, you can add footnotes 

explaining the data source as well as notes that clarify the type of numbers being presented 

(i.e., if the numbers in a chart are truncated, you can state whether they are in thousands, 

millions, etc.). These notes are also helpful in answering questions if you are using charts in 

a live presentation. These formatting techniques will be demonstrated using the column 

chart and stacked column chart from the previous section.  

 

Getting to Know the Elements of a Chart  
A chart has many elements. Some of these elements are displayed by default, others can be 

added as needed. You can change the display of the chart elements by moving them to 

other locations in the chart, resizing them, or by changing the format. You can also remove 

chart elements that you do not want to display. 

1. The chart area of the chart.  

2. The plot area of the chart.  

3. The data points of the data series that are plotted 

in the chart.  

4. The horizontal (category) and vertical (value) 

axis along which the data is plotted in the chart.  

5. The legend of the chart.  

6. A chart and axis title that you can use in the chart.  
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7. A data label that you can use to identify the details of a data point in a data series. 

 

X and Y Axis Formats  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.08 if starting here.)  

There are numerous formatting commands that can be applied to the X and Y axes of the 

chart. Although adjusting the font size, style, and color are common, many more options are 

available through the Format Axis dialog box (see Figure 4.5 "Format Axis Dialog Box"). 

The following steps demonstrate a few of these formatting techniques on the Grade 

Distribution Comparison chart: 

1. Click anywhere along the X axis (horizontal axis) of the Grade Distribution Comparison 

chart on the Grade Distribution worksheet.  

2. Click the Home tab of the Ribbon.  

3. Change the font style to Arial. Notice that as the mouse pointer hovers over a font style, 

you can preview the change on the chart before you make a selection.  

4. Change the font size to 11 points and bold the font. The final appearance of the X axis is 

shown in Figure 4.24 "Formatted X Axis".  

5. Click anywhere along the Y axis to activate it.  

6. Repeat steps 3 and 4. 
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7. Click the Format tab in the Chart Tools section of the Ribbon. 

8. Click the Format Selection button in the Current Selection group of commands. This 

opens the Format Axis dialog box. Note: you can access any of the formatting dialog boxes 

by right clicking on the area you wish to format. Then select format (whichever area you 

chose). 

 
 

9. Click Number from the bottom of the Axis (see Figure 4.25 "Formatting Numbers on the 

Y Axis"). The commands in this section of the Format Axis dialog box are used to format 

numbers that appear on the X and Y axes of a chart.  

10. Click in the Decimal places input box and change the value to 0.  

11. Click the X button at the top right of the Format Axis dialog box. The formatting 

adjustments are shown in Figure 4.26 "Completed X and Y Axis Formats". 
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Chart Legend and Title Formats  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.09 if starting here.)  

The next items we will format on the Grade Distribution Comparison chart are the chart 

legend, axis titles and chart title. Similar to how we formatted the X and Y axes, we can 

format these items by activating them and using the formatting commands in the Home tab 

or the Format tab of the Ribbon. We will use the Quick Layout button on the Chart Tools 

Design ribbon to add axis titles and move the legend. The following steps explain how to 

add these formats:  

 

1. Activate the Grade Distribution chart on the Grade Distribution worksheet. From the 

Chart Tools Design ribbon click on the Quick Layout button. AS you scroll through the 

different layouts you will see your chart change. Select Layout 9. This will add your axis 

titles, keep the chart title and move the legend to the right side of the Plot area. (Note: if 

you accidently select a quick layout that eliminates the title, you will have to redo your title 

text.) 
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2. Click and drag the legend so the top of the legend aligns with the 35% line next to the 

plot area (see Figure 4.27-2 "Moving the Legend"). 
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3. Click and drag the lower center sizing handle so the bottom of the legend is aligned with 

the 25% line of the plot area.  

4. Click and drag the left sizing handle so the legend is against the plot area.  

5. Change the font style in the Home tab of the Ribbon to Arial.  

6. Change the font size to 12 points.  

7. Click the bold and italics commands in the Home tab of the Ribbon.  

8. Click the chart title to activate it.  

9. Click the Format tab in the Chart Tools section of the Ribbon.  

10. Click the More down arrow in the Shape Styles group of commands to open the 

complete set of preset format styles. 

 

11. Click the Subtle Effect - Blue, Accent 1 option, which is in the fourth row, second style 

from the left. As the mouse hovers over a style, you can preview the appearance on the 

chart.  

12. In the Home tab of the Ribbon, change the font style to Arial and reduce the font size to 

14 points (see Figure 4.29 "Chart Legend and Title Formatted"). 
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X and Y Axis Titles  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.10 if starting here.)  

 

Titles for the X and Y axes are necessary for defining the numbers and categories presented 

on a chart. For example, by looking at the Grade Distribution Comparison chart, it is not 

clear what the percentages along the Y axis represent. In the last section, we added axis 

titles by using the Quick Layout button. To add titles without using a Quick Layout, the 

following steps explain how to add titles to the X and Y axes to define these numbers and 

categories:  

1. If you have axis titles already on your chart proceed to step 5.  

2. Click anywhere on the Grade Distribution Comparison chart in the Grade Distribution 

worksheet to activate it.  

3. Click the Add Chart Element button.  

4. Click the Axis Titles button in the Labels group of commands and select Primary Vertical 

Axis. This adds a title next to the Y axis. Repeat the above to add the Primary Horizontal 

Axis. 

5. Click the Format tab in the Chart Tools section of the Ribbon.  

6. Click the Colored Outline - Blue, Accent 1 preset style option in the Shape Styles group of 

commands.  

7. Change the font style in the Home tab to Arial. Change the font size to 11 points and 

apply the bold format.  

8. While the vertical Axis Title box is selected type Percent of Enrolled Students in the 

formula bar. Hit Enter when finished.  

9. Click on the horizontal Axis Title.  

10. Click the Format tab in the Chart Tools section of the Ribbon.  

11. Click the Colored Outline - Blue, Accent 1 preset style option in the Shape Styles group 

of commands.  

12. Change the font style in the Home tab to Arial. Change the font size to 11 points and 

apply the bold format.  

13. While the vertical Axis Title box is selected type Final Course Grade in the formula bar. 

Hit Enter when finished.  
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Figure 4.31 "X and Y Axis Titles Added" shows the added titles for the X and Y axes. The 

titles provide definitions for the grade categories along the X axis as well as the percentages 

on the Y axis. 

 

Data Series Labels and Formats  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.11 if starting here.)  

Adding labels to the data series of a chart is a formatting feature that may aide in bringing 

clarity to a chart. However, caution should be used so the chart does not become cluttered 

and hard to read. A data series is the item that is being displayed graphically on a chart. For 

example, the blue bars on the Grade Distribution Comparison chart represent one data 

series. We can add labels at the end of each bar to show the exact percentage the bar 

represents. In addition, we can add other formatting enhancements to the data series, such 

as changing the color of the bars or adding an effect. The following steps explain how to add 

these labels and formats to the chart:  

1. Click any red bar representing the College data series on the Grade Distribution 

Comparison chart in the Grade Distribution worksheet. Clicking one bar automatically 

activates all bars in the data series. If you click a bar a second time, only that bar is 

activated.  

2. Click the Format tab in the Chart Tools section of the Ribbon.  

3. Click the down arrow on the Shape Fill button in the Shape Styles group of commands.  
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4. Click the orange color square from the drop-down color palette (see Figure 4.32" 

Changing the Color of a Data Series"). As you move the mouse pointer over colors on the 

palette, you can preview the change on the data bars. 

 
5. Click the Design tab in the Chart Tools section of the Ribbon.  

6. Click the Add Chart Element. button in the Labels group of commands. Select Data Labels, 

and then Outside End from the options in the drop-down list.  

7. Right click on any of the labels and select Format Data Labels from the drop-down list.  

8. Select Number in the Text Options Format window. Then, select Percentage in the 

Category box. Then change the decimal places to 0. (see Figure 4.33 "Adding Labels to a 

Data Series").  

9. Click in the Decimal Places input box and change the number of decimal places to zero.  

10. Click the Close button at the bottom of the Format Data Labels dialog box.  

11. Click the Home tab of the Ribbon.  

12. Change the font style to Arial, change the font size to 9 points, and select the Bold 

command.  

13. Click any blue bar in the Class data series.  

14. Repeat steps 5 through 12. 
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Figure 4.34 "Completed Formatting Adjustments for the Data Series" shows the Grade 

Distribution Comparison chart with the completed formatting adjustments and labels 

added to the data series. Note that we can move each individual data label. This might be 

necessary if two data labels overlap or if a data label falls in the middle of a grid line. To 

move an individual data label, click it twice, then click and drag. 
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Formatting the Plot and Chart Areas  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.12 if starting here.)  

 

The next items to format on the Grade Distribution Comparison chart are the plot and chart 

areas. We can format these areas primarily to enhance the visibility of the data series. The 

following steps explain how to add these formatting enhancements to the chart:  

 

1. Click anywhere in the chart area of the Grade Distribution Comparison chart in the Grade 

Distribution worksheet. 

2. Click the Format tab in the Chart Tools section of the Ribbon.  

3. Click the down arrow on the Shape Fill button in the Shape Styles group of commands.  

4. Select the Tan, Background 2, Darker 25% option from the color palette (see Figure 4.36 

"Formatting the Chart Area").  

https://mlpp.pressbooks.pub/businesscomputers2019
https://creativecommons.org/licenses/by-nc-sa/4.0/


 
 

 

 

 The Most Excellent OER Spreadsheets Textbook Ever Published (in 2025) by Marcus Lacher  
is licensed  under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License,    
except where otherwise noted                298 

  

 
5. Click anywhere in the plot area to activate it. Be sure not to click a grid line or one of the 

data series.  

6. Click the Format tab in the Chart Tools section of the Ribbon.  

7. Click the Shape Effects button in the Shape Styles group of commands.  

8. Place the mouse pointer over the Bevel option from the drop-down list. Then select the 

Round bevel option from the second drop-down list (see Figure 4.37 "Putting a Bevel Effect 

on the Plot Area"). 
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Figure 4.38 "Grade Distribution Comparison Chart with Formats Applied" shows the 

completed Grade Distribution Comparison chart. The darker shade on the chart area along 

with the bevel effect on the plot area make the data series the main focal point of the chart. 
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Adding Series Lines and Annotations to a Chart  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.13 if starting here.)  

 

The last formatting features we will demonstrate are adding series lines and annotations to 

a chart. To demonstrate these skills, we will use the Change in Health Care Spend Source 

stacked column chart. Series lines are commonly used in stacked column charts to show the 

change from one stack to the next. Annotations are useful for clarifying the data presented 

in a chart or for identifying data sources. In addition to demonstrating these skills, we will 

review several of the formatting skills that were covered in this section. The following steps 

include the skills review as well as the new formatting features:  

1. Locate the Change in Health Care Spend Source chart on the Health Care worksheet. 

Activate the chart by clicking anywhere inside the chart perimeter.  

2. Move the chart to a separate chart sheet by clicking the Move Chart button in the Design 

tab of the Ribbon. Type the following sheet tab label in the New sheet input box: Health 

Spending Chart. Click the OK button.  

3. Click anywhere on the X axis to activate it. In the Home tab of the Ribbon, change the font 

style to Arial, change the font size to 12 points, and select the bold command.  

4. Activate the Y axis and apply the same formatting adjustments as stated in step 3.  

5. Add a Y axis title by Clicking on Add Chart Element for the Chart Tools Design ribbon and 

selecting Axis titles, then Primary Vertical Axis.  

6. In the Format tab under the Chart Tools section of the Ribbon, select the first preset style 

option, Colored Outline - Black, Dark 1, in the Shape Styles group of commands. Then, in the 

Home tab of the Ribbon, change the font style to Arial and the font size to 14 points.  

7. While the Axis Title is still selected, type Percent of Total Annual Spend in the Formula 

bar and then hit enter to save your changes.  

8. Click and drag the vertical axis so it is closer to the plot area. 

9. Activate the title of the chart by clicking it once. In the Format tab under the Chart Tools 

section of the Ribbon, select the first preset style option, Colored Outline - Black, Dark 1, in 

the Shape Styles group of commands. Then, in the Home tab of the Ribbon, change the font 

style to Arial.  

10. Activate the Chart Area by clicking on the down arrow next to the Format Selection box 

on the Format tab of the Chart Tools ribbon, and selecting Chart Area. 
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11. Click the Format tab in the Chart Tools section of the Ribbon and click the down arrow 

on the Shape Fill button. Select the Olive Green, Accent 3, Lighter 60% option on the color 

palette. Note: This will change the entire chart background to the color selected.  

12. Activate the plot area using the method in step 10.  

13. Change the plot area shape fill to white.  

14. Click the Shape Effects button in the Format tab of the Ribbon. Place the mouse pointer 

over the Bevel option from the drop-down menu. Select the first option from the Bevel 

format list, which is the “Round” bevel option.  

15. Click and drag down the top center sizing handle of the plot area approximately 1/2 

inch (see Figure 4.39 "Adjusting the Size of the Plot Area").  

16. Click and drag up the bottom center sizing handle approximately three-quarters of an 

inch This step and step 15 are necessary to create space at the top and bottom of the chart 

to add annotations.  
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Figure 4.39 "Adjusting the Size of the Plot Area" shows the Change in Health Care Spend 

Source chart prior to adding the series lines and annotations. The remaining steps will 

focus on adding lines and annotations: 

 
17. Click the Design tab in the Chart Tools section of the Ribbon.  

18. Click the Add Chart Element, Lines, Click the Series Lines option from the drop-down 

list. This adds lines to the chart, connecting each data series between the two stacks (see 

Figure 4.40 "Selecting the Series Lines Option"). 
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19. Click any of the series lines added to the chart. Clicking one line will activate all lines on 

the chart. Note: you can select the series lines the way you did earlier. Chart Tools, Format, 

select Series Line1 from the Format Selection box. 
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20. Click the Shape Outline button in the Format tab of the Ribbon. Place the mouse pointer 

over the Weight option and select the “2¼ line weight” option. 

Figure 4.42 "Series Lines Added to the Stacked Column Chart" shows the appearance of the 

chart with the series lines connecting the two stacks. This formatting enhancement is 

common for stacked column charts. The lines help focus the audience’s attention on 

changes in the percent of total trend. In this case, the audience can quickly see the decline 

in the Out-of-Pocket category (blue) and the increase in the Health Insurance category 

(red). 

 
21. Click anywhere in the chart area of the Change in Health Care Spend Source chart.  

22. Click the Text Box button in the Chart Tools Format Ribbon. 
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23. Position the mouse pointer on the left edge of the chart area approximately one-quarter 

inch from the top. Click and drag a rectangle approximately one and a half inches wide and 

one-quarter inch high (see Figure 4.43 "Adding Annotations to the Stacked Column Chart").  

24. Click the Home tab of the Ribbon and change the font style to Arial, change the font size 

to 10 points, and select the bold and italics commands.  

25. Type Dollars in Millions. This tells the audience that the numbers have been truncated 

and represent denominations in millions. This means you would add six zeros to the end of 

each number on the chart. Therefore, the Out-of-Pocket value for 1975 is shown as $22,617 

but is $22,617,000,000, or $22.6 billion. 

 
26. Repeat steps 19–22 to add a second text box to the chart. Begin drawing this text box 

below the first box approximately one inch in from the left edge of the chart Complete the 

formatting changes in step 22 and select the Align Text Right command.  

27. Type 100% = in the second text box.  

28. Repeat steps 19–22 to add a third text box to the chart. Center this text box over the 

1975 stack. In addition to the formatting commands in step 22, select the Center align 

command and the Underline command.  

29. Type $66,172 in the third text box.  

30. Repeat steps 19–22 to add a fourth text box to the chart. Center this text box over the 

2015 stack. In addition to the formatting commands in step 22, select the Center align 

command and the Underline command.  

31. Type $2,486,293 in the fourth textbox.  
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32. Repeat steps 19–22 to add a fifth text box to the chart. Begin drawing this text box at 

the bottom left edge of the chart, just below the data table. The text box will need to be at 

least four inches wide.  

33. Type Source: CMS Centers for Medicaid and Medicare Services in the fifth text box. 

Figure 4.44 "Completed Stacked Column Chart with Annotations" shows the completed 

Change in Health Care Spend Source stacked column chart. The lines and annotations 

provide key information for understanding the data and interpreting the trends presented 

on the chart. 
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4.3 The Scatter Chart 

 
This section focuses on the scatter chart type. What makes this chart different from the 

other charts demonstrated in this chapter is that values are used on both the X and Y axes. 

So far, the charts we have demonstrated in this chapter use categories or qualitative labels 

for the X axis. This means that the distance between each category on the X axis will always 

be the same, even if numbers are used. In a scatter chart, the X axis operates just like the Y 

axis. In other words, the distance between the values on the X axis will vary depending on 

the value of the number. Depending on the format, we can create the scatter chart to look 

just like a line chart. Since both the X and Y axes contain quantitative values, the scatter 

chart is a valuable tool for studying various shapes or functional forms for a line chart. In 

fact, a common feature used with the scatter chart is the trendline and equation. Excel can 

evaluate the line that is produced on a scatter chart and produce a mathematical equation. 

We will demonstrate these features in this section. 

 

The Scatter Chart: Supply and Demand  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.14 if starting here.)  

A common use for a scatter chart is the study of supply and demand curves. This is because 

the data points for both the supply and demand lines require quantitative values on both 

the X and Y axes. The Y axis contains the price of a certain good or item; the X axis contains 

the quantity sold for that good or item. Fundamental economic laws state that as prices 

rise, sellers are willing to increase supply and sell more goods. However, the reverse is true 

for consumers. As prices rise, consumers purchase fewer goods. The Supply & Demand 

worksheet contains hypothetical data for the supply and demand of breakfast cereal. There 

are ten data points to show the change in supply and demand as the price changes in 

Column A. The values you see in Columns A through C are formula outputs that are driven 

by the percentage in cell C14. For example, if the percentage in cell C14 is changed to 10, 

each price listed in Column A will increase, as shown in Figure 4.45 "Hypothetical Supply 

and Demand Data". 
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The formula =A3*(1+$C$14) is multiplying the Price in A3 by 1 + the percent change in cell 

C14. Using 1 + % is the same as multiplying A3 by 110% (given the example in Figure 4.45.) 

If you only multiply by the price change percent, you will get just the percent increase 

amount. Not the price but the percent increase. In the above example, if you multiply by the 

price change percent only, you will get $.15. Not the new price after the increase has been 

applied.  

We will use the scatter chart to study the change in quantity supplied and demanded as the 

price increases over ten data points, as shown in Figure 4.45 "Hypothetical Supply and 

Demand Data". For many of the charts demonstrated in this chapter, we could highlight a 

range of cells and insert the chart type we needed. This was especially the case when the 

data was in a contiguous range of cells. However, this method rarely works when creating a 

scatter chart, even if the data are in a contiguous range. As a result, the method we present 
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here starts with a blank chart and demonstrates how each data series is added to the chart 

individually. The following steps explain how we create this chart:  

 

1. Change the value in cell C14 on the Supply & Demand worksheet to zero.  

2. Activate cell E1 on the Supply & Demand worksheet. It is important to note that this cell 

location is not adjacent to any data on the worksheet.  

3. Click the Scatter button from the Charts group of commands on the Insert tab of the 

Ribbon.  

4. Select the Scatter with Smooth Lines and Markers format from the drop-down list of 

options (see Figure 4.46 "Selecting a Scatter Chart Format"). This adds a blank chart to the 

worksheet. 

 

 
5. Click and drag the chart so the upper left corner is in the center of cell E2.  
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6. Resize the chart so the left side is locked to the left side of Column E, the right side is 

locked to the right side of Column M, the top is locked to the top of Row 2, and the bottom is 

locked to the bottom of Row 17.  

7. Click the Design tab in the Chart Tools section of the Ribbon. Then click the Select Data 

button in the Data group of commands. This opens the Select Data Source dialog box.  

8. Click the Add button on the left side of the Select Data Source dialog box. This opens the 

Edit Series dialog box. Notice on this dialog box there are inputs for defining values for both 

the X and Y axes. Charts that we previously created using this method only had an input for 

putting values on the Y axis.  

9. Type the series name Demand. This should appear in the Series name input box.  

10. Press the TAB key on your keyboard to advance to the Series X values input box on the 

Edit Series dialog box.  

11. Highlight the range B3:B12 on the Supply & Demand worksheet. You will see this range 

appear in the Series X values input box after it is highlighted.  

12. Press the TAB key on your keyboard to advance to the Series Y values input box on the 

Edit Series dialog box.  

13. Highlight the range A3:A12 on the Supply & Demand worksheet.  

14. Figure 4.47 "Defining the Demand Data Series" shows the final settings in the Edit 

Series dialog box for the Demand data series. You will see that as the X and Y axis values are 

defined in the dialog box, they appear on the chart. The chart in this figure shows the price 

along the Y axis and quantity along the X axis. 
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15. Click the OK button at the bottom of the Edit Series dialog box.  

16. Click the Add button on the left side of the Select Data Source dialog box.  

17. Type the series name Supply. This should appear in the Series name input box.  

18. Press the TAB key on your keyboard to advance to the Series X values input box on the 

Edit Series dialog box.  

19. Highlight the range C3:C12 on the Supply & Demand worksheet. This range appears in 

the Series X values input box after it is highlighted.  

20. Press the TAB key on your keyboard to advance to the Series Y values input box on the 

Edit Series dialog box.  

21. Highlight the range A3:A12 on the Supply & Demand worksheet.  

22. Click the OK button at the bottom of the Edit Series dialog box.  

23. Click the OK button at the bottom of the Select Data Source dialog box. 

Figure 4.48 "Scatter Chart Showing One Price" shows the appearance of the scatter chart 

before any formatting enhancements are applied. Notice only two plot points are located 

on the chart. This is because the price change value in cell C14 is still zero. Therefore, the 

data are not reflecting any change in price, quantity demanded, or quantity supplied. The 
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chart shows that at the current price of $1.50, suppliers are willing to provide fewer units 

compared with the number of units consumers are willing to buy.  

 
 

The following steps explain the formatting enhancements we will apply to the scatter chart 

shown in Figure 4.48 "Scatter Chart Showing One Price": 

 

1. Add titles to the chart by clicking the Quick Layout drop down button on the Chart Tools 

Design Tab. Choose Layout 1  

2. Click on the Chart Title to activate it. Select Subtle Effect - Orange, Accent 6 from the 

Theme Styles list in the Shape Styles group of commands on the Format tab of the Ribbon.  

3. Change the font style of the chart title to Arial, bold, and the font size to 14 points.  

4. Change the wording of the chart title as follows: Supply and Demand for Breakfast 

Cereal.  

5. Click on the vertical Axis Title  

6. Repeat steps 2 and 3 to format the Y axis title. However, change the font size to 12 points.  

7. Change the wording of the Y axis title as follows: Price per Unit.  

8. Click on the X Axis Title.  

9. Repeat steps 2 and 3 to format the X axis title. However, change the font size to 12 points.  
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10. Change the wording of the X axis title as follows: Quantity in Units.  

11. Change the color of the plot area back to white. Note: if you don’t change the color to 

white, when you do step 12 the entire chart will be Aqua Accent 5. You can always come 

back and change the plot area back to white if that happens.  

12. Change the color of the chart area to Aqua, Accent 5, Lighter 40% (see Figure 4.49 

"Formatting Enhancements Added to the Scatter Chart"). 

 
13. Apply a bevel effect to the plot area. Use the Circle format option from the Bevel 

dropdown list of options.  

14. Change the font style of the legend to Arial and bold the font.  

15. Change the value in cell C14 to 2. Then change it to 4 and then to 8. Change the value 

one more time to 14. As you change the values in cell C14, you will see the lines change on 

the chart.  

 

Figure 4.50 "Scatter Chart with Price Change at 2%" shows the completed scatter chart 

when the Price Change is set to 2%, and Figure 4.51 "Scatter Chart with Price Change at 

14%" shows the same chart when the Price Change is set to 14%. The point at which the 
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demand and supply lines intersect on Figure 4.51 "Scatter Chart with Price Change at 14%" 

is known as the market equilibrium point.  

The market equilibrium is where the quantity demanded equals the quantity supplied at a 

specific price. The price where quantity demanded equals quantity supplied is referred to 

as the equilibrium price. 
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Changing the Scale of the X and Y Axes  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.15 if starting here.)  

 

For all the charts demonstrated in this chapter, Excel has automatically established the 

scale for the Y axis. For scatter charts, Excel has also established the scale for the X axis. The 

axis scale is the minimum and maximum value that appears on an axis. For example, in 

Figure 4.51 "Scatter Chart with Price Change at 14%", the Y axis scale is set to a minimum 

value of zero and a maximum value of 6.00. Although this is a very convenient feature of 

Excel, you may want to change the scale in some instances. If you change the value in cell 

C14 on the Supply & Demand worksheet, the lines jump or shift on the plot area of the 

chart. This is because Excel keeps rearranging the scale of both the X and Y axes. When 

studying the shape of lines, it is best to set the scale so it does not change. The following 

steps explain how to accomplish this:  

1. Change the value in cell C14 on the Supply & Demand worksheet to zero.  

2. Right click anywhere on the Y axis of the chart and select Format Axis.  

3. Click in the Maximum setting under the Axis Options in the Format Axis dialog box.  

4. Click in the input box next to the Maximum setting. Remove the 1.6 and enter the number 

5.0.  

5. We will not be studying the behavior of supply and demand beyond a $5.00 price point, 

so there is no need to extend the Y axis beyond this point.  
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6. Click in the input box next to the Major Unit setting and change the value to 0.5 if not 

already set to 0.5. (see Figure 4.52 "Setting the Y Axis Scale"). This allows us to measure the 

plot points in $0.50 intervals along the Y axis.  

 
7. Click the X button at the top of the Format Axis dialog box.  

8. Click anywhere along the X axis of the chart.  

9. Click the Format Selection button in the Layout tab of the Chart Tools section of the 

Ribbon. This opens the Format Axis dialog box for the X axis.  

10. Click the Fixed option next to the Minimum setting under the Axis Options in the 

Format Axis dialog box. This ensures that the minimum value for the X axis will always be 

zero.  

11. Click the Fixed option next to the Maximum setting under the Axis Options in the 

Format Axis dialog box.  

12. Click in the input box next to the Maximum setting. Remove the 500.0 and enter the 

number 450.0. The number of units supplied or demanded will not exceed 450 based on 

the price points in our study. There is no need to extend the X axis to 500.  

13. Click the Fixed option next to the Major Unit setting under the Axis Options in the 

Format Axis dialog box.  
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14. Click in the input box next to the Major Unit setting and change the value from 100.0 to 

50.0. This allows us to measure the plot points in 50-unit intervals along the X axis.  

15. Click the Close button at the bottom of the Format Axis dialog box.  

16. Change the value in cell C14 to 2. Then change it to 4 and then to 8. Change the value 

one more time to 14. As you change the values in cell C14, the lines change but they no 

longer jump or shift since the scale of both axes is fixed.  

Figure 4.53 "Final Appearance of the Scatter Chart" shows the final appearance of the 

scatter chart after the scale is set for both the X and Y axes. Notice that market equilibrium 

is achieved at a price of approximately $2.50. 

 

Figure 4.53 Final Appearance of the Scatter Chart 

 

 

Adding a Trendline and Equation  
Follow-along file: Continue with Excel Objective 4.00. (Use file Excel Objective 4.16 if starting here.)  

A trendline can be applied to a chart to estimate or predict where plot points may occur at 

various points along the X and Y axes. Excel enables you to add a trendline to a chart and 

provides the equation you can use to plot additional points. The following steps explain 

how to accomplish this:  

1. Set the value in cell C14 on the Supply & Demand worksheet to14.  

2. Click anywhere in the chart area of the scatter chart to activate it.  

3. Click the Add Chart Element button in the Design tab of the Chart Tools and select 

Trendline from the drop-down menu. Select the Linear Trendline option from the 

dropdown list.  
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4. Select the Demand option from the Add Trendline dialog box and click the OK button. 

This adds a new line to the plot area of the chart as well as the legend.  

5. Figure 4.54 "Adding a Linear Trendline" shows the scatter chart after adding a linear 

trendline.  

Notice that the line goes through only two points on the demand line. This indicates that 

this trendline may not be a good fit for the line that has been created on the chart. 

 

6. Finding the right shape for a trendline may require trying a few different options. As 

shown in Figure 4.54 "Adding a Linear Trendline", the linear trendline is not a good fit for 

the shape of the demand line. The remaining steps will demonstrate how to remove a 

trendline and access more trendline options:  

7. Click the Trendline button in the Layout tab of the Ribbon. Select the None option from 

the drop- down list. This removes the trendline from the chart.  

8. Click the Trendline button in the Layout tab of the Ribbon again. Note: You must remove 

a trendline because clicking on other trendlines will add them to your chart with the one 

you already have created. This time, select More Trendline Options from the drop-downlist.  

9. Select the Demand option from the Add Trendline dialog box and click OK. This opens the 

Format Trendline dialog box.  

10. Select the Power option from the Format Trendline dialog box.  

11. Click the “Display Equation on chart” option at the bottom of the Format Trendline 

dialog box (see Figure 4.55 "The Format Trendline Dialog Box").  

12. Click the Close button at the bottom of the Format Trendline dialog box. 
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Figure 4.56 "Scatter Chart with a Power Trendline" shows the scatter chart with the Power 

trendline added for the demand series. Notice that the line fits perfectly over the demand 

series in the plot area. In fact, it may be difficult to see the line in the figure. This indicates 

that the trendline is an excellent fit for the demand line. As a result, we can be confident in 

using this line to predict other demand values along the X and Y axes. You can also see that 

the equation for this trendline has been added to the plot area of the chart. We can use the 

equation to calculate the price for each quantity value substituted for X. For example, if the 

number 150 is substituted for X in the equation, the result is a price of $2.59. Based on the 

values used to create the chart, this result appears to be accurate. 
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4.4 Using Charts with Microsoft® Word® and PowerPoint® 

 
Charts that are created in Excel are commonly used in Microsoft Word documents or for 

presentations that use Microsoft PowerPoint slides. Excel provides options for pasting an 

image of a chart into either a Word document or a PowerPoint slide. You can also establish 

a link to your Excel charts so that if you change the data in your Excel file, it is automatically 

reflected in your Word or PowerPoint files. We will demonstrate both methods in this 

section.  

 

Pasting a Chart Image into Word  
Follow-along Word file: Excel Objective 4.17  

 

Excel charts can be valuable tools for explaining quantitative data in a written report. 

Reports that address business plans, public policies, budgets, and so on all involve 

quantitative data. For this example, we will assume that the Change in Health Care Spend 

Source stacked column chart (see Figure 4.44 "Completed Stacked Column Chart with 

Annotations") is being used in a written policy report. The following steps demonstrate 

how to paste an image, or picture, of this chart into a Word document:  

 

1. Click below the figure heading in the Word document that reads: Figure 6: Health Care 

Spending in the U.S. The image of the stacked column chart will be placed below this 

heading.  

2. Open the Excel Objective 4.16 follow-along file.  

3. Activate the Change in Health Care Spend Source chart in the Health Spending Chart 

worksheet.  

4. Click the Copy button in the Home tab of the Ribbon.  

5. Go back to the Excel Objective 4.17 Word document by clicking the file in the taskbar.  

6. Click the drop-down arrow below the Paste button in the Home tab of the Ribbon. Click 

the Picture option from the drop-down list, which is the last option on the far right (see 

Figure 4.57 "Paste Picture Option for Word"). 

7. Click anywhere on the picture of the chart to activate it.  
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8. Click the Format tab under the Picture Tools section of the Ribbon (see Figure 4.58 

"Changing the Size of a Picture in Word"). 

 
9. Click the down arrow on the Shape Width button in the Size group of commands (see 

Figure 4.58 "Changing the Size of a Picture in Word"). Continue to click the down arrow 

until the width of the picture is 5.5. As you reduce the width of the picture, the height is 

automatically reduced as well. 
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Figure 4.59 "Final Appearance of Pasting a Chart Image into Word" shows the final 

appearance of the Change in Health Care Spend Source chart pasted into a Word document. 

It is best to use either the Shape Width or Shape Height buttons to reduce the size of the 

chart. Using either button automatically reduces the height and width of the chart in proper 

proportion. If you choose to use the sizing handles to resize the chart, holding the SHIFT 

key while clicking and dragging on a corner sizing handle will also keep the chart in proper 

proportion. 
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Pasting a Linked Chart Image into PowerPoint  
Follow-along PowerPoint file: Excel Objective 4.18  

 

Microsoft PowerPoint is perhaps the most commonly used tool for delivering live 

presentations. The charts used in a live presentation are critical for efficiently delivering 

your ideas to an audience. Like written documents, a wide range of presentations may 

require the explanation of quantitative data. This demonstration includes a PowerPoint 

slide that could be used in a presentation for setting prices for a hypothetical breakfast 

cereal company. We will paste the scatter chart showing the supply and demand for 

breakfast cereal into this PowerPoint slide. However, instead of pasting an image, as 

demonstrated in the Word document, we will establish a link to the Excel file. As a result, if 

we change the chart in the Excel file, the change will be reflected in the PowerPoint file. The 

following steps explain how to accomplish this:  

1. Open the Excel Objective 4.16 follow-along file.  

2. Activate the scatter chart in the Supply & Demand worksheet.  

3. Click the Copy button in the Home tab of the Ribbon.  

4. Go back to the Excel Objective 4.18 PowerPoint file by clicking the file in the taskbar.  
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5. Click the down arrow below the Paste button in the Home tab of the Ribbon in the 

PowerPoint file.  

6. Select the Keep Source Formatting & Link Data option from the drop-down list (see 

Figure 4.60 "Creating a Link to an Excel Chart in PowerPoint"). This pastes an image of the 

Excel chart into the PowerPoint slide. In addition, a link is created so that any changes 

made to the chart appear on the PowerPoint slide. 

 

 
7. Click anywhere in the plot area of the scatter chart pasted into the PowerPoint slide. You 

will see the same Excel Chart Tools tabs added to the Ribbon (see Figure 4.61 "Modifying 

an Excel Chart Pasted into a PowerPoint Slide"). 
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8. Click the down arrow next to the Shape Fill button in the Format tab of the Ribbon. Select 

the white color block from the palette (see Figure 4.61 "Modifying an Excel Chart Pasted 

into a PowerPoint Slide").  

9. Go back to the Excel Objective 4.16 file by clicking it in the taskbar.  

10. In the Supply & Demand worksheet, change the value in cell C14 to 6. 

11. Go back to the Excel Objective 4.18 PowerPoint file by clicking it in the taskbar.  

12. Click the Design tab in the Chart Tools section of the Ribbon. Click the Refresh Data 

button (see Figure 4.62 "Refreshing a Linked Excel Chart Pasted into a PowerPoint Slide"). 

The change made in the Excel workbook is now reflected on the PowerPoint slide.  

 
 

Figure 4.62 "Refreshing a Linked Excel Chart Pasted into a PowerPoint Slide “shows the 

appearance of the scatter chart in the PowerPoint slide after the color of the plot area was 

changed back to white. Figure 4.63 "Final Chart Linked to a PowerPoint Slide" shows the 

appearance of the scatter plot after the change was made in the Supply & Demand 

worksheet in the Excel file. The change that was made in the Excel file will appear in the 

PowerPoint file after clicking the Refresh Data button. 
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Chapter 5 
 

Tables and PivotTables 
 

Until now in this text we have dealt with small amounts of data. However, the more 

common situation in businesses today is having very large data sets to manipulate and 

make sense of. For example, large amounts of data can come from Access databases, data 

mining on the web, exporting from an accounting program, or many other places. The data 

can be thousands upon thousands of rows of raw data. How can we efficiently manipulate 

that kind of overwhelming data? In this chapter, we will explore the built-in tools in Excel 

that allow us to easily manipulate large data sets. Excel will easily condense, sort, filter, and 

subtotal data. Using PivotTables and PivotCharts we will see the power of Excel to 

condense raw data into easily manipulated reports. 

 
 

Creating a Table  
Suni works in the accounting department for Great Education College. She is given the task 

of condensing the data around vehicles owned by the college. She must condense the 

information into easily understandable reports to be provided to the college board’s 

finance committee. 

Follow-along file: Excel Objective 5.00.  

Suni examines the data in the College Vehicles worksheet. She notes that each has an Asset 

number, the year vehicle was made, the make and style of the vehicle, which department 

has control of the vehicle, its purchase price and estimated annual maintenance cost. She 

will use this data to create her various reports.  

A few things to know about data in tables before we begin. 
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• Data must be in contiguous cells – no breaks in rows or columns  

• Headers must be next to the first row of data – no break in rows between headers and the 

start of your data.  

 

We will create an Excel table to manipulate her data. The steps we will use to do that are:  

1. Click on any cell within the list of data.  

2. From the Insert ribbon, select Table. Excel will automatically determine the absolute 

range of cells that will be placed in your table. See Figure 5.01  

 
 

1. From the Create Table dialog box check to make sure it is including all the data table. You 

will see a marquee around your table and the range selected will be in the dialog box. You 

can use the dialog box to select the correct data if the range is not correct.  

2. Click Ok  

Excel will automatically apply a color style with banded rows. We will eliminate the banded 

rows, because it only adds visual clutter to the data. Remember our data needs to tell a 
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story without clutter. The banded row format will lose the ability to maintain the banded 

row colors when the table is converted back to a range. Note: we will cover converting back 

to a range later.  

3. In the Table styles section of the Table Tools Design ribbon, use the drop-down in the 

styles and select None. (Top row, first column) See Figure 5.2. The None style will revert 

the appearance of your table back to a normal spreadsheet, except that now you will have 

drop-down arrows next to each of the column headers.  

 
 

4. Rename the table to Vehicles_Source by clicking in the Table Name Box on the Table 

Tools ribbon. Note: the same rules that you learned for naming cells and ranges applies to 

naming tables.  
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Adding Records  
Maintaining data in an Excel tables means that you will most likely be adding or deleting 

records from the table. The simplest way to add a record to an Excel table is to add it at the 

first blank row at the bottom of the table.  

The school recently purchased another vehicle for the maintenance department. The 

record for the vehicle needs to be added to the Vehicle_Source table. The data for the new 

vehicle is:  

• Asset # 4625  

• Year 2023  

• Make: Ford  

• Style: Pickup  

• Odometer: 15  

• Department Maintenance  

• Purchase price: $44,250  

• Annual Maintenance: 2,532  

1.From anywhere in the worksheet hold the Ctrl key down and click the End key. 

2.Click the Home key to move you to column A. 

3.Hit Enter once to move you to the first blank row. 

4.Enter the data above. Use the tab key to move you across the cells as you enter the data. Note: as 

you enter the new data, the table will continue the formatting from the data in the column above the 

new entry. 
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Finding and Editing Records  
You need to update the records for the 2008 Chevrolet van, asset number 1196, and the 2013 Ford 

van, asset number 1678. They have been reassigned from Campus Housing to the Athletics 

department. You’ll use the Find command to locate the records. Then, you will edit the record to 

change the assigned departments to Athletics.  

1. Press the Ctrl+Home keys to move to the top of the worksheet, and then click cell A2 to make it 

the active cell. You will search on the asset number because it is a distinguishing number in the 

table. 

2. In the Editing group on the Home tab, click the Find & Select button, and then click Find. The 

Find and Replace dialog box opens. 

3. Type 1140 into the Find what: dialog box. Then click Find Next. Leave the Find and Replace 

dialog box open while you edit the first record. 

4. Click F26 and change the department to Athletics. Note: As you type the A, the Athletics 

department will appear in the auto complete. Hit enter to accept the department. 

5. In the Find and Replace dialog box, delete the 1196 asset number and enter the next record 

number that must be updated, 1678. Click Find Next. Then close the dialog box. 

6. Change the department to Athletics.  

 

Deleting Records  
The last update required is to delete a record for a sold vehicle. Asset number 1040, a 2003 Ford 

van was sold and needs to be removed from the asset list.  

The steps you will use to delete the record are:  

1. Press the Ctrl+Home keys to move to the top of the worksheet, and then click cell A2 to make it 

the active cell. You will search on the asset number because it is a distinguishing number in the 

table. 

2. In the Editing group on the Home tab, click the Find & Select button, and then click Find. The 

Find and Replace dialog box opens. 

3. Type 1040 into the Find what: dialog box. Then click Find Next. Close the Find and Replace 

Dialog box. 

4. In the Cells group of the Home tab, click the Delete button and select Delete Table Rows from 

the drop down. Note: If a different record was deleted, the active cell was not in the record for the 

Asset 1140. Click the Undo button and select the correct record.  
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Adding a Total Row  
Follow-along file: Continue with Excel Objective 5.00. (Use file Excel Objective 5.01 if starting here.)  

Suni would like to see a count of how many vehicles the college owns. She wants to have the count 

be dynamically linked to the table contents.  

The steps we will use to create a total row, and then change it to a count are:  

1. From the Table Style Options on the Table Tools Deign tab, check the box for Total Row. Note: 

you can uncheck the box to turn off the total row.  
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2. Excel will drop you down to the newly created total row. It will automatically put in a total for 

Annual Maintenance. We will accept that for now. Click on the total row for the Style. From the 

drop-down select count.  

 
 

3. Delete the word Total from the A column and type Total number of vehicles. (Don’t worry about 

overlapping cell walls.)  

4. In column g: type Total maintenance.  

Remember: Your worksheet must tell a story all by itself! 

 

Adding a New Column  
Follow-along file: Continue with Excel Objective 5.00. (Use file Excel Objective 5.02 if starting here.)  

Suni would like to see the monthly maintenance cost for each vehicle. She has asked you to add a 

column next to the Annual Maintenance column.  

A unique feature of having your data in a table, versus just a range of data, is the ability to add a 

column, have the formatting applied, and the formulas added in the top row of the data will 

automatically copy down the worksheet.  

We will add a new column by:  

1. Click in cell I1. Type: Monthly Maintenance and hit Enter. The bold and center formatting will 

automatically be applied to the column header and a drop-down box will appear next to the 

column header. 

2. Resize column I to fit the new header. 

3. In I2 enter a formula to divide the Annual Maintenance by 12. Type = and click on cellH2. Notice 

that when you click on H2 you see something new in your formula. Instead ofH2 you now see = 

[@[Annual Maintenance]]. This only occurs in a table. It will allow the formula to be copied down 

the range of cells in the table automatically. Type /12 after clicking on cell H2. 
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4. Hit enter to complete the formula. 

5. Format the column by clicking on the column header to select it, then click on the lower border 

of the cell. This will highlight the column data. On the home ribbon select the Accounting format. 
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5.2 Sorting and Filtering Data 

 

Sorting One Column  
Follow-along file: Continue with Excel Objective 5.00. (Use file Excel Objective 5.03 if starting here.) 

 
The records in the Asset record table appear in the order they were entered. There will be times 

when you are working in a data table, or creating reports, that you will want to see records sorted 

in a different order. For example, you may want to sort records by department, by make of car, or 

by odometer reading.  

Data can be sorted in:  

• Ascending order: lowest to highest, dates oldest to newest, or A to Z.  

• Descending order: highest to lowest, dates newest to oldest, or Z to A  

Data can be quickly sorted by using the drop-down arrows to the right of each of the column 

headers. When you click on the arrow you will see the sort functions A to Z, or Z to A. Note: you 

cannot use the sort for more than one column. If you want to sort by multiple columns you must use 

the Sort button from the Data ribbon tab.  

Suni wants to see the table sorted by department to see how many vehicles are in each 

department. The steps to accomplish this are:  

1. We want to maintain the integrity of our raw data, so we will copy the Raw Data worksheet and 

make our changes in the new worksheet. While holding the Ctrl key down, left click the worksheet 

tab and drag to the right. You will see a little image of a piece of paper with a +. Drop the 

worksheet to the right of the original worksheet. The new worksheet will have the name Raw Data 

(2)  

2. Rename the new worksheet College Vehicles by double clicking on the worksheet tab, 

eliminating the title there and entering the new title.  

3. Click on the drop-down next to the Department column header. See Figure 5.4  

4. Select the A to Z sort. Data is sorted with Athletics first, ending with Telecom.  
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Notice that the active cell in Figure 5.5 is A1. However, the drop-down selected was for the 

Department as indicated by the department names at the bottom of the list.  
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Multi-Column Sort  
Using the drop-down in a table column makes a one series sort very quick and easy. However, 

trying to sort by multiple columns does not work using this method. As soon as you click on 

another column and perform a new sort, the original sort you created in the first column is 

overwritten by the new sort applied. You were briefly introduced to the Sort dialog box in 

Chapter1 for a single column sort. In this section, we will be dealing with performing a multi-

column sort using the Sort dialog box.  

The first thing that must be decided when performing a multi-column sort is what will be the 

primary sort, secondary, and so on.  

Suni, after looking at the sort, decides that a better view would be to sort by Department, then by 

Style, by Make, and finally by year purchased with the latest models first. To perform this multi-

column sort, we will perform the following steps:  

1. Have an active cell anywhere within your table or range.  

2. From the Sort & Filter section of the Data ribbon, select Sort.  

 
 

3. The sort dialog box will appear.  

4. The first dialog box in the Sort is the Column. Whichever column contains your active cell will 

be the default Sort by in the column. The drop-down next to the column will have all of the column 

headings. Remember that Suni wants to sort by department first. From the drop down select 

Department. Note: My data has headers at the top right of the dialog box must be checked or Excel 

will treat your headers as part of the table data.  

5. In the Sort On field, select what cell contents the sort will focus on. The choices in the list are:  

• Values – this is the default. Whatever value is in the cell will be used for the sort.  

• Cell color – if cells have a conditional formatting, or highlighting, that fills a cell with color, it 

can be used in the sort. When selecting this option, a color selection box will be added to 

the Add level row. A second new selection box will appear that asks if the cell color should 

be on top of the other items in the column, or at the bottom.  

 

• Font color – – if contents of cells have a font color other than black, it can be used in the 
sort. When selecting this option, a color selection box will be added to the Add level row. 
This choice will also get the second box that asks where the cells containing color should be 
place in the sort order.  

• Icons – Excel 2016 allows the placement of icons in a cell. This concept is not covered in 
this book, but if placed in a cell can be used as a sort.  
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6. The last field in the Sort is the Order field. You can sort in Ascending, Descending, or by a 
Custom List. (See Creating a Custom List in Section 5.2 Sorting and Filtering.) The default sort for 
text is A to Z. We will accept the default.  

7. Click on Add level at the top right of the Sort dialog box. A new level will be added to the sort 
dialog box. In the dialog box for the Then by, select Style from the drop-down list. Note: you can 
change a level by re-selecting from the drop-down. You can also delete a level by clicking on the row 
and clicking on Delete Level.  

8. Add another level for the Make.  

9. Add a final level for the year purchased. Change the Order for the Year to Largest to Smallest, so 
the newest vehicles are displayed first.  

10. Click OK.  
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Note that after a sort is applied you will see arrows in the filter buttons next to the column 

headers indicating the column has been sorted and in which order (up or down) the sort was 

performed. 

 

 

Sort Using a Custom List  
Follow-along file: Continue with Excel Objective 5.00. (Use file Excel Objective 5.04 if starting here.)  

There may be times when entering repetitive entries like days of the week, or sorting 

alphabetically or numerically in descending or ascending order doesn’t give you the results you 

want to see. An example of this that we use often is sorting by the days of the week, or by months 

in the year. If we sorted those alphabetically, we would come up with the jumbled orders you see 

in Table 5.1. 
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There may also be times where you would sort by a specific part number order, or name. In cases 

like these, you need to sort using a custom list. There are several custom lists already established 

in Excel. They include the days of the week and the months in the year. You saw the custom lists in 

action when we filled the months down a column using the auto fill feature. The auto fill feature 

will also draw on any custom lists established in Excel. You may even want to edit a custom list 

that is already set up. For instance, if you only want to fill Monday – Friday as the days of the 

week, you can edit the days of the week list to eliminate Saturday and Sunday from the list. Note: 

custom lists apply in all your workbooks. If you edit the days of the week list, it will be available in all 

your workbooks. 

 

Suni wants to see the departments sorted in the following order:  

• Athletics  

• Campus Housing  

• Campus Security  

• Printing Services  

• Dining Services  

• Telecom  

• Maintenance  

 

We will look at the custom lists already set up and set up a custom list for sorting the departments 

in an order different than alphabetically.  
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1. From the Sort & Filter section of the Data tab, click on the Sort button. The sort you established 

in the last section will be displayed.  

2. In the Department row, click on the drop down next to the Order box.  

3. Select Custom List. The Custom Lists dialog box will be activated.  

 
 

4. The NEW LIST option is automatically highlighted. Press Enter to create a new list or click in the 

List Entries box.  

5. Type the departments in the order that Suni gave you, or you can copy the list and paste if from 

another source if available.  

6. When finished, click OK. Note: Pressing enter will only move you down to a new row in your list.  

7. Your custom list now shows in the Order box.  

 

8. Resort the list by clicking OK. Your table is now sorted according to your custom list in the order 

Suni wanted.  

Before we wrap up the Sort section, let’s put a good title on our worksheet that describes what we 

have done to the worksheet. Remember, that each worksheet must tell a story to the reader. To 

describe out story for this worksheet, we will describe the sort we did in the worksheet and what 

data the worksheet represents.  
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1. Merge and center cells A1:J1.  

2. Click in the grey area of row 1, when you see the black arrow pointing right, hold your left 

mouse button down and drag down to row 2. Both rows 1 and 2 should be selected.  

3. Using keyboard commands, hold down the Ctrl key and click the + key on your ten-key keypad if 

you have one. If you don’t have one then hold down the Ctrl key, the shift key, and the + keys. This 

will add two rows at the top of your document.  

4. Insert the following title in row 1. Remember to hold the Alt key and press enter at the end of 

each row to wrap the text in the cell.  

Minnesota State College 

Vehicles Sorted by Department 

Report date: 3/1/2025 

 

 
As we progress through the rest of Chapter 5, we will modify the report title to reflect how we 

have modified our data. 

 

5.3 Filtering Data 

 
Suni now wants to determine which vehicles should be considered for replacement. She is going to 

base her decision to replace a vehicle based on the age of the vehicle and the odometer reading. 

She wants you to filter so that only the vehicles that were purchased before 2008 and have an 

odometer reading greater than 100,000 miles are shown in the list.  

Apply Filters  
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You could accomplish by coping the worksheet and deleting all the rows of vehicles that don’t 

meet her criteria, or you can filter the list to only show those vehicles that meet the given criteria. 

We will use filters to accomplish our goal.  

When you create an Excel table, or turn on the Filter from the Data tab, the filter arrows appear 

next to the column headers. You can use the options on the AutoFilter to create three types of 

filters. You can filter a column of data by its cell colors or font colors, by a specific text, number or 

date filter, (although the choices depend upon the type of data in the column,) or by selecting the 

exact values by which you want to filter in the column. After you filter a column, the Clear Filter 

command becomes available so you can remove the filter and redisplay all the records.  

Follow-along file: Continue with Excel Objective 5.00. (Use file Excel Objective 5.05 if starting here.)  

We will set up the filter for Suni, but we want to maintain the first worksheet sort. We will 

accomplish this by duplicating our worksheet and performing the filter on the new worksheet.  

1. While holding the Ctrl key down, left click the worksheet tab and drag to the right. You will see a 

little image of a piece of paper with a +. Drop the worksheet to the right of the original worksheet. 

The new worksheet will have the name College Vehicles (2).  

2. Rename the worksheet Vehicle Filter.  

 
 

3. Make sure the Vehicle Filter worksheet is active by clicking on the worksheet tab at the bottom 

of the worksheet.  

4. We will filter on the year first. It doesn’t matter which category you decide to filter on first, the 

end results will be the same. Click the Category Filter arrow next to Year.  

 
5. The AutoFilter menu opens as shown in Figure 5.7. It lists all the unique entries in the category. 

The list will differ based upon which column you select to filter.  
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6. We could go through and uncheck all the years we don’t want to filter on. In this case vehicle 

newer than 2008, or we can use the number filter feature. Click on the Number Filter directly 

above the Search box. Because we are filtering on all cars older than 2008, we will Select Less 

Than from the drop-down menu.  
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7. In the Custom AutoFilter dialog box, type 2008 and click OK.  

 
 

8. The next filter we will apply will be for the odometer reading greater than 100,000 miles. Click 

on the Category Filter arrow next to Odometer and choose Number Filters, Greater than. Type 

100000 (no commas) into the criteria value box. Click OK. Figure 5.10 shows the results of the 

number filters applied to the Year and Odometer columns.  

 

Suni decides that only the Maintenance department will get new vehicles this round, so she wants 

you to only show Maintenance in your report.  
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9. Click on the Category Filter next in the Department column. Note that the selection only shows 

those departments that are included in the filters that have been applied so far. Click the Select All 

so it is unchecked and then check Maintenance.  

10. Click OK to save the filter.  

 
Figure 5.11 shows the results of the custom filters applied to the data. Note that the count of 

vehicles and the sum of the annual maintenance has changed to reflect only those vehicles 

included in the filter. 
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11. The title of the worksheet must be corrected to reflect the data filters applied. We will change 

the second row of the title to reflect this change. Click in the A1, the worksheet title. Use the down 

arrow at the right side of the formula bar to show the entire title.  

12. Click in the second row and delete the text currently there. Replace that text with Maintenance 

Dept. Vehicles Bought before 2008 with > 100,000 miles.  

 

Clearing Filters  
To redisplay all the data in a filtered table or data range, you need to clear or remove the filters. 

When you clear a filter from a column, all the other filters still applied will remain in place. To 

redisplay the entire data table, all the filters must be removed. You can remove filters one at a 

time, or clear all filters.  

To remove one at a time, click on the AutoFilter button next to the category you want to restore. 

From the drop-down select Clear Filter from…  

To remove all filters, click on Clear Filters from the Sort & Filter section of the Data tab. 
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5.4 Subtotals 

 

Creating Subtotals  
Follow-along file: Continue with Excel Objective 5.00. (Use file Excel Objective 5.06 if starting here.)  

Suni is helping the college president prepare her budget, and she needs a report she can give to 

the college president showing the number of each style of vehicle and the total annual 

maintenance cost by department. Using the total row in your table would mean creating a filter for 

each department and Style. Then printing each out in a separate report. You can create this report 

for her by creating subtotals in your worksheet.  

We will summarize the data in our range by inserting subtotals. The subtotal command offers 

many kinds of summary commands. These include:  

• Count  

• Sum  

• Average  

• Maximums  
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• Minimums  

There are a few major rules that must be followed before we can use the subtotal command. These 

are critical and include:  

• Your data must be sorted in the order(s) you wish to create subtotals on. For instance, we 

want to create subtotals by department and by style within the department. Our sort levels 

would be department, then Style.  

• If you have your data in an Excel table, that data must be converted to a range. You cannot 

perform subtotals on data in a table.  

We will create these subtotals using the following steps.  

1. Copy the Raw Data worksheet by holding the Ctrl key down while left clicking the Raw Data 

worksheet tab and dragging the worksheet to the right of the Vehicle Filter worksheet.  

2. Rename the new worksheet Vehicle Subtotals.  

3. Create a multi-level sort by department and then by Style.  

 
4. Convert your Excel table to a range, (Note: you would skip this step if your data is not in an Excel 

table.) by clicking anywhere within the data. If your table has a total row, remove it by clicking on 

the check box in the Table Design ribbon. From the Table Tools Design click on Convert to Range 

in the Tools section.  
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5. Click Yes when the warning box appears.  

6. From the Outline section of the Data tab, click on Subtotal. The first subtotal we will insert is the 

cost of annual maintenance by department.  

7. From the Subtotal dialog box, in the At each change in: select Department from the drop-down. 

(This determines how the subtotals will be grouped.)  

8. In the Use function box, select Sum. (This determines what operation will be performed.)  

9. In the Add subtotal to: click on Annual Maintenance. Uncheck any box that may be selected 

because we only want a subtotal for Annual Maintenance.  

10. Click OK.  
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Next, we will add the count of vehicles by style to our subtotals. We will do that using the 

following steps.  

1. Make any cell in your data range active. Click on Subtotal in the Outline section of the Data 

ribbon.  

2. IMPORTANT: uncheck the box that says Replace current subtotals. If you do not, the new 

subtotal you create will erase the first one you did earlier.  

3. We need to count the number of vehicles by style in each department. In the At each change in: 

select Style.  

4. In the Use function: select Count. We want the number of each style vehicle in the department.  

5. In the Add subtotals to: select Style and uncheck Annual Maintenance.  

6. Click OK.  
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Next, we will add an appropriate title for our subtotal worksheet.  

1. Click in the grey area of row 1 and drag down through row 2. This will select the entire rows 1 

and 2. Hold the Ctrl key and click on the + key on your ten-key keypad, or Ctrl, Shift and the +, to 

insert two new rows.  

2. Merge and center across cells A1:H1.  

3. Type the following title in A1. Remember to use Alt and Enter to move down a row inside cell 

A1.  

Minnesota State College 

Vehicles Sorted by Department 

Report date: 3/1/2025 

4. Enter to save the contents of the cell.  

5. Resize row 1 so the entire title shows.  
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Subtotal Outline View  
In addition to displaying subtotals your Subtotal feature creates outline views. Figure 5.17 shows 

the outline buttons that are created when a worksheet has the subtotal feature applied. It will 

show or hide different levels of detail in your worksheet.  

1. Level 1: only the grand total shows.  

 
 

 

2. Level 2: totals for each of the main categories will show.  
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3. Level 3: will show if you have secondary subtotals. In the case of the college’s vehicles, 

we have a secondary sort by style, so our level 2 view shows the subtotals for both 

Department and Style.  

 
 

4. Level 4: shows the entire data set with subtotals. (Figure 5.17)  

In short, the higher the level showing the more condensed the data will be. As you move higher, 

more and more of the data will be revealed.  
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• Level 1 shows the grand total only  

• Level 2 shows the main category subtotal  

• Level 3 shows subtotals for each major and secondary subtotals (if more than one 

subtotal applied.)  

• Level 4 (in this example) shows all the data and subtotals.  

 

Removing Subtotals  
To remove the subtotal from a worksheet you must use the Subtotal button from the Outline 

section of the Data tab. Note: Clicking on Undo will not remove subtotals. 

Click Remove All from the lower left corner of the Subtotal Dialog box. See Figure 5.19. 
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5.6 PivotTables and PivotCharts 

 
An Excel worksheet can contain thousands upon thousands of rows and columns of data. The 

amount of data can be overwhelming to try to assimilate and make sense of. There is a wealth of 

information that can be obtained by using the right tools to condense and organize your data.  

A PivotTable summarizes data using the COUNT, SUM, AVERAGE, MIN and MAX functions. For 

example, Suni wants you to prepare a presentation for the budget committee that will summarize 

the college vehicles data. She wants her report to show total cost of annual maintenance by 

department and age of the vehicles.  

Creating a PivotTable  
Follow-along file: Continue with Excel Objective 5.00. (Use file Excel Objective 5.07 if starting here.)  

We will create a PivotTable to reflect Suni’s report needs. The steps to complete the PivotTable 

are:  

1. Click on the Raw Data worksheet tab to activate the worksheet. Make any cell active in your 

data range or table.  

2. Click on PivotTable from the Tables section of the Insert tab. The Create PivotTable dialog box 

will appear. 
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3. Accept the defaults and click OK.  

4. A new worksheet is created to the right of your Raw Data worksheet. Click and drag the 

worksheet tab to the right of the Vehicle Subtotal worksheet. Rename the worksheet Vehicle 

PivotTable.  
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Figure 5.21 shows the PivotTable elements. We are going to create the PivotTable by dragging 

fields from the field list into the design area in the lower right section.  

5. The first field we will drag down is the department field. Drag the field into the Rows area by 

clicking on the field name, holding left mouse, and dragging to Rows. As soon as you release the 

mouse you will see the departments appear in the PivotTable area.  

6. We will put the vehicle year field into the columns section of the pivot table by dragging it to 

Columns.  

7. Suni is looking for annual maintenance on the vehicles, so drag the annual maintenance field to 

the Values section of the design area.  
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Rearranging a PivotTable  
In evaluating the layout for the PivotTable, Suni determines she would rather see the years going 

down the rows and the departments as the columns. We will drag and drop the fields to recreate 

the chart.  

8. Click on Department in the Rows section and drag it up into the Columns area.  

9. Click on the Year in the Columns section and drag it down to rows. This makes the information 

easier to read.  

In looking at the data, it is difficult to determine how many vehicles the data applies to. Suni asks 

you to include a count of the vehicles in your layout.  

10. Drag the Style field into the Values section. Since the Style field contains text, Excel 

automatically applies a COUNT to the data.  

Suni likes this layout, but now it needs to be formatted and titled for a professional presentation.  

Value Field Settings  
11. Click any cell in the Sum of Annual Maintenance column of the PivotTable report.  

12. Left click the Sum of Annual maintenance field in the Values section. Select Value Field Settings 

from the drop-down menu.  

 
 

 

13. The field name is too wide and makes the PivotTable look long and drawn out. Change the 

Custom Name to Maint. Cost.  
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14. Click on Number Format and change the number format to Currency. In the symbol box select 

None from the drop-down. See Figure 5.23.  

 
15. Click OK to accept the Format Cells changes.  

16. Click Ok to accept all changes to the Annual Maintenance field in the PivotTable.  

17. Left click on the Count of Style field in the Values layout. Select Value Field Settings.  

18. Change the Custom Name to No. of Vehicles. Click OK to close the dialog box.  

PivotTable Formatting  
PivotTables are inherently ugly and require a bit of formatting to make them easily 

understandable to the reader. Remember, it must tell its own story.  

19. Click in cell B3. In the formula bar type; Department: Hit Enter.  

20. Click in cell A5. In the formula bar type: Vehicle Age. Hit Enter.  

21. Suni wants to see the No. of vehicles before the maintenance cost. In the Values section of the 

Pivot table design area, drag and drop the No. of Vehicles field above the Maint. Cost.  
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22. Highlight B4:C24 and apply an outside border. Repeat this step for each of the departments 

across the page.  

23. The last formatting change we will make to out PivotTable is the worksheet title. We already 

have a blank row in row 1, so adding a row is not needed.  

24. Select the range A1:Q1. Merge and Center the row.  

25. Type the following title into A1.  

Minnesota State College 

Annual Maintenance by Department 

Report Date 3/1/2025 

26. Resize Row 1 to fit the 3-line title.  

 

Recommended PivotTables  
If you have limited experience with PivotTables, or are not sure how to get started, a 

Recommended PivotTable is a good choice. When you use this feature, Excel determines a 

meaningful layout by matching the data with the most suitable areas in the PivotTable. This helps 

give you a starting point for additional experimentation. After a recommended PivotTable is 

created, you can explore different orientations and rearrange fields to achieve your specific 

results. The Recommended PivotTables feature was added in Excel 2013, so if you have an earlier 

version, follow the instructions below for how to manually create a PivotTable instead. 

Manually create a PivotTable  
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In the Choose where you want the PivotTable report to be placed section, select New 
Worksheet, or Existing Worksheet. For Existing Worksheet, you'll need to select both the 
worksheet and the cell where you want the PivotTable placed.  
 
If you want to include multiple tables or data sources in your PivotTable, click the Add this data 
to the Data Model check box.  
 
Click OK, and Excel will create a blank PivotTable, and display the PivotTable Fields list.  
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Slicers  
Slicers are a tool in Excel Pivot tables and Excel tables that allows you to insert a slicer on the face 

of the worksheet that easily filters out data. You can select a slicer from any field in the PivotTable, 

or table.  

Now that we have the PivotTable report finalized, we will add a slicer that will make it easy to 

filter data by Department. The steps we will use are:  

1. Click anywhere in the PivotTable to activate the PivotTable Tools Ribbon.  

2. Click on Insert Slicer from the Filter section of the Analyze tab of the PivotTable Tools.  

3. The Insert Slicers dialog box will appear. Click on Department to create a slicer for the 

department.  

 
4. Click OK.  

5. Move the slicer so it is positioned below the PivotTable.  

6. Click on a department to filter out all the other departments. You can select multiple 

departments by holding down the Ctrl key and clicking on department names.  
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Group or ungroup data in a PivotTable  
Grouping data in a PivotTable can help you show a subset of data to analyze. For example, you 

may want to group an unwieldy list of dates or times (date and time fields in the PivotTable) into 

quarters and months, like this: 

 
 

Note: The time grouping feature is new in Excel 2016. With time grouping, relationships across 

time-related fields are automatically detected and grouped together when you add rows of time 

fields to your PivotTables. Once grouped together, you can drag the group to your Pivot Table and 

start your analysis.  

Group fields  

1. In the PivotTable, right-click any numeric or date and time field, and click Group.  

2. In the Starting at and Ending at box, enter this (as needed):  
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• The smallest and largest number to group numeric fields.  

• The first and last date or time you want to group by.  

 

The entry in the Ending at box should be larger or later than the entry in the Starting at box.  

• 3. In the By box, do this:  

• For numeric fields, enter the number that represents the interval for each group.  

• For date or time fields, click one or more date or time periods for the groups.  

You can click additional time periods to group by. For example, you can group by Months and 

Weeks. Group items by weeks first, making sure Days is the only time period selected. In the 

Number of days box, click 7, and then click Months.  

Tip: Date and time groups are clearly labeled in the PivotTable; for example, as Apr, May, Jun for 

months. To change a group label, click it, press F2, and type the name you want.  

 

Group date and time columns automatically (time grouping)  

Note: The time grouping feature is available in Excel 2016 only.  

• In the PivotTable Fields task pane, drag a date field from the Fields area to the Rows or 

Columns areas to automatically group your data by the time period.  
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PivotTable Field List before time grouping  

 

Excel automatically adds calculated columns to the PivotTable used to group the date or time data. 

Excel will also auto collapse the data to show it in its highest date or time periods.  

For example, when the Date field is checked in the Fields list above, Excel automatically adds Year, 

Quarter, and month (Date) as shown below. 
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PivotTable Field List after time grouping  

 

Notes:  

• When you drag a date field from the Field List to the Rows or Columns area where a field 

already exists, and then put the date field above the existing field, the existing date field is 

removed from the Row or Columns area and the data won't be automatically collapsed so you 

can see this field when collapsing the data.  
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• For a data model PivotTable, when you drag a date field with over one thousand rows of data 

from the Field List to the Rows or Columns areas, the Date field is removed from the Field List 

so Excel can display a PivotTable that overrides the one million records limitation.  

Group selected items  

You can also select specific items and group them, like this: 

 
 

1. In the PivotTable, select two or more items to group together, holding down Ctrl or Shift while 

you click them.  

2. Right-click what you selected, and click Group.  

When you group selected items, you create a new field based on the field you are grouping. For 

example, when you group a field called SalesPerson, you create a new field called SalesPerson1. 

This field is added in the field section of the Field List, and you can use it like any other field. In the 

PivotTable, you’ll see a group label, like Group1 for the first group you create. To change a group 

label to something more meaningful, click it, > Field Settings, and in the Custom Name box, type 

the name you want.  

Tips:  

• For a more compact PivotTable, you might want to create groups for all the other ungrouped 

items in the field.  
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• For fields that are organized in levels, you can only group items that all have the same next-

level item. For example, if the field has levels Country and City, you can't group cities from different 

countries.  

 

Ungroup grouped data  

To remove grouping, right-click any item in the grouped data, and click Ungroup.  

If you ungroup numeric or date and time fields, all grouping for that field is removed. If you 

ungroup a group of selected items, only the selected items are ungrouped. The group field won’t 

be removed from the Field List until all groups for the field are ungrouped. For example, suppose 

you have four cities in the City field: Boston, New York, Los Angeles, and Seattle. You group them 

so that New York and Boston are in one group you name Atlantic, and Los Angeles and Seattle are 

in a group you name Pacific. A new field, City2, appears in the Fields area and is placed in the 

Rows area of the Fields List.  

As shown here, the City2 field is based on the City field, and is placed in the Rows area to group 

the selected cities. 
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As shown below, the four cities are arranged under the new groups, Atlantic and Pacific. 
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Note: When you undo time grouped or auto collapsed fields, the first undo will remove all the 

calculated fields from the field areas leaving only the date field. This is consistent with how 

PivotTable undo worked in previous releases. The second undo will remove the date field from 

the field areas and undo everything.  

About grouping data in a PivotTable  

When you group data in a PivotTable, be aware that:  

• You can’t add a calculated item to an already grouped field. You first need to ungroup the 

items, add the calculated item, and then regroup the items.  

• You can’t create slicers for grouped fields.  

• Excel 2016 only: You can turn off time grouping in PivotTables (including data model 

PivotTables) and Pivot Charts by editing your registry.  
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PivotCharts  
Suni would like you to create a chart for her that graphically shows the cost by department. 

Because of the disparate vales between maintenance cost and number of vehicles for each 

department, the data in the Vehicle PivotTable would not create a clear and informative 

PivotChart. We will make a copy of the Vehicle PivotTable worksheet and use the copy to build our 

PivotChart.  

1. Click on the Vehicle PivotTable tab, hold the Ctrl key down while dragging to the right.  

2. Rename the new Vehicle PivotTable(2) to Vehicle PivotChart.  

3. If the PivotTable Field list is not showing, click anywhere in the PivotTable, from the Show 

section of the Analyze PivotTable Tools tab, click the FieldList button.  

4. On the copied PivotTable, in the PivotTable name box on the Analyze tab of the PivotTable tools, 

rename the PivotTable1 to PivotTable 2. Note: if you don’t rename the PivotTable, it will be linked to 

the first PivotTable.  

5. To eliminate the number of vehicles from our PivotTable so we can create a meaningful chart, 

drag the No. of Vehicles field out of the Values section. Your PivotTable will now just show the 

annual maintenance cost by department and year.  

6. Click the PivotChart button from the Analyze PivotTable Tools tab.  

7. Select the Clustered Column chart type.  

8. From the PivotTable Tools Design tab, click the Move Chart button. Move the PivotChart to its 

own chart sheet called Maint PivotChart.  
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9. Close the PivotChart field list.  

10. From the Design tab of the PivotChart Tools, apply Style 9 to the PivotChart.  

11. From the Quick Layout button select Layout 3 which will put the legend below the chart and 

insert a Title.  

12. Click in the title box. In the Formula bar insert the same title you used for the PivotTable.  

Great Education College 

Annual Maintenance by Department 

Report Date 7/1/2018 

 

13. From the Add Chart Element button, add a primary vertical axis.  

14. Click in the vertical axis. In the formula bar type: Annual Maintenance Cost  
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Import data from a database  
We start this tutorial with a blank workbook. The goal in this section is to connect to an external 

data source, and import that data into Excel for further analysis.  

The data we will import describes Olympic Medals, and is a Microsoft Access database.  

1. Download the OlympicMedals.accb Access database file from the text files and save it where you 

will be able to find it again for the next steps.  

2. In Excel 2016, open a blank workbook.  

3. Click DATA > Get External Data > From Access. The ribbon adjusts dynamically based on the 

width of your workbook, so the commands on your ribbon may look slightly different from the 

following screens.  
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4. Select the OlympicMedals.accdb file you downloaded and click Open. The following Select Table 

window appears, displaying the tables found in the database. Tables in a database are similar to 

worksheets or tables in Excel. Check the Enable selection of multiple tables box, and select all 

the tables. Then click OK.  

 
 

5. The Import Data window appears.  

Select the PivotTable Report option, which imports the tables into Excel and prepares a 

PivotTable for analyzing the imported tables, and click OK. 
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6. Once the data is imported, a PivotTable is created using the imported tables.  

 
With the data imported into Excel, and the Data Model automatically created, you’re ready to 

explore the data. 
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Understanding Different File Formats Supported by Excel 
Understanding different file formats supported by Excel is crucial for efficient data import and 

export. Excel provides support for a variety of file formats, each with its own unique 

characteristics and advantages. Acquiring an understanding of these formats will enable you to 

seamlessly work with diverse data sources. 

 

 

 

 

Below is a summary table of the file formats that Excel supports: 

Considering both the file format and the purpose of import or export, it is essential to select the 

appropriate format to ensure compatibility and data integrity. Additionally, it is important to stay 

updated with the latest features and enhancements of Excel in order to fully leverage its 

capabilities and effectively manage different file formats.  

File Format Description 

CSV A file format called Comma-Separated Values, commonly used for data interchange. 

Text A plain-text file that stores data in a straightforward format. 

Databases 
Enables you to connect to and import data from different database management 

systems. 

Web Sources 
Allows importing data from websites through web queries or by connecting to web 

services. 

PDF 
Permits exporting data to a portable document format that is widely used for sharing 

and preserving document integrity. 

Other File 

Formats 
Excel supports numerous other file formats, including XLSX, XLS, XML, and more. 
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Importing Data from Text Files 
When importing data from text files into Excel, follow these steps: 

1. Open Excel and create a new workbook. 

2. Click on the “File” tab and select “Open” to open the file you want to import. 

3. In the “Open” dialog box, locate and select the text file you want to import. 

4. Click on the “Open” button. 

5. Excel will display the Text Import Wizard. Select the appropriate options for your text file, 

such as the file origin, delimiter, and text format. 

6. Preview the data to ensure it is correctly formatted. 

7. Click on the “Load” button to import the data into Excel. 

By following these steps, you can easily import data from text files into Excel for further analysis 

and manipulation. 
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Importing Data from Databases 
Importing Data from Databases is a crucial task for professionals who need to analyze and 

manipulate large datasets. Here is a table with different approaches to Importing Data from 

Databases: 

 
To ensure smooth Importing Data from Databases, verify that the database credentials are correct, 

and test the import process with a sample dataset. Remember to properly format the imported 

data in Excel to ensure it aligns with your analysis needs. 
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Importing Data from Web Sources 
1. Importing data from web sources is a valuable method to gather information for analysis in 

Excel, making it essential to know how to incorporate the keywords “Importing Data from 

Web Sources” in the given text. 

2. When it comes to importing data from web sources, there are several steps to consider: 

3. Identify the data source: Begin by determining the website or webpage that contains the 

information you need to import into Excel. 

4. Access the data: To input the URL of the webpage, utilize the “From Web” option found in 

the Data tab of the Excel ribbon. 

5. Select and preview the data: Excel will generate a preview of the data on the webpage, 

allowing you to choose the specific data elements you wish to import. 

6. Specify import settings: Customize the way the data is imported by utilizing options such 

as data type, delimiter, headers, and more. 

7. Refresh and update: It is crucial to regularly refresh the imported data to ensure it 

remains up-to-date. This can be performed manually or automatically at regular intervals. 

By effectively following these steps, you can effortlessly import data from web sources into Excel, 

enabling analysis and manipulation of the data. 
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Chapter X 
 

What’s New & Overlooked in Excel? 
 

Do you now consider yourself an Excel expert? While you may definitely be much more 

comfortable using Excel than prior to this course, there are still many features that while a bit 

obscure, might be the solution to your data analysis problem. Challenge yourself to continue to 

advance your Excel skills and keep up to date on new features as they get released.  

 

One of the hottest topics in technology in modern times is the proliferation of artificial intelligence 

(AI) functionality in our daily lives. Excel has utilized elements of AI for several years, and the 

latest releases continue to integrate AI throughout Excel and other Microsoft applications.  

 
In the realm of Excel, artificial intelligence is about utilizing advanced algorithms and machine 

learning techniques to automate data analysis, reduce errors, and improve efficiency. AI in Excel 

enables the software to understand complex patterns in data, make predictions, and suggest 

optimized solutions. While one could simply ask Copilot or another generative-AI tool to deduce 

which AI features exist in Excel, it may be easier to read this short summary. 
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Artificial Intelligence in Excel 
Some introductory artificial intelligence 

functionality has been in Excel for years. For 

example, when inserting a chart, Excel will 

provide a suggestion of appropriate charts 

based on your data. Recommended Charts 

and Recommended PivotTables are 

examples of AI because they use algorithms to 

analyze the data you select and suggests the 

most suitable chart type for effectively 

visualizing that data. By understanding the 

data’s nature and relationships, the AI 

identifies patterns and trends, recommending 

the chart that best communicates the insights 

in a meaningful way.  

 

Excel data entry AI is a game changer regarding data input as it saves time and reduces the chance 

of errors. This is facilitated through functionality that replaces human data entry with machine 

learning features like AutoComplete, AutoCorrect, AutoFill or Flash Fill, which works by 

recognizing patterns of filled data and filling out the rest.  Try using AutoFill by typing Sunday in 

one cell, then type Monday in the next cell. Select the 

two cells and drag the fill handle to see Excel’s artificial 

intelligence fill the neighboring cell with “Tuesday”.  

Usually Flash Fill starts automatically, and you only 

need to provide a pattern.  

1. Insert a new column adjacent to the column with 

your source data. 

2. In the first cell of a newly added column, type the 

desired value. 

3. Start typing in the next cell, and if Excel senses a 

pattern, it will show a preview of data to be auto 

filled in the cells below. 

4. Press the Enter key to accept the preview.  

 

 

 

  

If Excel doesn’t identify a pattern, 

click the Flash Fill button to complete 

the pattern. 
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Another AI data entry feature is the Insert Data from Picture feature which allows users to insert 

data from a screen capture on their clipboard, or an image file from their computer. One can even 

screen capture a table from a web site and convert the picture into Excel data. Copying data from 

websites into Excel will never be the same! Try it below! 

 

Import data from a sample image file or clipboard   Right-click the following image and "Save 

image as..." a local copy, then click Data > From Picture > Picture From File …. (or 

Clipboard) and follow the on-screen instructions to convert the picture to data. 

 
 

 

Analyze Data in Excel (formerly known as Ideas) empowers users to understand their data 

through natural language queries that allow users to ask questions about their data 

without having to write complicated formulas. In addition, Analyze Data provides 

high-level visual summaries, trends, and patterns. Simply select a cell in a data range 

> select the Analyze Data button on the Home tab. Analyze Data in Excel will 

analyze your data and return interesting visuals about it in a task pane. 

 

Linked data types connect to reputable sources of data, such as Bing, Power BI and more, so 

users can access information about a variety of subjects without ever leaving Excel. Real-time 

stock quote integration, geography and currencies are three new data types that use AI to connect 

to online data in return real-time data into Excel for further analysis. To get current data for the 

data types, right-click a cell with the linked data type and select Data Type > Refresh. That will 

refresh the selected cell, plus any other cells that have that same data type. 

 

Without artificial intelligence, users must write a formula for every value they want. However, the 

AI dynamic arrays feature allows users to write a formula, hit the enter key, and immediately see 

an array of values. Using dynamic arrays, any formula that returns an array of values will 

seamlessly “spill” into neighboring unoccupied cells, making it as easy to get an array of values 

returned as it is to work on a single cell. Users can immediately harness the power of dynamic 
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arrays by using one of the new FILTER, UNIQUE, SORT, SORTBY, SEQUENCE, SINGLE, and 

RANDARRAY functions to build spreadsheets that would previously have been nearly impossible.  

Several AI functions began appearing in some versions of Excel 365 for Windows in 2024. If you 

have the right Excel, try typing =ai in the formula bar, and if the AI functions are available you’ll 

see something like this. 

 
One might be surprised to see the reference to OpenIA in the screentip! The current version of 

Excel utilizes the OpenAI server/API to connect the AI functionality to their data. This might be a 

short-term solution until a complete Microsoft Copilot solution is released.  

Current AI functionality in Excel requires add-on functionality to be installed, such as the ChatGPT 

for Excel add-in which introduces five key AI functions — AI.ASK, AI.FILL, AI.TABLE, AI.EXTRACT, 

and AI.TRANSLATE.  

 
 

 

The AI.ASK function allows users to query their data in natural language. 

This simplifies complex data analysis by interpreting questions and 

providing answers directly within Excel. It can be used to write text, 

summarize, analyze data, and more—like having a virtual assistant inside 

Excel! It’s Clippy on Steroids!  
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 For example, the formula: 

                  =AI.ASK("Identify the highest selling model of Ford vehicles in 2024") 

will return the result: 

As of 2024, the highest selling model of Ford vehicles is the Ford F-Series, 

particularly the Ford F-150. The F-Series has consistently been one of the best-

selling vehicle lines in the United States for many years, and it continues to 

dominate the market in 2024. 

 

Copilot in Excel 
The future of artificial intelligence integration in Excel rests with Microsoft’s Copilot functionality, 

which was released in late 2024, but might not be live for all Excel users right away. Web versions 

of Excel are more likely to reveal AI functionality before the desktop version licenses are updated.  

Copilot in Excel is built into your workbook, enabling users to iterate with it quickly and easily. 

This integration allows users to continually prompt as they work, making it feel like users have an 

Excel expert right by their side. Copilot in Excel can help you go from a blank page to a finished 

document in a fraction of the time it would take to compose text on your own. Copilot can now 

reason over structured data, not just tables, and it can complete tasks such as adding filters or 

splitting text. It can respond to prompts to help users analyze data trends. For example, in the 

following illustration, a prompt was asked to determine “How many different “Dealership” are 

there (in the worksheet)?  

 
The result returned was: 
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Another prompt asked, “Which Salesperson has the most sales?”   The result returned was: 

 
While a user could write formulas with functions to extrapolate similar answers, the Copilot 

prompting functionality generated answers in a fraction of the time! 

In addition to answering prompts, Copilot can identify insights, generate formulas, highlight, sort 

& filter, as well as advanced functionality such as helping to write Python code, and provide text 

insights to streamline and enhance data interpretation. With AI-powered features, Excel users can 

now analyze large datasets, identify trends, and make informed decisions more efficiently. 

 

Solver 
 

The Solver tool is an add-in program available in Excel that allows users to perform additional 

what-if analysis, by altering different variables in a spreadsheet in order find an optimal 

(maximum or minimum) value for a formula in one cell — called the objective cell — subject to 

constraints, or limits, on the values of other formula cells on a worksheet.  For example, what is 

the minimum number of sales you’d need to make to cover the cost of an expensive piece of 

business equipment? 
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Solver has three parts to it—a target value, variables that it can change to reach that value, and 

constraints that Solver has to work in.  Solver adjusts the values in the variable cells to satisfy the 

limits on constraint cells and produce the result you want for the objective cell.  

 

To install Solver, go to File > Options and in the Excel Options window choose the Solver Add-in. If 

necessary, select Excel 

add-ins from 

the Manage drop-down 

menu at the bottom of the 

window, then press 

the Go button. In the Add-

ins window, mark the 

checkbox next to Solver 

Add-in and click OK. The 

Solver option should appear in an Analysis group under the Data tab. 

 

Let’s use Solver to determine a common staffing scheduling dilemma. You manage a small 
business and need to determine the optimal hours per week to schedule each employee given a 
set of constraints.  Open the following worksheet (try using the Insert Data From Picture feature) 
and study the formulas in column D & F.  
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Consider the following constraints: 

• Ensure that no employee works more than 40 hours per week. 
• Fractional cakes are not acceptable. 

 

1. Select the range B9:F9 and click the AutoSum button.  
2. Select cell D9 and use the 

Solver feature to determine 
how many hours each 
employee needs to work to 
produce at least 750 cakes 
in a week.  (Current output 
is barely 600 cakes) 

3. In the Solver window that 
opens, add the objective, 
variables and constraints as 
shown below. 

 
4. Choose Solve. The Solver 

Results window should 

eventually display… 
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5.  

 
6. Choose the Keep Solver Solution option and click OK. Your updated spreadsheet should 

now display the solution to your scheduling dilemma. 
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Power3 – Oh, so much power!!! 

Power BI, Power Query, and Power Pivot are powerful 

business intelligence tools developed by Microsoft that 

allow users to connect, transform, and analyze data from 

various sources to create compelling visualizations, 

reports, and dashboards. While they all help manage 

data, there are key differences between these solutions.  

 

Power BI, Microsoft’s business intelligence tool, enables 

users to transform raw data into operable insights. 

Power BI focuses on data visualization and reporting, 

while Excel is better for detailed analysis and financial 

modeling. Power BI and Excel both have Power Query for gathering/combining and 

transformation of data, however power BI lets users connect to more data sources (such as Google 

sheets). Both Power Query and Power Pivot are part of the Power BI cloud-based business 

analytics service. Power BI strengths over regular Excel are in its visualizations. Visualizations is 

the name assigned to the charts, slicers, tables and matrixes that users can insert into their reports 

in Power BI. Power BI has a greater choice of visualizations than Excel, and lots of options for how 

they interact with the other visualizations on a page, or even across the entire report. 

 

Power Query 
Power Query is a data extraction, loading and transformation tool used for business intelligence. 

With Power Query (known as Get & Transform in Excel), users can import 

or connect to external data, and then shape that data. For example, a user 

can remove a column, change a data type, or merge tables, in ways that meet 

their needs. Then, the user can load their query into Excel to create charts 

and reports. Periodically, the user can refresh the data to make it up to 

date.  In Excel, select the Data tab on the ribbon to see the Get & Transform Data and Queries & 

Connections groups. 

 

After importing and refreshing data from a wide variety of data sources, users can then shape the 

data in a step-by-step transformation that gradually creates a unique, tabular shape to fit the 

user’s data analysis needs. For users who perform repetitive data transformation tasks or struggle 

to organize and analyze their data, Power Query might be a great solution.  
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Power Pivot 
Power Pivot is used to model data and perform 

more complex calculations than Excel can handle. 

Power Pivot is great when working with huge data 

sets. Once Power Query has imported and cleaned 

the various data sources, Power Pivot is used to 

establish relationships between the 

tables/queries. Using DAX (Data Analysis 

Expressions), the formula language of Power Pivot, users can create more powerful calculations 

and more sophisticated data models than they can in Excel alone. 

 

Power Query can prepare simple but large datasets for analysis. Power Pivot, on the other hand, is 

for more complex models and more powerful calculations than Excel worksheet functions or 

PivotTables alone. Conversely, while Power Pivot contains features for importing and shaping 

data, it is recommended to leave this job to Power Query. Use both to shape your data in Excel so 

you can explore and visualize it in PivotTables, PivotCharts, and Power BI. 

 

  

1 The Power Pivot option on the Data ribbon 
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3-D References  
 

An Excel cell reference that refers to the same cell 

or range on multiple sheets is called a 3-D 

reference. A 3-D reference, sometimes referred to 

as 3-D formula, is a useful and convenient way to 

reference several worksheets that follow the same 

pattern and contain the same type of data—such 

as when a user consolidates budget data from 

different departments in their organization.   

 

3-D references work brilliantly when a user 

desires to consolidate data into a summary sheet. 

For example, monthly sales data can be entered on 

separate sheets, then consolidated via 3-D formulas on a summary sheet that reference each 

monthly sheet.  

 

Creating a 3D reference is straightforward once you understand the structure of your workbook. 

Here's a simple guide to setting up a 3D reference: 

 

1. Identify the Range: Determine which cell or range of cells you want to reference. Make 

sure this cell or range is consistently used across all worksheets for accurate results. 

2. Initiate the Formula: Click on the cell where you want to display the result of your 

calculation. Begin typing the formula that will incorporate the 3D reference, such 

as =SUM( or =AVERAGE(. 

3. Select the Worksheet Range: While still in the formula bar, click on the first worksheet 

tab that you want to include in the reference. Then hold down the Shift key and click on the 

last worksheet tab to include. This action selects all worksheets between and including the 

first and last tabs clicked. 

4. Complete the Reference: After selecting the worksheets, select the cell or range of cells in 
the formula bar that you wish to calculate across the selected sheets. For example, if 

calculating the sum of values in cell B3 across sheets "Jan" to "Dec", the completed formula 

would look like =SUM(Jan:Dec!B3). 

5. Enter and Apply: Press Enter to complete the formula. Excel will now calculate the sum, 

average, or other aggregate measures of the cell or range across the selected worksheets. 
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In the workbooks below, a small business has monthly expenses in separate worksheets (Jan, Feb, 

Mar) that the manager would like to aggregate into a summary sheet, named Q1. Each sheet has 

the identical structure, but many of the cells that represent variable expenses, differ from month-

to-month, while other fixed expenses stay consistent from month-to-month. The Q1 sheet below is 

ready for some 3-D references to consolidate data from sheets Jan, Feb, and Mar. 

 

In cell B4 of the Q1 sheet the following formula will be inserted: =SUM(Jan:Mar!B4) 

 

After using AutoFill to copy the formulas to the 

rest of columns B:F and rows 4:12, the Q1 

worksheet now appears on the right.  Any changes 

to the data in the Jan, Feb or Mar sheets will be 

reflected in the Q1 sheet.  

 

3-D references are a powerful feature in Excel that 

allow for dynamic data management and analysis 

across multiple worksheets. By learning how to 

create and manage these references, users can 

significantly streamline their workflow, ensuring 

that their calculations are both efficient and 

accurate.  
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